aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libbonoboui/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-18 16:05:23 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-18 16:05:23 +0000
commit401ab0f9659188c7eb6d1da3540734e458e021b6 (patch)
tree3e4327652dd0c0f0b8e90ffa2c0b52af344f3817 /x11-toolkits/libbonoboui/Makefile
parente7b985a6bfc8bacb9a52afd466c13442ca827537 (diff)
downloadports-401ab0f9659188c7eb6d1da3540734e458e021b6.tar.gz
ports-401ab0f9659188c7eb6d1da3540734e458e021b6.zip
Notes
Diffstat (limited to 'x11-toolkits/libbonoboui/Makefile')
-rw-r--r--x11-toolkits/libbonoboui/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11-toolkits/libbonoboui/Makefile b/x11-toolkits/libbonoboui/Makefile
index c1393c63777c..6094b903c7bb 100644
--- a/x11-toolkits/libbonoboui/Makefile
+++ b/x11-toolkits/libbonoboui/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= gnomecanvas-2.0:${PORTSDIR}/graphics/libgnomecanvas \
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
@@ -29,8 +30,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
- @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
- 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
- s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
+ @find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
+ s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
.include <bsd.port.mk>