aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libbonobouimm/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-15 23:07:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-15 23:07:28 +0000
commit098bc24e38120f9a170019dd2f3c991fb979ca14 (patch)
tree8b025ddfec895feb38a9b4a0a71e65a99045d82b /x11-toolkits/libbonobouimm/Makefile
parentd33505b24fee259d56e98bcc223813e060562b53 (diff)
downloadports-098bc24e38120f9a170019dd2f3c991fb979ca14.tar.gz
ports-098bc24e38120f9a170019dd2f3c991fb979ca14.zip
Notes
Diffstat (limited to 'x11-toolkits/libbonobouimm/Makefile')
-rw-r--r--x11-toolkits/libbonobouimm/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-toolkits/libbonobouimm/Makefile b/x11-toolkits/libbonobouimm/Makefile
new file mode 100644
index 000000000000..6f3a7f081b80
--- /dev/null
+++ b/x11-toolkits/libbonobouimm/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libbonobouimm
+# Date created: 22 May 2003
+# Whom: Alexander Nedotsukov <bland@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbonobouimm
+PORTVERSION= 1.3.5
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtkmm
+DIST_SUBDIR= gnome2
+
+MAINTAINER= bland@mail.ru
+COMMENT= C++ interfaces for libbonoboui
+
+LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2 \
+ bonobomm_servers-1.3:${PORTSDIR}/devel/libbonobomm
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= libbonoboui
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-static
+
+.include <bsd.port.mk>