aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgail-gnome/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-12 20:00:44 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-12 20:00:44 +0000
commita83ef1ea07bdd842a4c4163d1500b1b5c832e24f (patch)
treeb1900c21c3acec95b34cf123247526361ddaf109 /x11-toolkits/libgail-gnome/Makefile
parentac5eadfcc776c1042782d686bd02aee1c7c13907 (diff)
downloadports-a83ef1ea07bdd842a4c4163d1500b1b5c832e24f.tar.gz
ports-a83ef1ea07bdd842a4c4163d1500b1b5c832e24f.zip
Notes
Diffstat (limited to 'x11-toolkits/libgail-gnome/Makefile')
-rw-r--r--x11-toolkits/libgail-gnome/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-toolkits/libgail-gnome/Makefile b/x11-toolkits/libgail-gnome/Makefile
new file mode 100644
index 000000000000..7c3efc48f874
--- /dev/null
+++ b/x11-toolkits/libgail-gnome/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: libgail-gnome
+# Date Created: 12 April 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgail-gnome
+PORTVERSION= 0.5.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui \
+ spi.0:${PORTSDIR}/x11-toolkits/at-spi
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc \
+ --enable-static
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
+ s|\$\(libdir\)/bonobo/servers|\$\(prefix\)/libdata/bonobo/servers|g'
+
+.include <bsd.port.mk>