aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgdiplus/Makefile
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 08:09:44 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 08:09:44 +0000
commit0f5f09ee5d0899a6f5c5f46f75b35032664df6d2 (patch)
treed7f9d6293d7ac62888c51c5b4d05126ad731f8d1 /x11-toolkits/libgdiplus/Makefile
parentac497234dfd4eb3747a4dcb6726fecc9cb8ff010 (diff)
Notes
Diffstat (limited to 'x11-toolkits/libgdiplus/Makefile')
-rw-r--r--x11-toolkits/libgdiplus/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
new file mode 100644
index 000000000000..a9729aa4bee3
--- /dev/null
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libgdiplus
+# Date created: 20040820
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.24 2006/02/05 03:07:29 tmclau02 Exp $
+#
+
+PORTNAME= libgdiplus
+PORTVERSION= 1.1.13.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.go-mono.com/sources/libgdiplus-1.1/
+
+MAINTAINER= bsd-sharp-list@forge.novell.com
+COMMENT= GDI+ API for System.Windows.Forms in Mono
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ png.5:${PORTSDIR}/graphics/png
+
+USE_GNOME= gnomehack gnometarget glib20
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+LIBTOOLFILES= configure cairo/configure
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+# Included cairo does not work for us. Enable below when Mono catches
+# up with our port. For now, use included but patch out glitz manually.
+#CONFIGURE_ARGS+= --with-cairo=installed
+
+.include <bsd.port.mk>