aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgdiplus/Makefile
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-07-28 18:02:39 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-07-28 18:02:39 +0000
commite820a0e3a8e322f10127e33d7d0a2bdaadbee50b (patch)
treecbd3c8d62677c80b4aeb2a4fec686fcfca55f41e /x11-toolkits/libgdiplus/Makefile
parent5a4055b083de196c29e003b0fe31916528bbdbef (diff)
Notes
Diffstat (limited to 'x11-toolkits/libgdiplus/Makefile')
-rw-r--r--x11-toolkits/libgdiplus/Makefile31
1 files changed, 9 insertions, 22 deletions
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index a14b54e9af17..65ec6adedb3f 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -3,11 +3,10 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.46 2007/12/13 19:37:18 killfill Exp $
#
PORTNAME= libgdiplus
-PORTVERSION= 2.6.4
+PORTVERSION= 2.6.7
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
@@ -18,32 +17,20 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
ungif.5:${PORTSDIR}/graphics/libungif \
png.6:${PORTSDIR}/graphics/png
+GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget glib20
USE_GMAKE= yes
USE_XLIB= yes
-USE_LDCONFIG= yes
-LIBTOOLFILES= configure cairo/configure
-USE_AUTOTOOLS= libtool:22
+USE_LDCONFIG= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-# Included cairo does not work for us. Enable below when Mono catches
-# up with our port. For now, use included but patch out glitz manually.
-#CONFIGURE_ARGS+= --with-cairo=installed
-CPPFLAGS+= -DPNG_DEPSTRUCT=
-post-patch:
- ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/cairo/src/cairo-png.c
- ${REINPLACE_CMD} -e 's|libpng12|libpng14|' \
- ${WRKSRC}/configure
-
-.include <bsd.port.pre.mk>
-
-# Avoid build error on 64-bit architectures
-.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
-CFLAGS+= -fPIC
-.endif
+PLIST_FILES= lib/libgdiplus.a \
+ lib/libgdiplus.la \
+ lib/libgdiplus.so \
+ lib/libgdiplus.so.0 \
+ libdata/pkgconfig/libgdiplus.pc
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>