aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgdiplus
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 08:09:44 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-02-19 08:09:44 +0000
commit0f5f09ee5d0899a6f5c5f46f75b35032664df6d2 (patch)
treed7f9d6293d7ac62888c51c5b4d05126ad731f8d1 /x11-toolkits/libgdiplus
parentac497234dfd4eb3747a4dcb6726fecc9cb8ff010 (diff)
Notes
Diffstat (limited to 'x11-toolkits/libgdiplus')
-rw-r--r--x11-toolkits/libgdiplus/Makefile33
-rw-r--r--x11-toolkits/libgdiplus/distinfo3
-rw-r--r--x11-toolkits/libgdiplus/files/patch-cairo_src_cairo-ft-font.c28
-rw-r--r--x11-toolkits/libgdiplus/pkg-descr3
-rw-r--r--x11-toolkits/libgdiplus/pkg-plist4
5 files changed, 71 insertions, 0 deletions
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
new file mode 100644
index 000000000000..a9729aa4bee3
--- /dev/null
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libgdiplus
+# Date created: 20040820
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.24 2006/02/05 03:07:29 tmclau02 Exp $
+#
+
+PORTNAME= libgdiplus
+PORTVERSION= 1.1.13.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.go-mono.com/sources/libgdiplus-1.1/
+
+MAINTAINER= bsd-sharp-list@forge.novell.com
+COMMENT= GDI+ API for System.Windows.Forms in Mono
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ png.5:${PORTSDIR}/graphics/png
+
+USE_GNOME= gnomehack gnometarget glib20
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+LIBTOOLFILES= configure cairo/configure
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+# Included cairo does not work for us. Enable below when Mono catches
+# up with our port. For now, use included but patch out glitz manually.
+#CONFIGURE_ARGS+= --with-cairo=installed
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/libgdiplus/distinfo b/x11-toolkits/libgdiplus/distinfo
new file mode 100644
index 000000000000..c47d57c33c91
--- /dev/null
+++ b/x11-toolkits/libgdiplus/distinfo
@@ -0,0 +1,3 @@
+MD5 (libgdiplus-1.1.13.2.tar.gz) = 97da26e08454a08e64c3936800efdfa5
+SHA256 (libgdiplus-1.1.13.2.tar.gz) = 3da0ebbb1b9957cb3c372cf83932bbf21e6f8ba1ecd176ac811b3230fea4e1e6
+SIZE (libgdiplus-1.1.13.2.tar.gz) = 1260230
diff --git a/x11-toolkits/libgdiplus/files/patch-cairo_src_cairo-ft-font.c b/x11-toolkits/libgdiplus/files/patch-cairo_src_cairo-ft-font.c
new file mode 100644
index 000000000000..be7d74f47b24
--- /dev/null
+++ b/x11-toolkits/libgdiplus/files/patch-cairo_src_cairo-ft-font.c
@@ -0,0 +1,28 @@
+--- cairo/src/cairo-ft-font.c.orig Mon Aug 29 14:11:27 2005
++++ cairo/src/cairo-ft-font.c Sun Sep 11 00:44:30 2005
+@@ -44,6 +44,11 @@
+ #include <fontconfig/fontconfig.h>
+ #include <fontconfig/fcfreetype.h>
+
++#include <sys/types.h>
++#include <stdlib.h>
++#include <time.h>
++#include <unistd.h>
++
+ #include <ft2build.h>
+ #include FT_FREETYPE_H
+ #include FT_OUTLINE_H
+@@ -278,7 +283,12 @@
+ key->id = id;
+
+ /* 1607 is just an arbitrary prime. */
+- hash = _cairo_hash_string (filename);
++ if (filename != NULL) {
++ hash = _cairo_hash_string (filename);
++ } else {
++ srandom(time(NULL) * getpid());
++ hash = random();
++ }
+ hash += ((unsigned long) id) * 1607;
+
+ key->base.hash_entry.hash = hash;
diff --git a/x11-toolkits/libgdiplus/pkg-descr b/x11-toolkits/libgdiplus/pkg-descr
new file mode 100644
index 000000000000..28d73cdb2e52
--- /dev/null
+++ b/x11-toolkits/libgdiplus/pkg-descr
@@ -0,0 +1,3 @@
+libgdiplus is an Open Source implementation of the GDI+ API.
+
+WWW: http://www.mono-project.com
diff --git a/x11-toolkits/libgdiplus/pkg-plist b/x11-toolkits/libgdiplus/pkg-plist
new file mode 100644
index 000000000000..d99388881552
--- /dev/null
+++ b/x11-toolkits/libgdiplus/pkg-plist
@@ -0,0 +1,4 @@
+lib/libgdiplus.a
+lib/libgdiplus.so
+lib/libgdiplus.so.0
+libdata/pkgconfig/libgdiplus.pc