aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgdiplus
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2010-07-28 18:02:39 +0000
committerRomain Tartière <romain@FreeBSD.org>2010-07-28 18:02:39 +0000
commite820a0e3a8e322f10127e33d7d0a2bdaadbee50b (patch)
treecbd3c8d62677c80b4aeb2a4fec686fcfca55f41e /x11-toolkits/libgdiplus
parent5a4055b083de196c29e003b0fe31916528bbdbef (diff)
downloadports-e820a0e3a8e322f10127e33d7d0a2bdaadbee50b.tar.gz
ports-e820a0e3a8e322f10127e33d7d0a2bdaadbee50b.zip
Notes
Diffstat (limited to 'x11-toolkits/libgdiplus')
-rw-r--r--x11-toolkits/libgdiplus/Makefile31
-rw-r--r--x11-toolkits/libgdiplus/distinfo6
-rw-r--r--x11-toolkits/libgdiplus/files/patch-cairo_src_cairo-ft-font.c28
-rw-r--r--x11-toolkits/libgdiplus/pkg-plist5
4 files changed, 12 insertions, 58 deletions
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index a14b54e9af17..65ec6adedb3f 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -3,11 +3,10 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.46 2007/12/13 19:37:18 killfill Exp $
#
PORTNAME= libgdiplus
-PORTVERSION= 2.6.4
+PORTVERSION= 2.6.7
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
@@ -18,32 +17,20 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
ungif.5:${PORTSDIR}/graphics/libungif \
png.6:${PORTSDIR}/graphics/png
+GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget glib20
USE_GMAKE= yes
USE_XLIB= yes
-USE_LDCONFIG= yes
-LIBTOOLFILES= configure cairo/configure
-USE_AUTOTOOLS= libtool:22
+USE_LDCONFIG= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
-# Included cairo does not work for us. Enable below when Mono catches
-# up with our port. For now, use included but patch out glitz manually.
-#CONFIGURE_ARGS+= --with-cairo=installed
-CPPFLAGS+= -DPNG_DEPSTRUCT=
-post-patch:
- ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/cairo/src/cairo-png.c
- ${REINPLACE_CMD} -e 's|libpng12|libpng14|' \
- ${WRKSRC}/configure
-
-.include <bsd.port.pre.mk>
-
-# Avoid build error on 64-bit architectures
-.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
-CFLAGS+= -fPIC
-.endif
+PLIST_FILES= lib/libgdiplus.a \
+ lib/libgdiplus.la \
+ lib/libgdiplus.so \
+ lib/libgdiplus.so.0 \
+ libdata/pkgconfig/libgdiplus.pc
.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/libgdiplus/distinfo b/x11-toolkits/libgdiplus/distinfo
index 72832a668ca7..eab36d7ea57e 100644
--- a/x11-toolkits/libgdiplus/distinfo
+++ b/x11-toolkits/libgdiplus/distinfo
@@ -1,3 +1,3 @@
-MD5 (libgdiplus-2.6.4.tar.bz2) = d860cfca4c13fbbaa054077eda3ab97b
-SHA256 (libgdiplus-2.6.4.tar.bz2) = 0f750f7f6696c329b4209230d355599cbf47570b4f899777e5ecb5fccc884833
-SIZE (libgdiplus-2.6.4.tar.bz2) = 1959635
+MD5 (libgdiplus-2.6.7.tar.bz2) = 6448c2dd9a63ccdd69cb305e0ce4d40b
+SHA256 (libgdiplus-2.6.7.tar.bz2) = 7ebe427d6486cdab56fb6715e2d14a484e8ffe5cb6f183e133abca7d4f8f7144
+SIZE (libgdiplus-2.6.7.tar.bz2) = 1960822
diff --git a/x11-toolkits/libgdiplus/files/patch-cairo_src_cairo-ft-font.c b/x11-toolkits/libgdiplus/files/patch-cairo_src_cairo-ft-font.c
deleted file mode 100644
index be7d74f47b24..000000000000
--- a/x11-toolkits/libgdiplus/files/patch-cairo_src_cairo-ft-font.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- cairo/src/cairo-ft-font.c.orig Mon Aug 29 14:11:27 2005
-+++ cairo/src/cairo-ft-font.c Sun Sep 11 00:44:30 2005
-@@ -44,6 +44,11 @@
- #include <fontconfig/fontconfig.h>
- #include <fontconfig/fcfreetype.h>
-
-+#include <sys/types.h>
-+#include <stdlib.h>
-+#include <time.h>
-+#include <unistd.h>
-+
- #include <ft2build.h>
- #include FT_FREETYPE_H
- #include FT_OUTLINE_H
-@@ -278,7 +283,12 @@
- key->id = id;
-
- /* 1607 is just an arbitrary prime. */
-- hash = _cairo_hash_string (filename);
-+ if (filename != NULL) {
-+ hash = _cairo_hash_string (filename);
-+ } else {
-+ srandom(time(NULL) * getpid());
-+ hash = random();
-+ }
- hash += ((unsigned long) id) * 1607;
-
- key->base.hash_entry.hash = hash;
diff --git a/x11-toolkits/libgdiplus/pkg-plist b/x11-toolkits/libgdiplus/pkg-plist
deleted file mode 100644
index 2ee543daf3d3..000000000000
--- a/x11-toolkits/libgdiplus/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-lib/libgdiplus.a
-lib/libgdiplus.la
-lib/libgdiplus.so
-lib/libgdiplus.so.0
-libdata/pkgconfig/libgdiplus.pc