aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgnomeprintuimm/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 11:37:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 11:37:13 +0000
commit62678d3fc1c8b3d7e63d1923f2aca85558015378 (patch)
treec107e0a44c54efd02662087c961e84bd267680c0 /x11-toolkits/libgnomeprintuimm/Makefile
parentaff220824b5c223cb0cca10423c5fa86b3ae641e (diff)
downloadports-62678d3fc1c8b3d7e63d1923f2aca85558015378.tar.gz
ports-62678d3fc1c8b3d7e63d1923f2aca85558015378.zip
Notes
Diffstat (limited to 'x11-toolkits/libgnomeprintuimm/Makefile')
-rw-r--r--x11-toolkits/libgnomeprintuimm/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-toolkits/libgnomeprintuimm/Makefile b/x11-toolkits/libgnomeprintuimm/Makefile
new file mode 100644
index 000000000000..3ee5e140fe52
--- /dev/null
+++ b/x11-toolkits/libgnomeprintuimm/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: libgnomeprintuimm
+# Date created: 17 December 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgnomeprintuimm
+PORTVERSION= 2.5.2
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.5
+DIST_SUBDIR= gnome2
+
+MAINTAINER= bland@FreeBSD.org
+COMMENT= C++ wrappers for the GNOME print support library
+
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ gnomeprintmm-2.5.2:${PORTSDIR}/print/libgnomeprintmm
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack libgnomeprintui
+USE_GCC= 3.4
+INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
+USE_INC_LIBTOOL_VER=15
+CONFIGURE_ARGS= --enable-static
+
+PLIST_SUB= VERSION="2.5" API_VERSION="2.6"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|2\.0|2.6|' ${WRKSRC}/tools/m4/Makefile.in
+
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
+.include <bsd.port.mk>