aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgnomeui/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-08 21:05:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-08 21:05:28 +0000
commit2c099c38b27f917b4b63a20d2faa2bdc712b5a00 (patch)
treefb24908bbec8dcbad19e831701529ca16076f003 /x11-toolkits/libgnomeui/Makefile
parent94472178617a67889b0c1030cff239b50e4c823a (diff)
downloadports-2c099c38b27f917b4b63a20d2faa2bdc712b5a00.tar.gz
ports-2c099c38b27f917b4b63a20d2faa2bdc712b5a00.zip
Notes
Diffstat (limited to 'x11-toolkits/libgnomeui/Makefile')
-rw-r--r--x11-toolkits/libgnomeui/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-toolkits/libgnomeui/Makefile b/x11-toolkits/libgnomeui/Makefile
new file mode 100644
index 000000000000..a7297a3bbd5e
--- /dev/null
+++ b/x11-toolkits/libgnomeui/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: libgnomeui
+# Date created: 07 April 2002
+# Whom: Joe Marcus Clarke <marcus@FreBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgnomeui
+PORTVERSION= 1.114.0
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-beta3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS+= libbonoboui-2.0:${PORTSDIR}/x11-toolkits/libbonoboui
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_XPM= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+USE_BISON= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-html-dir=${PREFIX}/share/doc \
+ --disable-gtk-doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g ; \
+ s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+
+.include <bsd.port.mk>