aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgnomeui
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-08-01 02:06:55 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-08-01 02:06:55 +0000
commit81427aba51e2920b9fe3e14cb38cba3657039a50 (patch)
treec1cd66d96b518a228aef90e868075e409dd514de /x11-toolkits/libgnomeui
parentca004105109784a2081420986ee38eb16ff5ec59 (diff)
downloadports-81427aba51e2920b9fe3e14cb38cba3657039a50.tar.gz
ports-81427aba51e2920b9fe3e14cb38cba3657039a50.zip
Notes
Diffstat (limited to 'x11-toolkits/libgnomeui')
-rw-r--r--x11-toolkits/libgnomeui/Makefile1
-rw-r--r--x11-toolkits/libgnomeui/files/patch-libgnomeui_gnome-authentication-manager.c30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-toolkits/libgnomeui/Makefile b/x11-toolkits/libgnomeui/Makefile
index 3794996458ae..89ecfea12e81 100644
--- a/x11-toolkits/libgnomeui/Makefile
+++ b/x11-toolkits/libgnomeui/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libgnomeui
PORTVERSION= 2.10.1
+PORTREVISION= 1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.10
diff --git a/x11-toolkits/libgnomeui/files/patch-libgnomeui_gnome-authentication-manager.c b/x11-toolkits/libgnomeui/files/patch-libgnomeui_gnome-authentication-manager.c
new file mode 100644
index 000000000000..99990e1b9f63
--- /dev/null
+++ b/x11-toolkits/libgnomeui/files/patch-libgnomeui_gnome-authentication-manager.c
@@ -0,0 +1,30 @@
+--- libgnomeui/gnome-authentication-manager.c.orig Mon Aug 1 03:34:03 2005
++++ libgnomeui/gnome-authentication-manager.c Mon Aug 1 03:36:29 2005
+@@ -849,7 +849,11 @@
+ info->response = response;
+ info->response_data = response_data;
+
++ GDK_THREADS_ENTER ();
++
+ present_question_dialog_nonblocking (info);
++
++ GDK_THREADS_LEAVE ();
+ }
+
+ static void /* GnomeVFSModuleCallback */
+@@ -870,11 +874,15 @@
+ in_real = (GnomeVFSModuleCallbackQuestionIn *)in;
+ out_real = (GnomeVFSModuleCallbackQuestionOut *)out;
+
++ GDK_THREADS_ENTER ();
++
+ out_real->answer = -1; /* Set a default value */
+ dialog = create_question_dialog (in_real->primary_message, in_real->secondary_message, in_real->choices);
+ out_real->answer = gtk_dialog_run (GTK_DIALOG(dialog));
+
+ gtk_widget_destroy (GTK_WIDGET (dialog));
++
++ GDK_THREADS_LEAVE ();
+ }
+
+