aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgnomeuimm26/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 11:38:46 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 11:38:46 +0000
commitd377e35692b3112d1d427fd9c5cb6b65ce50fec1 (patch)
treee1e381ea2d7048beca3ff6fbea44a78a1c92ee0c /x11-toolkits/libgnomeuimm26/Makefile
parent62678d3fc1c8b3d7e63d1923f2aca85558015378 (diff)
Update to 2.10.0. Note: this release is API and ABI compatible with
2.6.x, so a repocopy to libgnomeuimm210 is not needed.
Notes
Notes: svn path=/head/; revision=131008
Diffstat (limited to 'x11-toolkits/libgnomeuimm26/Makefile')
-rw-r--r--x11-toolkits/libgnomeuimm26/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/x11-toolkits/libgnomeuimm26/Makefile b/x11-toolkits/libgnomeuimm26/Makefile
index 7ef6b45f1c9f..7f4bb83e2fa9 100644
--- a/x11-toolkits/libgnomeuimm26/Makefile
+++ b/x11-toolkits/libgnomeuimm26/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libgnomeuimm
-PORTVERSION= 2.6.0
-PORTREVISION= 1
+PORTVERSION= 2.10.0
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -30,8 +29,8 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GCC= 3.4
USE_REINPLACE= yes
-USE_GNOME= gnomehack lthack libgnomeui
-USE_INC_LIBTOOL_VER=13
+USE_GNOME= gnomehack libgnomeui
+USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
@@ -41,4 +40,13 @@ post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
${WRKSRC}/Makefile.in
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
.include <bsd.port.mk>