aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgnomeuimm26
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-08-27 23:31:43 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-08-27 23:31:43 +0000
commit6babeb84a5af4c01adbcb2042600819007e5094b (patch)
tree679ed91ef98838b1dd17f887e5ce8df31a6f63d7 /x11-toolkits/libgnomeuimm26
parent39b6e964c0347b99315e11fbb8219523553f0339 (diff)
downloadports-6babeb84a5af4c01adbcb2042600819007e5094b.tar.gz
ports-6babeb84a5af4c01adbcb2042600819007e5094b.zip
Notes
Diffstat (limited to 'x11-toolkits/libgnomeuimm26')
-rw-r--r--x11-toolkits/libgnomeuimm26/Makefile8
-rw-r--r--x11-toolkits/libgnomeuimm26/files/extra-patch-old_gcc_bugs29
2 files changed, 36 insertions, 1 deletions
diff --git a/x11-toolkits/libgnomeuimm26/Makefile b/x11-toolkits/libgnomeuimm26/Makefile
index 2c0cef2203e9..cd6bc4868e19 100644
--- a/x11-toolkits/libgnomeuimm26/Makefile
+++ b/x11-toolkits/libgnomeuimm26/Makefile
@@ -29,4 +29,10 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-old_gcc_bugs
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/libgnomeuimm26/files/extra-patch-old_gcc_bugs b/x11-toolkits/libgnomeuimm26/files/extra-patch-old_gcc_bugs
new file mode 100644
index 000000000000..bccb729cec94
--- /dev/null
+++ b/x11-toolkits/libgnomeuimm26/files/extra-patch-old_gcc_bugs
@@ -0,0 +1,29 @@
+--- libgnomeui/libgnomeuimm/dateedit.cc.orig Wed Aug 27 22:24:13 2003
++++ libgnomeui/libgnomeuimm/dateedit.cc Wed Aug 27 22:25:02 2003
+@@ -35,7 +35,7 @@
+ : Gtk::HBox(GTK_HBOX(g_object_new(get_type(), (char*)0)))
+ {
+ gnome_date_edit_construct(gobj(), the_time,
+- static_cast<GnomeDateEditFlags>(
++ GnomeDateEditFlags(
+ (show_time ? DATE_EDIT_SHOW_TIME : static_cast<DateEditFlags>(0))
+ | (use_24_format ? DATE_EDIT_24_HR : static_cast<DateEditFlags>(0)) ) );
+ }
+@@ -44,7 +44,7 @@
+ DateEdit::DateEdit(time_t the_time, DateEditFlags flags)
+ : Gtk::HBox(GTK_HBOX(g_object_new(get_type(), (char*)0)))
+ {
+- gnome_date_edit_construct(gobj(), the_time, static_cast<GnomeDateEditFlags>(flags));
++ gnome_date_edit_construct(gobj(), the_time, GnomeDateEditFlags(flags));
+ }
+
+
+@@ -254,7 +254,7 @@
+
+ void DateEdit::set_flags(DateEditFlags flags)
+ {
+- gnome_date_edit_set_flags(gobj(), static_cast<GnomeDateEditFlags>(flags));
++ gnome_date_edit_set_flags(gobj(), GnomeDateEditFlags(flags));
+ }
+
+ DateEditFlags DateEdit::get_flags() const