aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libpanelappletmm/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-12-04 07:48:08 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-12-04 07:48:08 +0000
commit8a5a07a68ef880b87df6705554e7b5dc4b06c487 (patch)
tree37b4f6d5ca1f635dbc054aa3422f04224524479a /x11-toolkits/libpanelappletmm/Makefile
parent7bfb6a039b81f17cd3bbbaa028d4e660f842d9a4 (diff)
downloadports-8a5a07a68ef880b87df6705554e7b5dc4b06c487.tar.gz
ports-8a5a07a68ef880b87df6705554e7b5dc4b06c487.zip
Notes
Diffstat (limited to 'x11-toolkits/libpanelappletmm/Makefile')
-rw-r--r--x11-toolkits/libpanelappletmm/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-toolkits/libpanelappletmm/Makefile b/x11-toolkits/libpanelappletmm/Makefile
new file mode 100644
index 000000000000..40184817acd6
--- /dev/null
+++ b/x11-toolkits/libpanelappletmm/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libpanelappletmm
+# Date created: 3 Dec 2003
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpanelappletmm
+PORTVERSION= 1.3.1
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gtkmm
+DIST_SUBDIR= gnome2
+
+MAINTAINER= bland@FreeBSD.org
+COMMENT= C++ binding for the panel applet API
+
+LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2 \
+ gconfmm-2.0:${PORTSDIR}/devel/gconfmm \
+ gnomeuimm-2.0:${PORTSDIR}/x11-toolkits/libgnomeuimm
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomepanel
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-static
+
+.include <bsd.port.mk>