aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libsexy/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-08 21:36:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-08 21:36:33 +0000
commit9e1d390915fae020d28e5e5139079ea1834ffd70 (patch)
tree84aa96ded79a75f75efa2dee7f214dbffa47a375 /x11-toolkits/libsexy/Makefile
parent760497b493f8c62ec99a02dbe90f52ad7479a218 (diff)
libsexy is a library containing additional widgets for gtk:
- url label - spell checked text entry - text entry with icons libsexymm are the corresponding c++ bindings for libsexy. PR: ports/88577 Submitted by: Andreas Kohn <andreas@syndrom23.de>
Notes
Notes: svn path=/head/; revision=147638
Diffstat (limited to 'x11-toolkits/libsexy/Makefile')
-rw-r--r--x11-toolkits/libsexy/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-toolkits/libsexy/Makefile b/x11-toolkits/libsexy/Makefile
new file mode 100644
index 000000000000..46afac597c69
--- /dev/null
+++ b/x11-toolkits/libsexy/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: libsexy
+# Date created: 2005-11-06
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsexy
+PORTVERSION= 0.1.3.1
+CATEGORIES= x11-toolkits devel
+MASTER_SITES= http://osiris.chipx86.com/projects/libsexy/releases/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= Extension widgets for GTK+
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+LIB_DEPENDS= enchant:${PORTSDIR}/textproc/enchant
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+
+USE_GNOME= gnomehack lthack gtk20 libxml2
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+USE_X_PREFIX= yes
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>