aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libsexy
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-08 21:36:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-08 21:36:33 +0000
commit9e1d390915fae020d28e5e5139079ea1834ffd70 (patch)
tree84aa96ded79a75f75efa2dee7f214dbffa47a375 /x11-toolkits/libsexy
parent760497b493f8c62ec99a02dbe90f52ad7479a218 (diff)
downloadports-9e1d390915fae020d28e5e5139079ea1834ffd70.tar.gz
ports-9e1d390915fae020d28e5e5139079ea1834ffd70.zip
Notes
Diffstat (limited to 'x11-toolkits/libsexy')
-rw-r--r--x11-toolkits/libsexy/Makefile27
-rw-r--r--x11-toolkits/libsexy/distinfo2
-rw-r--r--x11-toolkits/libsexy/files/patch-libsexy-sexy-icon-entry.c20
-rw-r--r--x11-toolkits/libsexy/files/patch-libsexy-sexy-spell-entry.c20
-rw-r--r--x11-toolkits/libsexy/pkg-descr4
-rw-r--r--x11-toolkits/libsexy/pkg-plist10
6 files changed, 83 insertions, 0 deletions
diff --git a/x11-toolkits/libsexy/Makefile b/x11-toolkits/libsexy/Makefile
new file mode 100644
index 000000000000..46afac597c69
--- /dev/null
+++ b/x11-toolkits/libsexy/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: libsexy
+# Date created: 2005-11-06
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsexy
+PORTVERSION= 0.1.3.1
+CATEGORIES= x11-toolkits devel
+MASTER_SITES= http://osiris.chipx86.com/projects/libsexy/releases/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= Extension widgets for GTK+
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+LIB_DEPENDS= enchant:${PORTSDIR}/textproc/enchant
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes
+
+USE_GNOME= gnomehack lthack gtk20 libxml2
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+USE_X_PREFIX= yes
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/libsexy/distinfo b/x11-toolkits/libsexy/distinfo
new file mode 100644
index 000000000000..b85d7a804892
--- /dev/null
+++ b/x11-toolkits/libsexy/distinfo
@@ -0,0 +1,2 @@
+MD5 (libsexy-0.1.3.1.tar.gz) = bffbbfb23d4b8560517e2beb59a3a4a0
+SIZE (libsexy-0.1.3.1.tar.gz) = 314762
diff --git a/x11-toolkits/libsexy/files/patch-libsexy-sexy-icon-entry.c b/x11-toolkits/libsexy/files/patch-libsexy-sexy-icon-entry.c
new file mode 100644
index 000000000000..cf8a1d0bf800
--- /dev/null
+++ b/x11-toolkits/libsexy/files/patch-libsexy-sexy-icon-entry.c
@@ -0,0 +1,20 @@
+--- libsexy/sexy-icon-entry.c.orig Fri Oct 14 10:48:10 2005
++++ libsexy/sexy-icon-entry.c Tue Nov 8 21:09:27 2005
+@@ -316,6 +316,8 @@
+
+ for (i = 0; i < MAX_ICONS; i++)
+ {
++ SexyIconInfo *icon_info;
++
+ attributes.window_type = GDK_WINDOW_CHILD;
+ attributes.wclass = GDK_INPUT_OUTPUT;
+ attributes.visual = gtk_widget_get_visual(widget);
+@@ -329,7 +331,7 @@
+ attributes_mask = GDK_WA_X | GDK_WA_Y |
+ GDK_WA_VISUAL | GDK_WA_COLORMAP;
+
+- SexyIconInfo *icon_info = &entry->priv->icons[i];
++ icon_info = &entry->priv->icons[i];
+ icon_info->window = gdk_window_new(widget->window, &attributes,
+ attributes_mask);
+ gdk_window_set_user_data(icon_info->window, widget);
diff --git a/x11-toolkits/libsexy/files/patch-libsexy-sexy-spell-entry.c b/x11-toolkits/libsexy/files/patch-libsexy-sexy-spell-entry.c
new file mode 100644
index 000000000000..772775ecd66f
--- /dev/null
+++ b/x11-toolkits/libsexy/files/patch-libsexy-sexy-spell-entry.c
@@ -0,0 +1,20 @@
+--- libsexy/sexy-spell-entry.c.orig Fri Oct 14 20:20:45 2005
++++ libsexy/sexy-spell-entry.c Tue Nov 8 22:13:53 2005
+@@ -866,13 +866,15 @@
+ gboolean
+ sexy_spell_entry_activate_language(SexySpellEntry *entry, const gchar *lang, GError **error)
+ {
++#ifdef HAVE_ENCHANT
++ gboolean ret;
++#endif
++
+ g_return_val_if_fail(entry != NULL, FALSE);
+ g_return_val_if_fail(SEXY_IS_SPELL_ENTRY(entry), FALSE);
+ g_return_val_if_fail(lang != NULL && lang != '\0', FALSE);
+
+ #ifdef HAVE_ENCHANT
+- gboolean ret;
+-
+ if (error)
+ g_return_val_if_fail(*error == NULL, FALSE);
+
diff --git a/x11-toolkits/libsexy/pkg-descr b/x11-toolkits/libsexy/pkg-descr
new file mode 100644
index 000000000000..3303e9c3ffd1
--- /dev/null
+++ b/x11-toolkits/libsexy/pkg-descr
@@ -0,0 +1,4 @@
+A library with extension widgets for GTK+. Included are a clickable URL
+label, a text entry with icon support, and others.
+
+WWW: http://wiki.chipx86.com/wiki/Libsexy
diff --git a/x11-toolkits/libsexy/pkg-plist b/x11-toolkits/libsexy/pkg-plist
new file mode 100644
index 000000000000..25ed7fecfa08
--- /dev/null
+++ b/x11-toolkits/libsexy/pkg-plist
@@ -0,0 +1,10 @@
+include/libsexy/sexy-enum-types.h
+include/libsexy/sexy-icon-entry.h
+include/libsexy/sexy-spell-entry.h
+include/libsexy/sexy-url-label.h
+include/libsexy/sexy.h
+lib/libsexy.a
+lib/libsexy.so
+lib/libsexy.so.1
+libdata/pkgconfig/libsexy.pc
+@dirrm include/libsexy