aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-f10-gtk2/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-19 21:17:13 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-19 21:17:13 +0000
commit3857c650b763709b385936e1d2088bab474da928 (patch)
tree74583381e6edb93c514426e9ef8126ae67026943 /x11-toolkits/linux-f10-gtk2/Makefile
parent9810bde3fa94da803512c9925ad4c66b9f58d404 (diff)
downloadports-3857c650b763709b385936e1d2088bab474da928.tar.gz
ports-3857c650b763709b385936e1d2088bab474da928.zip
Notes
Diffstat (limited to 'x11-toolkits/linux-f10-gtk2/Makefile')
-rw-r--r--x11-toolkits/linux-f10-gtk2/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/x11-toolkits/linux-f10-gtk2/Makefile b/x11-toolkits/linux-f10-gtk2/Makefile
index 3e4114471579..f615ee4fc2d3 100644
--- a/x11-toolkits/linux-f10-gtk2/Makefile
+++ b/x11-toolkits/linux-f10-gtk2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gtk2
PORTVERSION= 2.2.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= x11-toolkits linux
MAINTAINER= trevor@FreeBSD.org
@@ -22,12 +22,20 @@ RESTRICTED= "binaries under GNU LGPL without accompanying source"
RPM_SET= gtk2-2.2.1-4.i386.rpm
pre-install:
+ ${RM} -f ${PLIST}
+.for ii in gtk.immodules gdk-pixbuf.loaders
+ ${ECHO_CMD} etc/gtk-2.0/${ii} >> ${PLIST}
+.endfor
${RM} -rf ${WRKSRC}/tmp
${MKDIR} ${WRKSRC}/tmp
cd ${WRKSRC}/tmp; \
rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
- ${FIND} * -type f -o -type l > ${PLIST}; \
- ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' \
- >> ${PLIST}
+ ${FIND} * -type f -o -type l >> ${PLIST}; \
+ ${FIND} -d * -type d | ${GREP} -E 'locale|gtk|themes' | \
+ ${SED} -e 's:^:@dirrm :' >> ${PLIST}
+
+post-install:
+ ${INSTALL_DATA} ${FILESDIR}/gtk.immodules ${PREFIX}/etc/gtk-2.0/
+ ${TOUCH} ${PREFIX}/etc/gtk-2.0/gdk-pixbuf.loaders
.include "../linux-gtk/Makefile"