aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-f10-openmotif/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-10-04 03:26:26 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-10-04 03:26:26 +0000
commit393824e661eee7d98f059c9e8bd6b1eab122b10c (patch)
tree5f1d6b0091f94b93ce318ee5c09d452b835a9ff4 /x11-toolkits/linux-f10-openmotif/Makefile
parent944aa31f796747c0a9fb80cda05a6948c4b04212 (diff)
downloadports-393824e661eee7d98f059c9e8bd6b1eab122b10c.tar.gz
ports-393824e661eee7d98f059c9e8bd6b1eab122b10c.zip
Notes
Diffstat (limited to 'x11-toolkits/linux-f10-openmotif/Makefile')
-rw-r--r--x11-toolkits/linux-f10-openmotif/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-toolkits/linux-f10-openmotif/Makefile b/x11-toolkits/linux-f10-openmotif/Makefile
new file mode 100644
index 000000000000..b224df234cd7
--- /dev/null
+++ b/x11-toolkits/linux-f10-openmotif/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: linux-openmotif
+# Date created: 2001-09-24
+# Whom: Christian Weisgerber <naddy@mips.inka.de>
+#
+# $FreeBSD$
+
+PORTNAME= openmotif
+PORTVERSION= 2.1.30
+CATEGORIES= x11-toolkits linux
+MASTER_SITES= ftp://ftp.redhat.com/pub/%SUBDIR%/ \
+ ftp://ftp.sourceforge.net/pub/mirrors/redhat/%SUBDIR%/ \
+ ftp://ftp.funet.fi/pub/mirrors/ftp.redhat.com/pub/%SUBDIR%/ \
+ ftp://ftp.uni-bayreuth.de/pub/redhat.com/%SUBDIR%/
+MASTER_SITE_SUBDIR= contrib/openmotif/linux-rpm
+PKGNAMEPREFIX= linux-
+EXTRACT_SUFX= -1_ICS.${MACHINE_ARCH}.rpm
+DIST_SUBDIR= rpm
+EXTRACT_ONLY=
+
+MAINTAINER= naddy@mips.inka.de
+
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm
+
+ONLY_FOR_ARCHS= alpha i386
+USE_LINUX_PREFIX= yes
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+
+EXTRACT_FILES= usr/X11R6/lib/libMrm.so.2.1 \
+ usr/X11R6/lib/libUil.so.2.1 \
+ usr/X11R6/lib/libXm.so.2.1
+
+do-install:
+ cd ${PREFIX}; \
+ rpm2cpio ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} | \
+ cpio -idum -R ${LIBOWN}:${LIBGRP} ${EXTRACT_FILES}
+ chroot ${PREFIX} /sbin/ldconfig
+
+.include <bsd.port.mk>