aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-f10-pango/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
commit64cf27c85d89298041b8c8dc2fd090181e6d10d8 (patch)
tree11668b893f94453b0262a155d53e6eac8dd4a6f5 /x11-toolkits/linux-f10-pango/Makefile
parent440d8863c8d496b982754e2a71867892213a902b (diff)
downloadports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.tar.gz
ports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.zip
Notes
Diffstat (limited to 'x11-toolkits/linux-f10-pango/Makefile')
-rw-r--r--x11-toolkits/linux-f10-pango/Makefile26
1 files changed, 9 insertions, 17 deletions
diff --git a/x11-toolkits/linux-f10-pango/Makefile b/x11-toolkits/linux-f10-pango/Makefile
index d85e6f6c789d..bfae1cfb4acb 100644
--- a/x11-toolkits/linux-f10-pango/Makefile
+++ b/x11-toolkits/linux-f10-pango/Makefile
@@ -7,35 +7,27 @@
PORTNAME= pango
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits linux
-MAINTAINER= trevor@FreeBSD.org
-COMMENT= Linux/i386 pango binary
+MAINTAINER= freebsd-emulation@FreeBSD.org
+COMMENT= Linux pango binary
# these libraries are required by pango-querymodules
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXft.so.2:${PORTSDIR}/x11/linux-XFree86-libs \
+BUILD_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs \
${LINUXBASE}/usr/lib/libglib-2.0.so.0:${PORTSDIR}/devel/linux-glib2 \
${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
${LINUXBASE}/usr/lib/libexpat.so.0:${PORTSDIR}/textproc/linux-expat
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
BASEVERSION= 9
ONLY_FOR_ARCHS= i386
-PLIST= ${WRKDIR}/plist
-RESTRICTED= "binary under GNU LGPL without accompanying source"
+PLIST= ${PKGDIR}/pkg-plist
RPM_SET= pango-1.2.1-3.i386.rpm
-pre-install:
- ${RM} -rf ${WRKSRC}/tmp
- ${ECHO_CMD} etc/pango/pango.modules > ${PLIST}
- ${MKDIR} ${WRKSRC}/tmp
- cd ${WRKSRC}/tmp; \
- rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | ${CPIO} -id; \
- ${FIND} * -type f -o -type l >> ${PLIST}; \
- ${FIND} -d * -type d | ${GREP} pango | \
- ${SED} -e 's:^:@dirrm :' >> ${PLIST}
-
post-install:
- ${PREFIX}/usr/bin/pango-querymodules > ${PREFIX}/etc/pango/pango.modules
+ @${BRANDELF} -t Linux ${PREFIX}/usr/bin/pango-querymodules
+ @${PREFIX}/usr/bin/pango-querymodules > ${PREFIX}/etc/pango/pango.modules
.include "../linux-gtk/Makefile"