aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-f10-qt33/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2007-05-25 14:16:34 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2007-05-25 14:16:34 +0000
commit3f2976d2e538bcce64f5a9d4b2331f084876d581 (patch)
tree8119008b179f9b51d26865d51c22218d10c575ad /x11-toolkits/linux-f10-qt33/Makefile
parentbc946f8825e206bcb80de51829ab0b7c622873b5 (diff)
Notes
Diffstat (limited to 'x11-toolkits/linux-f10-qt33/Makefile')
-rw-r--r--x11-toolkits/linux-f10-qt33/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-toolkits/linux-f10-qt33/Makefile b/x11-toolkits/linux-f10-qt33/Makefile
new file mode 100644
index 000000000000..347e898de162
--- /dev/null
+++ b/x11-toolkits/linux-f10-qt33/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: linux-qt33
+# Date created: 24 May 2007
+# Whom: Boris Samorodov <bsam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qt33
+PORTVERSION= 3.3.4
+CATEGORIES= x11-toolkits linux
+DISTNAME= qt-${PORTVERSION}-${RPMVERSION}
+
+MAINTAINER= bsam@FreeBSD.org
+COMMENT= RPM of QT3
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libfontconfig.so.1:${PORTSDIR}/x11-fonts/linux-fontconfig \
+ ${LINUXBASE}/usr/lib/libmng.so.1:${PORTSDIR}/graphics/linux-libmng \
+ ${LINUXBASE}/usr/lib/libpng12.so.0:${PORTSDIR}/graphics/linux-png
+
+USE_LINUX_RPM= yes
+RPMVERSION= 15.5
+LINUX_DIST_VER= 4
+INSTALLS_SHLIB= yes
+PLIST= pkg-plist.${LINUX_RPM_ARCH}
+
+.include <bsd.port.mk>