aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-f8-gtk/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-11-01 09:55:05 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-11-01 09:55:05 +0000
commit5104eaa3f8cf3f0b1b069b05dd913b088f06a846 (patch)
tree149b6b5b78248afed76ea7f7db212323b7eeed2f /x11-toolkits/linux-f8-gtk/Makefile
parent8934149fdef6fe6746abb064200c98746eb2344c (diff)
Notes
Diffstat (limited to 'x11-toolkits/linux-f8-gtk/Makefile')
-rw-r--r--x11-toolkits/linux-f8-gtk/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-toolkits/linux-f8-gtk/Makefile b/x11-toolkits/linux-f8-gtk/Makefile
index 0abcc6447fe9..9611edad0aad 100644
--- a/x11-toolkits/linux-f8-gtk/Makefile
+++ b/x11-toolkits/linux-f8-gtk/Makefile
@@ -20,19 +20,25 @@ MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= rpm:${PORTSDIR}/misc/rpm
RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+ONLY_FOR_ARCHS= i386 alpha
DIST_SUBDIR= rpm
EXTRACT_ONLY=
NO_BUILD= yes
NO_FILTER_SHLIBS= yes
NO_MTREE= yes
-ONLY_FOR_ARCHS= i386
+PLIST= ${PKGDIR}/pkg-plist.${MACHINE_ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
PREFIX= /compat/linux
RPM_MIRRORS= ftp://ftp.freesoftware.com/pub/linux/redhat/old-releases/__DIR__/ \
ftp://ftp.freesoftware.com/pub/linux/redhat/__DIR__/
STDDIR= redhat-6.1/${MACHINE_ARCH}/RedHat/RPMS
UPDDIR= updates/6.1/${MACHINE_ARCH}
+.if (${MACHINE_ARCH} == "i386")
RPM_SET?= gtk+-1.2.5-2.${MACHINE_ARCH}.rpm
+.elif (${MACHINE_ARCH} == "alpha")
+RPM_SET?= gtk+-1.2.6-1.${MACHINE_ARCH}.rpm
+.endif
DBPATH= /var/lib/rpm
RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
--nodeps --replacepkgs