aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-gtk/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-12-31 18:24:10 +0000
commit64cf27c85d89298041b8c8dc2fd090181e6d10d8 (patch)
tree11668b893f94453b0262a155d53e6eac8dd4a6f5 /x11-toolkits/linux-gtk/Makefile
parent440d8863c8d496b982754e2a71867892213a902b (diff)
downloadports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.tar.gz
ports-64cf27c85d89298041b8c8dc2fd090181e6d10d8.zip
Notes
Diffstat (limited to 'x11-toolkits/linux-gtk/Makefile')
-rw-r--r--x11-toolkits/linux-gtk/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/x11-toolkits/linux-gtk/Makefile b/x11-toolkits/linux-gtk/Makefile
index 61a93aaf25fb..05a20c29f376 100644
--- a/x11-toolkits/linux-gtk/Makefile
+++ b/x11-toolkits/linux-gtk/Makefile
@@ -9,17 +9,20 @@
PORTNAME?= gtk
PORTVERSION?= 1.2
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES?= x11-toolkits linux
MASTER_SITES?= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
PKGNAMEPREFIX= linux-
DISTFILES= ${RPM_SET}
-MAINTAINER?= ports@FreeBSD.org
+MAINTAINER?= freebsd-emulation@FreeBSD.org
COMMENT?= RPM of the Gtk lib
BUILD_DEPENDS+= rpm:${PORTSDIR}/archivers/rpm
+RUN_DEPENDS?= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
+
USE_LINUX_PREFIX= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS?= i386 alpha
DIST_SUBDIR?= rpm
@@ -54,4 +57,13 @@ do-install:
rpm -U ${RPMFLAGS} ${RPMDIR}/$$R || true ; \
done
+new-plist:
+ @${RM} -rf ${WRKSRC}/tmp
+ @${MKDIR} ${WRKSRC}/tmp
+ @cd ${WRKSRC}/tmp; \
+ rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | ${CPIO} -id; \
+ ${FIND} * -type f -o -type l > ${PLIST}.new; \
+ ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' \
+ >> ${PLIST}.new
+
.include <bsd.port.mk>