aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/linux-pango
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-19 21:30:52 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-19 21:30:52 +0000
commit67db3a6a89bf61aa9f6e26b6690a088347032110 (patch)
tree67b309409d771b2f495d6dd8d048a0cca377c9fc /x11-toolkits/linux-pango
parentf4e2f13b58bd1dd0ba895681bb3dd5a9d97e087e (diff)
Fix packing list. Fix generation of pango.modules file (still
assumes Linux emulation is enabled).
Notes
Notes: svn path=/head/; revision=94408
Diffstat (limited to 'x11-toolkits/linux-pango')
-rw-r--r--x11-toolkits/linux-pango/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-toolkits/linux-pango/Makefile b/x11-toolkits/linux-pango/Makefile
index d91faeea68c9..d1573514ca31 100644
--- a/x11-toolkits/linux-pango/Makefile
+++ b/x11-toolkits/linux-pango/Makefile
@@ -24,14 +24,17 @@ RPM_SET= pango-1.2.1-3.i386.rpm
pre-install:
${RM} -rf ${WRKSRC}/tmp
+ ${ECHO_CMD} etc/pango/pango.modules > ${PLIST}
${MKDIR} ${WRKSRC}/tmp
cd ${WRKSRC}/tmp; \
rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
- ${FIND} * -type f -o -type l > ${PLIST}; \
- ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
+ ${FIND} * -type f -o -type l >> ${PLIST}; \
+ ${FIND} -d * -type d | ${GREP} pango | \
+ ${SED} -e 's:^:@dirrm :' >> ${PLIST}
post-install:
- ${LINUXBASE}/usr/bin/pango-querymodules >\
- ${LINUXBASE}/etc/pango/pango.modules
+ - chroot ${LINUXBASE} usr/bin/pango-querymodules > \
+ ${WRKSRC}/pango.modules
+ ${INSTALL_DATA} ${WRKSRC}/pango.modules ${LINUXBASE}/etc/pango/
.include "../linux-gtk/Makefile"