aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/osm-gps-map
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2016-02-13 14:31:04 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2016-02-13 14:31:04 +0000
commit981315bd9d08e4a3a1b9771bec393096d33e1373 (patch)
tree1784250850cc318bcd3f22a4d7163ccab57f2c53 /x11-toolkits/osm-gps-map
parent25f63a2dc79d9c3964d36e04e7f641c285bb274d (diff)
downloadports-981315bd9d08e4a3a1b9771bec393096d33e1373.tar.gz
ports-981315bd9d08e4a3a1b9771bec393096d33e1373.zip
Notes
Diffstat (limited to 'x11-toolkits/osm-gps-map')
-rw-r--r--x11-toolkits/osm-gps-map/Makefile24
-rw-r--r--x11-toolkits/osm-gps-map/distinfo2
-rw-r--r--x11-toolkits/osm-gps-map/pkg-descr9
-rw-r--r--x11-toolkits/osm-gps-map/pkg-plist44
4 files changed, 79 insertions, 0 deletions
diff --git a/x11-toolkits/osm-gps-map/Makefile b/x11-toolkits/osm-gps-map/Makefile
new file mode 100644
index 000000000000..d9620bea8fa7
--- /dev/null
+++ b/x11-toolkits/osm-gps-map/Makefile
@@ -0,0 +1,24 @@
+# Created by: Jean-Sébastien Pédron <dumbbell@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= osm-gps-map
+PORTVERSION= 1.1.0
+CATEGORIES= x11-toolkits net
+MASTER_SITES= https://github.com/nzjrs/${PORTNAME}/releases/download/${PORTVERSION}/
+
+MAINTAINER= dumbbell@FreeBSD.org
+COMMENT= Gtk+ 3.0 mapping widget
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup
+
+USES= gmake gnome libtool pkgconfig
+USE_GNOME= cairo gtk30 introspection:build
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/osm-gps-map/distinfo b/x11-toolkits/osm-gps-map/distinfo
new file mode 100644
index 000000000000..3f19fc82305e
--- /dev/null
+++ b/x11-toolkits/osm-gps-map/distinfo
@@ -0,0 +1,2 @@
+SHA256 (osm-gps-map-1.1.0.tar.gz) = 8f2ff865ed9ed9786cc5373c37b341b876958416139d0065ebb785cf88d33586
+SIZE (osm-gps-map-1.1.0.tar.gz) = 440480
diff --git a/x11-toolkits/osm-gps-map/pkg-descr b/x11-toolkits/osm-gps-map/pkg-descr
new file mode 100644
index 000000000000..380571dfea5c
--- /dev/null
+++ b/x11-toolkits/osm-gps-map/pkg-descr
@@ -0,0 +1,9 @@
+osm-gps-map is a Gtk mapping widget (and Python bindings) that when
+given GPS co-ordinates, draws a GPS track, and points of interest on a
+moving map display.
+
+osm-gps-map downloads map data from a number of websites, including
+openstreetmap.org, openaerialmap.org and others and can be used to build
+desktop mapping or geolocation applications.
+
+WWW: http://nzjrs.github.io/osm-gps-map/
diff --git a/x11-toolkits/osm-gps-map/pkg-plist b/x11-toolkits/osm-gps-map/pkg-plist
new file mode 100644
index 000000000000..375dff988d43
--- /dev/null
+++ b/x11-toolkits/osm-gps-map/pkg-plist
@@ -0,0 +1,44 @@
+include/osmgpsmap-1.0/osm-gps-map-compat.h
+include/osmgpsmap-1.0/osm-gps-map-image.h
+include/osmgpsmap-1.0/osm-gps-map-layer.h
+include/osmgpsmap-1.0/osm-gps-map-osd.h
+include/osmgpsmap-1.0/osm-gps-map-point.h
+include/osmgpsmap-1.0/osm-gps-map-polygon.h
+include/osmgpsmap-1.0/osm-gps-map-source.h
+include/osmgpsmap-1.0/osm-gps-map-track.h
+include/osmgpsmap-1.0/osm-gps-map-widget.h
+include/osmgpsmap-1.0/osm-gps-map.h
+lib/girepository-1.0/OsmGpsMap-1.0.typelib
+lib/libosmgpsmap-1.0.a
+lib/libosmgpsmap-1.0.so
+lib/libosmgpsmap-1.0.so.1
+lib/libosmgpsmap-1.0.so.1.0.0
+libdata/pkgconfig/osmgpsmap-1.0.pc
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+share/gir-1.0/OsmGpsMap-1.0.gir
+share/gtk-doc/html/libosmgpsmap/OsmGpsMap.html
+share/gtk-doc/html/libosmgpsmap/OsmGpsMapImage.html
+share/gtk-doc/html/libosmgpsmap/OsmGpsMapLayer.html
+share/gtk-doc/html/libosmgpsmap/OsmGpsMapPoint.html
+share/gtk-doc/html/libosmgpsmap/OsmGpsMapTrack.html
+share/gtk-doc/html/libosmgpsmap/annotation-glossary.html
+share/gtk-doc/html/libosmgpsmap/api-index-deprecated.html
+share/gtk-doc/html/libosmgpsmap/api-index-full.html
+share/gtk-doc/html/libosmgpsmap/api-reference-deprecated.html
+share/gtk-doc/html/libosmgpsmap/api-reference.html
+share/gtk-doc/html/libosmgpsmap/home.png
+share/gtk-doc/html/libosmgpsmap/index.html
+share/gtk-doc/html/libosmgpsmap/index.sgml
+share/gtk-doc/html/libosmgpsmap/left-insensitive.png
+share/gtk-doc/html/libosmgpsmap/left.png
+share/gtk-doc/html/libosmgpsmap/libosmgpsmap-OsmGpsMap-Deprecated.html
+share/gtk-doc/html/libosmgpsmap/libosmgpsmap.devhelp2
+share/gtk-doc/html/libosmgpsmap/right-insensitive.png
+share/gtk-doc/html/libosmgpsmap/right.png
+share/gtk-doc/html/libosmgpsmap/style.css
+share/gtk-doc/html/libosmgpsmap/up-insensitive.png
+share/gtk-doc/html/libosmgpsmap/up.png