aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Gtk-Perl/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-02-28 14:58:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-02-28 14:58:33 +0000
commit492ae2461d663bb1d6ddb878ba3ff8563f87ceee (patch)
treedf20a428a6764b46c6c0b01c839fdc814f2a27b6 /x11-toolkits/p5-Gtk-Perl/Makefile
parente5493b56b41050b06f6bb8239ab1c13e38d8030c (diff)
Notes
Diffstat (limited to 'x11-toolkits/p5-Gtk-Perl/Makefile')
-rw-r--r--x11-toolkits/p5-Gtk-Perl/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Gtk-Perl/Makefile b/x11-toolkits/p5-Gtk-Perl/Makefile
new file mode 100644
index 000000000000..eab62debab45
--- /dev/null
+++ b/x11-toolkits/p5-Gtk-Perl/Makefile
@@ -0,0 +1,30 @@
+# Created by: Vanilla I. Shu <vanilla@MinJe.com.TW>
+# $FreeBSD$
+
+PORTNAME= Gtk-Perl
+PORTVERSION= 0.7010
+PORTREVISION= 3
+CATEGORIES= x11-toolkits lang perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= The base module of Gtk-Perl
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-XML-Writer>=0:textproc/p5-XML-Writer \
+ p5-XML-Parser>=0:textproc/p5-XML-Parser
+
+USE_GNOME= gtk12
+USES= perl5 shebangfix
+SHEBANG_FILES= tools/gendoc.pl tools/gpdoc2pod
+USE_PERL5= configure
+CONFIGURE_ARGS= --without-guessing --lazy-load
+MAKE_JOBS_UNSAFE= yes
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Gtk/Gtk.so
+
+.include <bsd.port.mk>