aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Gtk2-Ex-PodViewer
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-03-07 23:00:14 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-03-07 23:00:14 +0000
commit5bf6fb7960b949ed316a83fac85b0a3296c3f9bb (patch)
treeb9ed8ad7b48d3a6805ee0ae15def8dfe1f2dde44 /x11-toolkits/p5-Gtk2-Ex-PodViewer
parent81ddcb742e63587ed3c269d6996335ffea310866 (diff)
downloadports-5bf6fb7960b949ed316a83fac85b0a3296c3f9bb.tar.gz
ports-5bf6fb7960b949ed316a83fac85b0a3296c3f9bb.zip
Notes
Diffstat (limited to 'x11-toolkits/p5-Gtk2-Ex-PodViewer')
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile27
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-PodViewer/distinfo2
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-PodViewer/pkg-descr10
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-PodViewer/pkg-plist7
4 files changed, 46 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile b/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
new file mode 100644
index 000000000000..e2a3c6a46d06
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Ex-PodViewer/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Gtk2-PodViewer
+# Date created: 2004-08-20
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Gtk2-PodViewer
+PORTVERSION= 0.07
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/G/GB/GBROWN/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Gtk2-Perl widget and program for displaying POD
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
+ ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= podviewer.1
+MAN3= Gtk2::PodViewer.3 Gtk2::PodViewer::Parser.3
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Gtk2-Ex-PodViewer/distinfo b/x11-toolkits/p5-Gtk2-Ex-PodViewer/distinfo
new file mode 100644
index 000000000000..be3b97a4c648
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Ex-PodViewer/distinfo
@@ -0,0 +1,2 @@
+MD5 (Gtk2-PodViewer-0.07.tar.gz) = 6e711a1e42cfcce6a53f73787c034495
+SIZE (Gtk2-PodViewer-0.07.tar.gz) = 12358
diff --git a/x11-toolkits/p5-Gtk2-Ex-PodViewer/pkg-descr b/x11-toolkits/p5-Gtk2-Ex-PodViewer/pkg-descr
new file mode 100644
index 000000000000..ea93caa29586
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Ex-PodViewer/pkg-descr
@@ -0,0 +1,10 @@
+Gtk2::PodViewer is a widget for rendering Perl POD documents.
+It is based on the Gtk2::TextView widget and uses Pod::Parser for manipulating
+POD data.
+
+Also, podviewer provides a simple and attractive way to read Perl's POD
+documentation. You can use it to read the Perl POD pages, module documentation
+and information about Perl's builtin functions.
+
+Author: gavin.brown-at-uk.com
+WWW: http://search.cpan.org/~gbrown/Gtk2-PodViewer/
diff --git a/x11-toolkits/p5-Gtk2-Ex-PodViewer/pkg-plist b/x11-toolkits/p5-Gtk2-Ex-PodViewer/pkg-plist
new file mode 100644
index 000000000000..2f50bd143ab7
--- /dev/null
+++ b/x11-toolkits/p5-Gtk2-Ex-PodViewer/pkg-plist
@@ -0,0 +1,7 @@
+bin/podviewer
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Gtk2/PodViewer/.packlist
+%%SITE_PERL%%/Gtk2/PodViewer.pm
+%%SITE_PERL%%/Gtk2/PodViewer/Parser.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Gtk2/PodViewer
+@dirrm %%SITE_PERL%%/Gtk2/PodViewer
+@unexec rmdir %D/%%SITE_PERL%%/Gtk2 2> /dev/null || true