aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Tk-JComboBox/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-08-31 11:38:32 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-08-31 11:38:32 +0000
commit15ec2820588b6679fdd0d9ec91f2cefd92a743bb (patch)
tree6a3ba7c42e2419f87da45f9eb0530fb92062ee11 /x11-toolkits/p5-Tk-JComboBox/Makefile
parent5f8bc532335cd9765cf66c379ddd1d88b1185b7e (diff)
downloadports-15ec2820588b6679fdd0d9ec91f2cefd92a743bb.tar.gz
ports-15ec2820588b6679fdd0d9ec91f2cefd92a743bb.zip
Notes
Diffstat (limited to 'x11-toolkits/p5-Tk-JComboBox/Makefile')
-rw-r--r--x11-toolkits/p5-Tk-JComboBox/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Tk-JComboBox/Makefile b/x11-toolkits/p5-Tk-JComboBox/Makefile
new file mode 100644
index 000000000000..67ac193208a1
--- /dev/null
+++ b/x11-toolkits/p5-Tk-JComboBox/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Tk-JComboBox
+# Date created: 31 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tk-JComboBox
+PORTVERSION= 1.11
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Contains a Label or Entry, a Button, and a Listbox
+
+BUILD_DEPENDS= p5-Tk>=804.027:${PORTSDIR}/x11-toolkits/p5-Tk \
+ p5-Tie-Watch>=1.2:${PORTSDIR}/devel/p5-Tie-Watch
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= ${PORTNAME:S/-/::/g}.3 Tk::CWidget.3 Tk::JComboBox::tutorial.3
+
+.include <bsd.port.mk>