aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Tk-Splashscreen/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-12-02 14:01:04 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-12-02 14:01:04 +0000
commitda79548f4721999819f26d1dc27f491522886363 (patch)
tree07937defacd0cfe566c0fd77f6765caa5ddba58b /x11-toolkits/p5-Tk-Splashscreen/Makefile
parent83a2af9ae5ffc8f64abb723870864c0b069bf6c7 (diff)
downloadports-da79548f4721999819f26d1dc27f491522886363.tar.gz
ports-da79548f4721999819f26d1dc27f491522886363.zip
Notes
Diffstat (limited to 'x11-toolkits/p5-Tk-Splashscreen/Makefile')
-rw-r--r--x11-toolkits/p5-Tk-Splashscreen/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Tk-Splashscreen/Makefile b/x11-toolkits/p5-Tk-Splashscreen/Makefile
new file mode 100644
index 000000000000..2a18ad2d88a9
--- /dev/null
+++ b/x11-toolkits/p5-Tk-Splashscreen/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: x11-toolkits/p5-Tk-Splashscreen
+# Date created: 02 December 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tk-Splashscreen
+PORTVERSION= 1.0
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tk
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Tk::Splashscreen, display a Splashscreen during program initialization
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Tk::Splashscreen.3 \
+ Tk::waitVariableX.3
+
+.include <bsd.port.mk>