aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/pango
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /x11-toolkits/pango
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Notes
Diffstat (limited to 'x11-toolkits/pango')
-rw-r--r--x11-toolkits/pango/Makefile17
-rw-r--r--x11-toolkits/pango/distinfo6
-rw-r--r--x11-toolkits/pango/files/extra-patch-gcc188
-rw-r--r--x11-toolkits/pango/files/patch-pango-view_Makefile.in11
4 files changed, 202 insertions, 20 deletions
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index 5d745929bb7f..345be6cd514f 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -3,11 +3,11 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports-stable/x11-toolkits/pango/Makefile,v 1.7 2009/04/15 22:25:48 kwm Exp $
+# $MCom: ports/x11-toolkits/pango/Makefile,v 1.149 2009/11/18 11:00:12 kwm Exp $
#
PORTNAME= pango
-PORTVERSION= 1.24.5
+PORTVERSION= 1.26.1
PORTREVISION?= 0
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME \
@@ -32,8 +32,7 @@ MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:22
USE_GNOME= gnomehack glib20 ltverhack referencehack
-CONFIGURE_ARGS= --with-qt=no \
- --with-html-dir=${PREFIX}/share/doc \
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--enable-static
# Hmm.. tough one. Found this one when I had graphics/hdf installed
# (which installs glist.h) which is picked up before the glib-2.0
@@ -45,7 +44,7 @@ PLIST_SUB= VERSION="1.6.0"
FONTSCALE= ${LOCALBASE}/lib/X11/fonts/TTF/luximb.ttf
FONTENCOD= ${LOCALBASE}/lib/X11/fonts/encodings/encodings.dir
-MAN1= pango-view.1 pango-querymodules.1 preload.1
+MAN1= pango-view.1 pango-querymodules.1
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --with-x=no
@@ -61,6 +60,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
PLIST_SUB+= X11=""
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gcc
+.endif
+
+.include <bsd.port.post.mk>
.endif
diff --git a/x11-toolkits/pango/distinfo b/x11-toolkits/pango/distinfo
index 80aac2bb8774..5acfcd5a394f 100644
--- a/x11-toolkits/pango/distinfo
+++ b/x11-toolkits/pango/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/pango-1.24.5.tar.bz2) = 815416a452e9cccc172fed9862401f37
-SHA256 (gnome2/pango-1.24.5.tar.bz2) = 0f733d1ec3e8dafcae152d7ac58f1090bee1fd856176c8fee0e81b0e42392f4e
-SIZE (gnome2/pango-1.24.5.tar.bz2) = 1519944
+MD5 (gnome2/pango-1.26.1.tar.bz2) = 2cbc1f26639e335905f7d31c0da53fce
+SHA256 (gnome2/pango-1.26.1.tar.bz2) = e0254e979bf0fac305de596997cabda83e26c713b666bc582aa9e4b70cb0920d
+SIZE (gnome2/pango-1.26.1.tar.bz2) = 1538050
diff --git a/x11-toolkits/pango/files/extra-patch-gcc b/x11-toolkits/pango/files/extra-patch-gcc
new file mode 100644
index 000000000000..d8a1cc957480
--- /dev/null
+++ b/x11-toolkits/pango/files/extra-patch-gcc
@@ -0,0 +1,188 @@
+diff -ru ../pango-1.26.0/pango/opentype/hb-open-type-private.hh ./pango/opentype/hb-open-type-private.hh
+--- pango/opentype/hb-open-type-private.hh 2009-08-28 17:15:12.000000000 -0400
++++ pango/opentype/hb-open-type-private.hh 2009-09-30 05:14:13.000000000 -0400
+@@ -508,10 +508,10 @@
+ inline const Type& operator [] (unsigned int i) const
+ {
+ if (HB_UNLIKELY (i >= len)) return Null(Type);
+- return array[i];
++ return _array(i);
+ }
+ inline unsigned int get_size () const
+- { return sizeof (len) + len * sizeof (array[0]); }
++ { return sizeof (len) + len * sizeof (Type); }
+
+ inline bool sanitize (SANITIZE_ARG_DEF) {
+ TRACE_SANITIZE ();
+@@ -523,7 +523,7 @@
+ return true;
+ unsigned int count = len;
+ for (unsigned int i = 0; i < count; i++)
+- if (!SANITIZE (array[i]))
++ if (!SANITIZE (_array(i)))
+ return false;
+ return true;
+ }
+@@ -532,7 +532,7 @@
+ if (!SANITIZE_GET_SIZE()) return false;
+ unsigned int count = len;
+ for (unsigned int i = 0; i < count; i++)
+- if (!array[i].sanitize (SANITIZE_ARG, base))
++ if (!_array(i).sanitize (SANITIZE_ARG, base))
+ return false;
+ return true;
+ }
+@@ -541,7 +541,7 @@
+ if (!SANITIZE_GET_SIZE()) return false;
+ unsigned int count = len;
+ for (unsigned int i = 0; i < count; i++)
+- if (!array[i].sanitize (SANITIZE_ARG, base, base2))
++ if (!_array(i).sanitize (SANITIZE_ARG, base, base2))
+ return false;
+ return true;
+ }
+@@ -550,15 +550,21 @@
+ if (!SANITIZE_GET_SIZE()) return false;
+ unsigned int count = len;
+ for (unsigned int i = 0; i < count; i++)
+- if (!array[i].sanitize (SANITIZE_ARG, base, user_data))
++ if (!_array(i).sanitize (SANITIZE_ARG, base, user_data))
+ return false;
+ return true;
+ }
+
+ LenType len;
+- Type array[];
++ //Type array[];
++ Type& _array(unsigned int i) const
++ {
++ return *(Type*)(&len + 1);
++ }
+ };
+
++#undef array
++
+ /* An array with a USHORT number of elements. */
+ template <typename Type>
+ struct ArrayOf : GenericArrayOf<USHORT, Type> {};
+@@ -586,7 +592,7 @@
+ inline const Type& operator [] (unsigned int i) const
+ {
+ if (HB_UNLIKELY (i >= this->len)) return Null(Type);
+- return this+this->array[i];
++ return this+this->_array(i);
+ }
+
+ inline bool sanitize (SANITIZE_ARG_DEF) {
+diff -ru ../pango-1.26.0/pango/opentype/hb-ot-layout-common-private.hh ./pango/opentype/hb-ot-layout-common-private.hh
+--- ../pango-1.26.0/pango/opentype/hb-ot-layout-common-private.hh 2009-08-28 17:15:12.000000000 -0400
++++ ./pango/opentype/hb-ot-layout-common-private.hh 2009-09-30 05:15:25.000000000 -0400
+@@ -67,14 +67,14 @@
+ inline const Tag& get_tag (unsigned int i) const
+ {
+ if (HB_UNLIKELY (i >= this->len)) return Null(Tag);
+- return this->array[i].tag;
++ return this->_array(i).tag;
+ }
+ inline bool get_tags (unsigned int *record_count /* IN/OUT */,
+ hb_tag_t *record_tags /* OUT */) const
+ {
+ unsigned int count = MIN (this->len, *record_count);
+ for (unsigned int i = 0; i < count; i++)
+- record_tags[i] = this->array[i].tag;
++ record_tags[i] = this->_array(i).tag;
+
+ *record_count = this->len;
+ return !!this->len;
+@@ -86,7 +86,7 @@
+ unsigned int count = this->len;
+ for (unsigned int i = 0; i < count; i++)
+ {
+- if (t == this->array[i].tag)
++ if (t == this->_array(i).tag)
+ {
+ if (index) *index = i;
+ return true;
+@@ -116,14 +116,14 @@
+ {
+ if (HB_UNLIKELY (i >= this->len))
+ return NO_INDEX;
+- return this->array[i];
++ return this->_array(i);
+ }
+ inline bool get_indexes (unsigned int *_count /* IN/OUT */,
+ unsigned int *_indexes /* OUT */) const
+ {
+ unsigned int count = MIN (this->len, *_count);
+ for (unsigned int i = 0; i < count; i++)
+- _indexes[i] = this->array[i];
++ _indexes[i] = this->_array(i);
+
+ *_count = this->len;
+ return !!this->len;
+diff -ru ../pango-1.26.0/pango/opentype/hb-ot-layout-gsub-private.hh ./pango/opentype/hb-ot-layout-gsub-private.hh
+--- ../pango-1.26.0/pango/opentype/hb-ot-layout-gsub-private.hh 2009-08-28 17:16:36.000000000 -0400
++++ ./pango/opentype/hb-ot-layout-gsub-private.hh 2009-09-30 05:28:53.000000000 -0400
+@@ -160,7 +160,7 @@
+ return false;
+
+ _hb_buffer_add_output_glyphs (buffer, 1,
+- substitute.len, (const uint16_t *) substitute.array,
++ substitute.len, (const uint16_t *) &substitute._array(0),
+ 0xFFFF, 0xFFFF);
+
+ /* This is a guess only ... */
+@@ -285,7 +285,7 @@
+ if (context->face->altfunc)
+ alt_index = (context->face->altfunc)(context->layout, buffer,
+ buffer->out_pos, glyph_id,
+- alt_set.len, alt_set.array);
++ alt_set.len, alt_set._array(0));
+ */
+
+ if (HB_UNLIKELY (alt_index >= alt_set.len))
+@@ -601,10 +601,10 @@
+ const ArrayOf<GlyphID> &substitute = CONST_NEXT (ArrayOf<GlyphID>, lookahead);
+
+ if (match_backtrack (APPLY_ARG,
+- backtrack.len, (USHORT *) backtrack.array,
++ backtrack.len, (USHORT *) &backtrack._array(0),
+ match_coverage, DECONST_CHARP(this)) &&
+ match_lookahead (APPLY_ARG,
+- lookahead.len, (USHORT *) lookahead.array,
++ lookahead.len, (USHORT *) &lookahead._array(0),
+ match_coverage, DECONST_CHARP(this),
+ 1))
+ {
+diff -ru ../pango-1.26.0/pango/opentype/hb-ot-layout-gsubgpos-private.hh ./pango/opentype/hb-ot-layout-gsubgpos-private.hh
+--- ../pango-1.26.0/pango/opentype/hb-ot-layout-gsubgpos-private.hh 2009-09-21 13:58:54.000000000 -0400
++++ ./pango/opentype/hb-ot-layout-gsubgpos-private.hh 2009-09-30 05:33:03.000000000 -0400
+@@ -572,10 +572,10 @@
+ const ArrayOf<USHORT> &lookahead = CONST_NEXT (ArrayOf<USHORT>, input);
+ const ArrayOf<LookupRecord> &lookup = CONST_NEXT (ArrayOf<LookupRecord>, lookahead);
+ return chain_context_lookup (APPLY_ARG,
+- backtrack.len, backtrack.array,
++ backtrack.len, &backtrack._array(0),
+ input.len, input.array,
+- lookahead.len, lookahead.array,
+- lookup.len, lookup.array,
++ lookahead.len, &lookahead._array(0),
++ lookup.len, &lookup._array(0),
+ lookup_context);
+ return false;
+ }
+@@ -754,10 +754,10 @@
+ {DECONST_CHARP(this), DECONST_CHARP(this), DECONST_CHARP(this)}
+ };
+ return chain_context_lookup (APPLY_ARG,
+- backtrack.len, (USHORT *) backtrack.array,
+- input.len, (USHORT *) input.array + 1,
+- lookahead.len, (USHORT *) lookahead.array,
+- lookup.len, lookup.array,
++ backtrack.len, (USHORT *) &backtrack._array(0),
++ input.len, (USHORT *) &input._array(1),
++ lookahead.len, (USHORT *) &lookahead._array(0),
++ lookup.len, &lookup._array(0),
+ lookup_context);
+ return false;
+ }
diff --git a/x11-toolkits/pango/files/patch-pango-view_Makefile.in b/x11-toolkits/pango/files/patch-pango-view_Makefile.in
deleted file mode 100644
index 345e608bf339..000000000000
--- a/x11-toolkits/pango/files/patch-pango-view_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- pango-view/Makefile.in.orig 2009-07-03 10:45:14.000000000 +0200
-+++ pango-view/Makefile.in 2009-07-03 10:46:39.000000000 +0200
-@@ -794,7 +794,7 @@ $(srcdir)/pango-view.1: ../configure.in
- (test -f "$@" || echo help2man is required to generate this file. >> "$@"));
-
- install-data-hook:
-- @cd "$(DESTDIR)$(man1dir)" && gzip -c pango-view.1 > pango-view.1.gz && $(RM) pango-view.1
-+ @cd "$(DESTDIR)$(man1dir)" && cp -p pango-view.1 preload.1
-
- uninstall-hook:
- $(RM) "$(DESTDIR)$(man1dir)/pango-view.1.gz"