aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/pango
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2020-07-23 18:36:06 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2020-07-23 18:36:06 +0000
commitf857a760cc46ac0a3010c993c93fe9f429321876 (patch)
tree44418b7e21e56e9cde82424dc3a4273f118dbc19 /x11-toolkits/pango
parent7634d3443977b3b211b9fafde7b41b0300dfc6ae (diff)
Notes
Diffstat (limited to 'x11-toolkits/pango')
-rw-r--r--x11-toolkits/pango/Makefile2
-rw-r--r--x11-toolkits/pango/files/CVE-2019101023816
2 files changed, 17 insertions, 1 deletions
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index 68cefb17a66a..59b4cbe023f5 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pango
PORTVERSION= 1.42.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
diff --git a/x11-toolkits/pango/files/CVE-20191010238 b/x11-toolkits/pango/files/CVE-20191010238
new file mode 100644
index 000000000000..89d21cd89db1
--- /dev/null
+++ b/x11-toolkits/pango/files/CVE-20191010238
@@ -0,0 +1,16 @@
+--- ../pango/pango-bidi-type.c.orig 2020-07-23 19:10:14.338937000 +0200
++++ ../pango/pango-bidi-type.c 2020-07-23 19:12:15.511836000 +0200
+@@ -179,8 +179,11 @@ pango_log2vis_get_embedding_levels (const gchar *te
+ for (i = 0, p = text; p < text + length; p = g_utf8_next_char(p), i++)
+ {
+ gunichar ch = g_utf8_get_char (p);
+- FriBidiCharType char_type;
+- char_type = fribidi_get_bidi_type (ch);
++ FriBidiCharType char_type = fribidi_get_bidi_type (ch);
++
++ if (i == n_chars)
++ break;
++
+ bidi_types[i] = char_type;
+ ored_types |= char_type;
+ if (FRIBIDI_IS_STRONG (char_type))