aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/paragui-devel/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-26 18:44:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-26 18:44:30 +0000
commit579f7f1a82d57d5f5cfd85af06a8f7dcce8e5e48 (patch)
treeeb17af7ae4a178f0d74f8862a62f7d4e98348e3b /x11-toolkits/paragui-devel/Makefile
parentaf82f5e0c9957f6f2ae92632b72a89f1b998d317 (diff)
downloadports-579f7f1a82d57d5f5cfd85af06a8f7dcce8e5e48.tar.gz
ports-579f7f1a82d57d5f5cfd85af06a8f7dcce8e5e48.zip
Notes
Diffstat (limited to 'x11-toolkits/paragui-devel/Makefile')
-rw-r--r--x11-toolkits/paragui-devel/Makefile25
1 files changed, 5 insertions, 20 deletions
diff --git a/x11-toolkits/paragui-devel/Makefile b/x11-toolkits/paragui-devel/Makefile
index ac81057548c5..6906834d7a1e 100644
--- a/x11-toolkits/paragui-devel/Makefile
+++ b/x11-toolkits/paragui-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= paragui
-PORTVERSION= 0.6.4
+PORTVERSION= 0.7.0
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.bms-austria.com/pub/paragui/release/
@@ -23,30 +23,15 @@ USE_FREETYPE= yes
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
- CFLAGS="${PTHREAD_CFLAGS}" \
+ CFLAGS="${CXXFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
USE_GMAKE= yes
-PLIST_SUB= PORTVER=${PORTVERSION}
-
INSTALLS_SHLIB= yes
-MAN3= MSG_MESSAGE.3 PARAGUI_EVENTHANDLERDATA.3 SDLApplication.3 \
- SDLButton.3 SDLButtonGroup.3 SDLCheckButton.3 SDLColumnItem.3 \
- SDLDrawObject.3 SDLGradientWidget.3 SDLLabel.3 SDLLineEdit.3 \
- SDLListBox.3 SDLListBoxBaseItem.3 SDLListBoxItem.3 \
- SDLMessageObject.3 SDLProgressBar.3 SDLRadioButton.3 SDLScrollBar.3 \
- SDLScrollBar__ScrollButton.3 SDLSlider.3 SDLStaticFrame.3 SDLTheme.3 \
- SDLUserButton.3 SDLWidget.3 SDLWidgetDnD.3 SDLWidgetList.3 \
- SDLWindow.3 SDL_Gradient.3 SDL_Point.3 bresenham_h.3 paragui_h.3 \
- paragui_msgmap_h.3 paragui_types_h.3 parastretch_h.3 \
- rendertextrect_h.3 sdlapplication_h.3 sdlbutton_h.3 \
- sdlbuttongroup_h.3 sdlcheckbutton_h.3 sdlcolumnitem_h.3 \
- sdldrawobject_h.3 sdlgradientwidget_h.3 sdllabel_h.3 sdllineedit_h.3 \
- sdllistbox_h.3 sdllistboxbaseitem_h.3 sdllistboxitem_h.3 \
- sdlmessageobject_h.3 sdlprogressbar_h.3 sdlradiobutton_h.3 \
- sdlscrollbar_h.3 sdlslider_h.3 sdlstaticframe_h.3 sdlwidget_h.3 \
- sdlwidgetdnd_h.3 sdlwidgetlist_h.3 sdlwindow_h.3 theme_h.3
+post-patch:
+ @${PERL} -pi -e "s,\`sdl-config ,\`${SDL_CONFIG} ,g ; \
+ s,SDL/,SDL11/,g" ${WRKSRC}/configure
.include <bsd.port.mk>