aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/paragui-devel/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-18 23:04:31 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-18 23:04:31 +0000
commit837e8ef30fbfa96d1e83dfd0d860fa347c9433e7 (patch)
tree772ad3e0023f2f65aa4912315d64a32b0d823dd9 /x11-toolkits/paragui-devel/Makefile
parentea103f8b132b726b150911f85de9ea0c2050e8a3 (diff)
downloadports-837e8ef30fbfa96d1e83dfd0d860fa347c9433e7.tar.gz
ports-837e8ef30fbfa96d1e83dfd0d860fa347c9433e7.zip
Notes
Diffstat (limited to 'x11-toolkits/paragui-devel/Makefile')
-rw-r--r--x11-toolkits/paragui-devel/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/x11-toolkits/paragui-devel/Makefile b/x11-toolkits/paragui-devel/Makefile
index cd63f53c3064..9d021cc0e2d9 100644
--- a/x11-toolkits/paragui-devel/Makefile
+++ b/x11-toolkits/paragui-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= paragui
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.bms-austria.com/pub/paragui/release/
@@ -21,7 +21,8 @@ LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
@@ -34,10 +35,10 @@ post-extract:
@${RM} -f ${WRKSRC}/src/physfs/platform.c
post-patch:
- @${PERL} -pi -e 's|LT_CURRENT=.*$$|LT_CURRENT=${SHLIB_VER}|g ; \
+ ${REINPLACE_CMD} -e 's|LT_CURRENT=.*$$|LT_CURRENT=${SHLIB_VER}|g ; \
s|`sdl-config |`\$$\{SDL_CONFIG\} |g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
- 's|\$$\(SDL_CFLAGS\)|\$$\(PARAGUI_CFLAGS\)|g ; \
- s|-release \$$\(LT_RELEASE\)||g'
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|[$][(]SDL_CFLAGS[)]|\$\(PARAGUI_CFLAGS\)|g ; \
+ s|lib/pkgconfig|libdata/pkgconfig|g'
.include <bsd.port.mk>