aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/pure-tk
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2012-01-26 20:18:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2012-01-26 20:18:32 +0000
commit61d3e676552ca52efea03e6970cffafd985b83a7 (patch)
treee0c37c203ce240297429c4a376edf965c2dabc82 /x11-toolkits/pure-tk
parent630374295fc90f69f554f8b94d819e543aff030a (diff)
downloadports-61d3e676552ca52efea03e6970cffafd985b83a7.tar.gz
ports-61d3e676552ca52efea03e6970cffafd985b83a7.zip
Notes
Diffstat (limited to 'x11-toolkits/pure-tk')
-rw-r--r--x11-toolkits/pure-tk/Makefile34
-rw-r--r--x11-toolkits/pure-tk/distinfo2
-rw-r--r--x11-toolkits/pure-tk/pkg-descr6
3 files changed, 42 insertions, 0 deletions
diff --git a/x11-toolkits/pure-tk/Makefile b/x11-toolkits/pure-tk/Makefile
new file mode 100644
index 000000000000..e4057772e76e
--- /dev/null
+++ b/x11-toolkits/pure-tk/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: pure-tk
+# Date created: 2011-11-09
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-tk
+PORTVERSION= 0.3
+CATEGORIES= x11-toolkits
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A basic interface between Pure and Tcl/Tk
+
+USE_PURE= yes
+USE_TK= 82+
+SHORT_TCL_VER= ${TCL_VER:S/8./8/}
+
+MAKE_ARGS+= tclvers=${TCL_VER}
+
+PLIST_FILES= lib/pure/gnocl.pure \
+ lib/pure/tk.so \
+ lib/pure/tk.pure
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e "s|/usr/include|${LOCALBASE}/include|g" \
+ -e "s|-ltcl\$$(tclvers)|-ltcl${SHORT_TCL_VER}|" \
+ -e "s|-ltk\$$(tclvers)|-ltk${SHORT_TCL_VER}|" \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/pure-tk/distinfo b/x11-toolkits/pure-tk/distinfo
new file mode 100644
index 000000000000..01f91dd47678
--- /dev/null
+++ b/x11-toolkits/pure-tk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure/pure-tk-0.3.tar.gz) = a1807441b4784b590b1fcd287d7750b66dd68f9e91bcddf710ccb3a4e9506a32
+SIZE (pure/pure-tk-0.3.tar.gz) = 31547
diff --git a/x11-toolkits/pure-tk/pkg-descr b/x11-toolkits/pure-tk/pkg-descr
new file mode 100644
index 000000000000..5380da967a27
--- /dev/null
+++ b/x11-toolkits/pure-tk/pkg-descr
@@ -0,0 +1,6 @@
+pure-tk provides a basic interface between Pure and Tcl/Tk. The
+operations of this module allow you to execute arbitrary commands
+in the Tcl interpreter, set and retrieve variable values in the
+interpreter, and invoke Pure callbacks from Tcl/Tk.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-tk.html