aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-Pmw
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-06-05 06:50:33 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-06-05 06:50:33 +0000
commit57d114ddf34f3fc55c0eda2d1dede63d93f1531c (patch)
tree028d3db5856de500fb29aefc994047be5c3ab17a /x11-toolkits/py-Pmw
parent4090cf268c62515a443660cb61ef8d669a7bfe79 (diff)
downloadports-57d114ddf34f3fc55c0eda2d1dede63d93f1531c.tar.gz
ports-57d114ddf34f3fc55c0eda2d1dede63d93f1531c.zip
New port pmw. The Python Mega Widgets are a set of high-level
graphics widget for Python's Tkinter.
Notes
Notes: svn path=/head/; revision=11269
Diffstat (limited to 'x11-toolkits/py-Pmw')
-rw-r--r--x11-toolkits/py-Pmw/Makefile43
-rw-r--r--x11-toolkits/py-Pmw/distinfo1
-rw-r--r--x11-toolkits/py-Pmw/pkg-comment1
-rw-r--r--x11-toolkits/py-Pmw/pkg-descr21
-rw-r--r--x11-toolkits/py-Pmw/pkg-plist362
5 files changed, 428 insertions, 0 deletions
diff --git a/x11-toolkits/py-Pmw/Makefile b/x11-toolkits/py-Pmw/Makefile
new file mode 100644
index 000000000000..a2826120e87e
--- /dev/null
+++ b/x11-toolkits/py-Pmw/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: pmw
+# Version required: 0.7
+# Date created: 03 June 1998
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+
+DISTNAME= Pmw.0.7
+PKGNAME= pmw-0.7
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.dscpl.com.au/pub/pmw/
+
+MAINTAINER= tg@FreeBSD.ORG
+
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_CONFIGURE= true
+
+PYTHONSCRIPTDIR=${PREFIX}/lib/python1.5
+SITEPYDIR= ${PYTHONSCRIPTDIR}/site-packages
+DOCDIR= ${PREFIX}/share/doc/Pmw
+EXAMPLEDIR= ${PREFIX}/share/examples/Pmw
+
+do-build:
+ @${ECHO_MSG} "Do a \`make install' as root."
+
+do-install:
+ @(cd ${WRKDIR}; tar cf - Pmw/__init__.py Pmw/Pmw_0_7/__init__.py Pmw/Pmw_0_7/lib) | \
+ (cd ${SITEPYDIR}; tar xf -)
+ @${PREFIX}/bin/python ${PYTHONSCRIPTDIR}/compileall.py ${SITEPYDIR}/Pmw
+ @${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${SITEPYDIR}/Pmw
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCDIR} ${EXAMPLEDIR}
+ @(cd ${WRKDIR}/Pmw/Pmw_0_7/doc; tar cf - .) | \
+ (cd ${DOCDIR}; tar xf -)
+ @(cd ${WRKDIR}/Pmw/Pmw_0_7/demos; tar cf - .) | \
+ (cd ${EXAMPLEDIR}; tar xf -)
+ @${PREFIX}/bin/python ${PYTHONSCRIPTDIR}/compileall.py ${EXAMPLEDIR}
+ @${PREFIX}/bin/python -O ${PYTHONSCRIPTDIR}/compileall.py ${EXAMPLEDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-Pmw/distinfo b/x11-toolkits/py-Pmw/distinfo
new file mode 100644
index 000000000000..50dd42301209
--- /dev/null
+++ b/x11-toolkits/py-Pmw/distinfo
@@ -0,0 +1 @@
+MD5 (Pmw.0.7.tar.gz) = 8f3ec4c94cb62cfd3bff58ac9c2743e6
diff --git a/x11-toolkits/py-Pmw/pkg-comment b/x11-toolkits/py-Pmw/pkg-comment
new file mode 100644
index 000000000000..bd1e35a8ef7c
--- /dev/null
+++ b/x11-toolkits/py-Pmw/pkg-comment
@@ -0,0 +1 @@
+High-level compound graphics widgets for Python.
diff --git a/x11-toolkits/py-Pmw/pkg-descr b/x11-toolkits/py-Pmw/pkg-descr
new file mode 100644
index 000000000000..7326957666f5
--- /dev/null
+++ b/x11-toolkits/py-Pmw/pkg-descr
@@ -0,0 +1,21 @@
+Pmw is a framework for building high-level compound widgets, or
+megawidgets, constructed using other widgets as component parts. It
+promotes consistent look and feel within and between graphical
+applications, is highly configurable to your needs and is easy to use.
+
+Pmw consists of:
+ * A few base classes, providing a framework for building megawidgets.
+ * A library of flexible and extensible megawidgets built on the base
+ classes, such as ButtonBox, ComboBox, MessageDialog, etc.
+
+The interface to Pmw megawidgets is similar to basic Tk widgets, so it
+is easy for developers to include both megawidgets and basic Tk
+widgets in their graphical applications. In addition, all Pmw
+megawidgets may themselves be extended, using either inheritance or
+composition.
+
+The use of the Pmw framework and megawidgets replaces common widget
+combinations with higher level abstractions. This simplifies code,
+making it more readable and maintainable and more easily modifiable.
+The ability to extend Pmw megawidgets enables developers to create new
+megawidgets based on previous work.
diff --git a/x11-toolkits/py-Pmw/pkg-plist b/x11-toolkits/py-Pmw/pkg-plist
new file mode 100644
index 000000000000..6391b2ac08cb
--- /dev/null
+++ b/x11-toolkits/py-Pmw/pkg-plist
@@ -0,0 +1,362 @@
+lib/python1.5/site-packages/Pmw/__init__.py
+lib/python1.5/site-packages/Pmw/__init__.pyc
+lib/python1.5/site-packages/Pmw/__init__.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/__init__.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/__init__.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/__init__.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/__init__.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/__init__.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/__init__.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/Pmw.def
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwAboutDialog.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwAboutDialog.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwAboutDialog.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwBlt.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwBlt.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwBlt.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwComboBox.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwComboBox.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwComboBox.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwComboBoxDialog.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwComboBoxDialog.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwComboBoxDialog.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwCounterDialog.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwCounterDialog.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwCounterDialog.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwEntryField.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwEntryField.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwEntryField.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwGroup.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwGroup.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwGroup.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwLabeledWidget.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwLabeledWidget.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwLabeledWidget.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwLogicalFont.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwLogicalFont.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwLogicalFont.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwMenuBar.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwMenuBar.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwMenuBar.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwNoteBookR.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwNoteBookR.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwNoteBookR.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwMessageBar.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwMessageBar.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwMessageBar.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwMessageDialog.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwMessageDialog.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwMessageDialog.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwNoteBookS.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwNoteBookS.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwNoteBookS.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwPromptDialog.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwPromptDialog.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwPromptDialog.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledCanvas.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledCanvas.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledCanvas.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledField.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledField.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledField.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledListBox.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledListBox.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledListBox.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledText.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledText.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledText.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwSelectionDialog.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwSelectionDialog.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwSelectionDialog.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTextDialog.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTextDialog.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTextDialog.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTimeCounter.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTimeCounter.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTimeCounter.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTreeBrowse.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTreeBrowse.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTreeBrowse.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwOptionMenu.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwOptionMenu.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwOptionMenu.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledFrame.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledFrame.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwScrolledFrame.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTimeFuncs.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTimeFuncs.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwTimeFuncs.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwLoader.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwLoader.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwLoader.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwBalloon.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwBalloon.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwBalloon.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwBase.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwBase.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwBase.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwButtonBox.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwButtonBox.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwButtonBox.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwColor.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwColor.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwColor.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwCounter.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwCounter.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwCounter.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwDialog.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwDialog.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwDialog.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwPanedWidget.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwPanedWidget.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwPanedWidget.pyo
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwRadioSelect.py
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwRadioSelect.pyc
+lib/python1.5/site-packages/Pmw/Pmw_0_7/lib/PmwRadioSelect.pyo
+share/doc/Pmw/refindex.html
+share/doc/Pmw/AboutDialog.html
+share/doc/Pmw/Balloon.html
+share/doc/Pmw/ButtonBox.html
+share/doc/Pmw/ComboBox.html
+share/doc/Pmw/ComboBoxDialog.html
+share/doc/Pmw/Counter.html
+share/doc/Pmw/CounterDialog.html
+share/doc/Pmw/Dialog.html
+share/doc/Pmw/EntryField.html
+share/doc/Pmw/Group.html
+share/doc/Pmw/LabeledWidget.html
+share/doc/Pmw/MegaArchetype.html
+share/doc/Pmw/MegaToplevel.html
+share/doc/Pmw/MegaWidget.html
+share/doc/Pmw/MenuBar.html
+share/doc/Pmw/MessageBar.html
+share/doc/Pmw/MessageDialog.html
+share/doc/Pmw/NoteBookR.html
+share/doc/Pmw/NoteBookS.html
+share/doc/Pmw/OptionMenu.html
+share/doc/Pmw/PanedWidget.html
+share/doc/Pmw/PromptDialog.html
+share/doc/Pmw/RadioSelect.html
+share/doc/Pmw/ScrolledCanvas.html
+share/doc/Pmw/ScrolledField.html
+share/doc/Pmw/ScrolledFrame.html
+share/doc/Pmw/ScrolledListBox.html
+share/doc/Pmw/ScrolledText.html
+share/doc/Pmw/SelectionDialog.html
+share/doc/Pmw/TextDialog.html
+share/doc/Pmw/TimeCounter.html
+share/doc/Pmw/PmwFunctions.html
+share/doc/Pmw/Color.html
+share/doc/Pmw/Blt.html
+share/doc/Pmw/features.html
+share/doc/Pmw/changes.html
+share/doc/Pmw/copyright.html
+share/doc/Pmw/srcindex.html
+share/doc/Pmw/index.html
+share/doc/Pmw/starting.html
+share/doc/Pmw/demosandtests.html
+share/doc/Pmw/howtobuild.html
+share/doc/Pmw/dynamicloader.html
+share/doc/Pmw/porting.html
+share/doc/Pmw/howtouse.html
+share/doc/Pmw/blue_line.gif
+share/doc/Pmw/blueball.gif
+share/doc/Pmw/counter1.gif
+share/doc/Pmw/counter2.gif
+share/doc/Pmw/example1.gif
+share/doc/Pmw/example2.gif
+share/doc/Pmw/halfblueball.gif
+share/doc/Pmw/scale1.gif
+share/doc/Pmw/scale2.gif
+share/doc/Pmw/transdove.gif
+share/doc/Pmw/example.py
+share/doc/Pmw/exercises.py
+share/doc/Pmw/ExampleDemo.py
+share/doc/Pmw/ScrolledText_test.py
+share/doc/Pmw/PmwAboutDialog.py.html
+share/doc/Pmw/PmwBalloon.py.html
+share/doc/Pmw/PmwBase.py.html
+share/doc/Pmw/PmwBlt.py.html
+share/doc/Pmw/PmwButtonBox.py.html
+share/doc/Pmw/PmwColor.py.html
+share/doc/Pmw/PmwComboBox.py.html
+share/doc/Pmw/PmwComboBoxDialog.py.html
+share/doc/Pmw/PmwCounter.py.html
+share/doc/Pmw/PmwCounterDialog.py.html
+share/doc/Pmw/PmwDialog.py.html
+share/doc/Pmw/PmwEntryField.py.html
+share/doc/Pmw/PmwGroup.py.html
+share/doc/Pmw/PmwLabeledWidget.py.html
+share/doc/Pmw/PmwLoader.py.html
+share/doc/Pmw/PmwLogicalFont.py.html
+share/doc/Pmw/PmwMenuBar.py.html
+share/doc/Pmw/PmwMessageBar.py.html
+share/doc/Pmw/PmwMessageDialog.py.html
+share/doc/Pmw/PmwNoteBookR.py.html
+share/doc/Pmw/PmwNoteBookS.py.html
+share/doc/Pmw/PmwOptionMenu.py.html
+share/doc/Pmw/PmwPanedWidget.py.html
+share/doc/Pmw/PmwPromptDialog.py.html
+share/doc/Pmw/PmwRadioSelect.py.html
+share/doc/Pmw/PmwScrolledCanvas.py.html
+share/doc/Pmw/PmwScrolledField.py.html
+share/doc/Pmw/PmwScrolledFrame.py.html
+share/doc/Pmw/PmwScrolledListBox.py.html
+share/doc/Pmw/PmwScrolledText.py.html
+share/doc/Pmw/PmwSelectionDialog.py.html
+share/doc/Pmw/PmwTextDialog.py.html
+share/doc/Pmw/PmwTimeCounter.py.html
+share/doc/Pmw/PmwTimeFuncs.py.html
+share/doc/Pmw/PmwTreeBrowse.py.html
+share/examples/Pmw/AboutDialog.py
+share/examples/Pmw/AboutDialog.pyc
+share/examples/Pmw/AboutDialog.pyo
+share/examples/Pmw/Balloon.py
+share/examples/Pmw/Balloon.pyc
+share/examples/Pmw/Balloon.pyo
+share/examples/Pmw/BltGraph.py
+share/examples/Pmw/BltGraph.pyc
+share/examples/Pmw/BltGraph.pyo
+share/examples/Pmw/ButtonBox.py
+share/examples/Pmw/ButtonBox.pyc
+share/examples/Pmw/ButtonBox.pyo
+share/examples/Pmw/Colors.py
+share/examples/Pmw/Colors.pyc
+share/examples/Pmw/Colors.pyo
+share/examples/Pmw/ComboBoxDialog.py
+share/examples/Pmw/ComboBoxDialog.pyc
+share/examples/Pmw/ComboBoxDialog.pyo
+share/examples/Pmw/ComboBox_Simple.py
+share/examples/Pmw/ComboBox_Simple.pyc
+share/examples/Pmw/ComboBox_Simple.pyo
+share/examples/Pmw/ConfigClass.py
+share/examples/Pmw/ConfigClass.pyc
+share/examples/Pmw/ConfigClass.pyo
+share/examples/Pmw/CounterDialog.py
+share/examples/Pmw/CounterDialog.pyc
+share/examples/Pmw/CounterDialog.pyo
+share/examples/Pmw/Dialog.py
+share/examples/Pmw/Dialog.pyc
+share/examples/Pmw/Dialog.pyo
+share/examples/Pmw/ErrorHandling.py
+share/examples/Pmw/ErrorHandling.pyc
+share/examples/Pmw/ErrorHandling.pyo
+share/examples/Pmw/ExampleDemo.py
+share/examples/Pmw/ExampleDemo.pyc
+share/examples/Pmw/ExampleDemo.pyo
+share/examples/Pmw/Grid.py
+share/examples/Pmw/Grid.pyc
+share/examples/Pmw/Grid.pyo
+share/examples/Pmw/Group.py
+share/examples/Pmw/Group.pyc
+share/examples/Pmw/Group.pyo
+share/examples/Pmw/LabeledWidget.py
+share/examples/Pmw/LabeledWidget.pyc
+share/examples/Pmw/LabeledWidget.pyo
+share/examples/Pmw/LogicalFont.py
+share/examples/Pmw/LogicalFont.pyc
+share/examples/Pmw/LogicalFont.pyo
+share/examples/Pmw/MenuBar.py
+share/examples/Pmw/MenuBar.pyc
+share/examples/Pmw/MenuBar.pyo
+share/examples/Pmw/MessageBar.py
+share/examples/Pmw/MessageBar.pyc
+share/examples/Pmw/MessageBar.pyo
+share/examples/Pmw/MessageInfo.py
+share/examples/Pmw/MessageInfo.pyc
+share/examples/Pmw/MessageInfo.pyo
+share/examples/Pmw/NoteBookR.py
+share/examples/Pmw/NoteBookR.pyc
+share/examples/Pmw/NoteBookR.pyo
+share/examples/Pmw/ShowBusy.py
+share/examples/Pmw/ShowBusy.pyc
+share/examples/Pmw/ShowBusy.pyo
+share/examples/Pmw/PanedWidget.py
+share/examples/Pmw/PanedWidget.pyc
+share/examples/Pmw/PanedWidget.pyo
+share/examples/Pmw/PromptDialog.py
+share/examples/Pmw/PromptDialog.pyc
+share/examples/Pmw/PromptDialog.pyo
+share/examples/Pmw/RadioSelect.py
+share/examples/Pmw/RadioSelect.pyc
+share/examples/Pmw/RadioSelect.pyo
+share/examples/Pmw/Resources.py
+share/examples/Pmw/Resources.pyc
+share/examples/Pmw/Resources.pyo
+share/examples/Pmw/Resources_Pmw.py
+share/examples/Pmw/Resources_Pmw.pyc
+share/examples/Pmw/Resources_Pmw.pyo
+share/examples/Pmw/ScrolledField.py
+share/examples/Pmw/ScrolledField.pyc
+share/examples/Pmw/ScrolledField.pyo
+share/examples/Pmw/ScrolledListBox.py
+share/examples/Pmw/ScrolledListBox.pyc
+share/examples/Pmw/ScrolledListBox.pyo
+share/examples/Pmw/ScrolledText.py
+share/examples/Pmw/ScrolledText.pyc
+share/examples/Pmw/ScrolledText.pyo
+share/examples/Pmw/SelectionDialog.py
+share/examples/Pmw/SelectionDialog.pyc
+share/examples/Pmw/SelectionDialog.pyo
+share/examples/Pmw/SpeedTest.py
+share/examples/Pmw/SpeedTest.pyc
+share/examples/Pmw/SpeedTest.pyo
+share/examples/Pmw/TextDialog.py
+share/examples/Pmw/TextDialog.pyc
+share/examples/Pmw/TextDialog.pyo
+share/examples/Pmw/TextDisplay.py
+share/examples/Pmw/TextDisplay.pyc
+share/examples/Pmw/TextDisplay.pyo
+share/examples/Pmw/ScrolledCanvas.py
+share/examples/Pmw/ScrolledCanvas.pyc
+share/examples/Pmw/ScrolledCanvas.pyo
+share/examples/Pmw/NoteBookS.py
+share/examples/Pmw/NoteBookS.pyc
+share/examples/Pmw/NoteBookS.pyo
+share/examples/Pmw/FontText.py
+share/examples/Pmw/FontText.pyc
+share/examples/Pmw/FontText.pyo
+share/examples/Pmw/WidgetDestroy.py
+share/examples/Pmw/WidgetDestroy.pyc
+share/examples/Pmw/WidgetDestroy.pyo
+share/examples/Pmw/OptionMenu.py
+share/examples/Pmw/OptionMenu.pyc
+share/examples/Pmw/OptionMenu.pyo
+share/examples/Pmw/TimeCounter.py
+share/examples/Pmw/TimeCounter.pyc
+share/examples/Pmw/TimeCounter.pyo
+share/examples/Pmw/ScrolledFrame.py
+share/examples/Pmw/ScrolledFrame.pyc
+share/examples/Pmw/ScrolledFrame.pyo
+share/examples/Pmw/All.py
+share/examples/Pmw/All.pyc
+share/examples/Pmw/All.pyo
+share/examples/Pmw/ComboBox_Dropdown.py
+share/examples/Pmw/ComboBox_Dropdown.pyc
+share/examples/Pmw/ComboBox_Dropdown.pyo
+share/examples/Pmw/EntryField.py
+share/examples/Pmw/EntryField.pyc
+share/examples/Pmw/EntryField.pyo
+share/examples/Pmw/MessageDialog.py
+share/examples/Pmw/MessageDialog.pyc
+share/examples/Pmw/MessageDialog.pyo
+share/examples/Pmw/DemoVersion.py
+share/examples/Pmw/DemoVersion.pyc
+share/examples/Pmw/DemoVersion.pyo
+share/examples/Pmw/SpecialEntry.py
+share/examples/Pmw/SpecialEntry.pyc
+share/examples/Pmw/SpecialEntry.pyo
+share/examples/Pmw/Counter.py
+share/examples/Pmw/Counter.pyc
+share/examples/Pmw/Counter.pyo
+share/examples/Pmw/NestedDialogs.py
+share/examples/Pmw/NestedDialogs.pyc
+share/examples/Pmw/NestedDialogs.pyo
+share/examples/Pmw/Spectrum.py
+share/examples/Pmw/Spectrum.pyc
+share/examples/Pmw/Spectrum.pyo
+@dirrm share/examples/Pmw
+@dirrm share/doc/Pmw
+@dirrm lib/python1.5/site-packages/Pmw/Pmw_0_7/lib
+@dirrm lib/python1.5/site-packages/Pmw/Pmw_0_7
+@dirrm lib/python1.5/site-packages/Pmw