aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gnome-desktop
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
commit951c257ea3655de6e80c26a36c18c69ee8047ea8 (patch)
tree249b59a23d9c6fae8db5e5639385f6273d237705 /x11-toolkits/py-gnome-desktop
parent91926e92b73e3751382216a16044c5d8b24ad126 (diff)
downloadports-951c257ea3655de6e80c26a36c18c69ee8047ea8.tar.gz
ports-951c257ea3655de6e80c26a36c18c69ee8047ea8.zip
Notes
Diffstat (limited to 'x11-toolkits/py-gnome-desktop')
-rw-r--r--x11-toolkits/py-gnome-desktop/Makefile11
-rw-r--r--x11-toolkits/py-gnome-desktop/distinfo6
-rw-r--r--x11-toolkits/py-gnome-desktop/pkg-plist124
3 files changed, 76 insertions, 65 deletions
diff --git a/x11-toolkits/py-gnome-desktop/Makefile b/x11-toolkits/py-gnome-desktop/Makefile
index 9d0178dfad32..331008880b6f 100644
--- a/x11-toolkits/py-gnome-desktop/Makefile
+++ b/x11-toolkits/py-gnome-desktop/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11-toolkits/py-gnome-desktop/Makefile,v 1.50 2006/09/05 01:09:07 ahze Exp $
+# $MCom: ports/x11-toolkits/py-gnome-desktop/Makefile,v 1.58 2007/03/18 05:45:44 marcus Exp $
#
PORTNAME= gnome
-PORTVERSION= 2.16.0
+PORTVERSION= 2.18.0
+PORTREVISION= 1
CATEGORIES= x11-toolkits python gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-python-desktop/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -19,10 +20,12 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A set of Python bindings used by modules in the GNOME Desktop
+BUILD_DEPENDS= bug-buddy:${PORTSDIR}/devel/bug-buddy
LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop \
- totem-plparser.1:${PORTSDIR}/multimedia/totem-gstreamer \
+ totem-plparser.1:${PORTSDIR}/multimedia/totem \
gnome-media-profiles.0:${PORTSDIR}/audio/gnome-media \
gnome-keyring:${PORTSDIR}/security/gnome-keyring
+RUN_DEPENDS= bug-buddy:${PORTSDIR}/devel/bug-buddy
USE_BZIP2= yes
USE_GMAKE= yes
@@ -30,6 +33,7 @@ USE_PYTHON= yes
USE_GNOME= gnomehack libgnomeprintui gnomepanel gnomedesktop \
gtksourceview libwnck nautiluscdburner pygnome2 metacity
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-metacity
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -52,6 +56,7 @@ post-install:
${MKDIR} ${EG_DST_DIR}
${TAR} -C ${EG_SRC_DIR} -cf - . | ${TAR} -C ${EG_DST_DIR} -xf -
${CHOWN} -R ${BINOWN}:${BINGRP} ${EG_DST_DIR}
+ ${CHMOD} -R go-w ${EG_DST_DIR}
.endif
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/py-gnome-desktop/distinfo b/x11-toolkits/py-gnome-desktop/distinfo
index 5bfd6963337b..7a6a8dc4b2cb 100644
--- a/x11-toolkits/py-gnome-desktop/distinfo
+++ b/x11-toolkits/py-gnome-desktop/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-python-desktop-2.16.0.tar.bz2) = ea79fe3e6a65d8380539a9ef6eed963f
-SHA256 (gnome2/gnome-python-desktop-2.16.0.tar.bz2) = 8b2a628e9f4a4827aa51456ab5cdf8839a9fe2522c5cd129aa9b50a712410610
-SIZE (gnome2/gnome-python-desktop-2.16.0.tar.bz2) = 429108
+MD5 (gnome2/gnome-python-desktop-2.18.0.tar.bz2) = ce1b1c095a69c2656177570a2939fabb
+SHA256 (gnome2/gnome-python-desktop-2.18.0.tar.bz2) = 1238ed484620cd29e65695376ebf8a38162b4a94706b956b647e43776820d787
+SIZE (gnome2/gnome-python-desktop-2.18.0.tar.bz2) = 432321
diff --git a/x11-toolkits/py-gnome-desktop/pkg-plist b/x11-toolkits/py-gnome-desktop/pkg-plist
index e7200549d7ea..7fd7db4d9b0a 100644
--- a/x11-toolkits/py-gnome-desktop/pkg-plist
+++ b/x11-toolkits/py-gnome-desktop/pkg-plist
@@ -1,3 +1,6 @@
+%%PYTHON_SITELIBDIR%%/gtk-2.0/bugbuddy.py
+%%PYTHON_SITELIBDIR%%/gtk-2.0/bugbuddy.pyc
+%%PYTHON_SITELIBDIR%%/gtk-2.0/bugbuddy.pyo
%%PYTHON_SITELIBDIR%%/gtk-2.0/gnome/applet.py
%%PYTHON_SITELIBDIR%%/gtk-2.0/gnome/applet.pyc
%%PYTHON_SITELIBDIR%%/gtk-2.0/gnome/applet.pyo
@@ -37,65 +40,67 @@
%%PYTHON_SITELIBDIR%%/gtk-2.0/wnck.la
%%PYTHON_SITELIBDIR%%/gtk-2.0/wnck.so
libdata/pkgconfig/gnome-python-desktop-2.0.pc
-%%DOCSDIR%%/pygnomeprint/class-gnomeprintconfig.html
-%%DOCSDIR%%/pygnomeprint/class-gnomeprintcontext.html
-%%DOCSDIR%%/pygnomeprint/class-gnomeprintfont.html
-%%DOCSDIR%%/pygnomeprint/class-gnomeprintfontface.html
-%%DOCSDIR%%/pygnomeprint/class-gnomeprintglyphlist.html
-%%DOCSDIR%%/pygnomeprint/class-gnomeprintjob.html
-%%DOCSDIR%%/pygnomeprint/gnomeprint-class-reference.html
-%%DOCSDIR%%/pygnomeprint/index.html
-%%DOCSDIR%%/pygnomeprint/index.sgml
-%%DOCSDIR%%/pygnomeprint/pygnomeprint.devhelp
-%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuidialog.html
-%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuifontdialog.html
-%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuifontpreview.html
-%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuifontselection.html
-%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuijobpreview.html
-%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuipaperselector.html
-%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuipreview.html
-%%DOCSDIR%%/pygnomeprintui/gnomeprintui-class-reference.html
-%%DOCSDIR%%/pygnomeprintui/index.html
-%%DOCSDIR%%/pygnomeprintui/index.sgml
-%%DOCSDIR%%/pygnomeprintui/pygnomeprintui.devhelp
-%%DOCSDIR%%/pygtksourceview/class-gtksourcebuffer.html
-%%DOCSDIR%%/pygtksourceview/class-gtksourcelanguage.html
-%%DOCSDIR%%/pygtksourceview/class-gtksourcelanguagesmanager.html
-%%DOCSDIR%%/pygtksourceview/class-gtksourcemarker.html
-%%DOCSDIR%%/pygtksourceview/class-gtksourceprintjob.html
-%%DOCSDIR%%/pygtksourceview/class-gtksourcestylescheme.html
-%%DOCSDIR%%/pygtksourceview/class-gtksourcetag.html
-%%DOCSDIR%%/pygtksourceview/class-gtksourcetagstyle.html
-%%DOCSDIR%%/pygtksourceview/class-gtksourcetagtable.html
-%%DOCSDIR%%/pygtksourceview/class-gtksourceview.html
-%%DOCSDIR%%/pygtksourceview/gtksourcesview-class-reference.html
-%%DOCSDIR%%/pygtksourceview/index.html
-%%DOCSDIR%%/pygtksourceview/index.sgml
-%%DOCSDIR%%/pygtksourceview/pygtksourceview.devhelp
-share/examples/py-gnome/applet/GNOME_PythonAppletSample.server
-share/examples/py-gnome/applet/README
-share/examples/py-gnome/applet/applet.py
-share/examples/py-gnome/gnomeprint/README
-share/examples/py-gnome/gnomeprint/example_01.py
-share/examples/py-gnome/gnomeprint/example_02.py
-share/examples/py-gnome/gnomeprint/example_03.py
-share/examples/py-gnome/gnomeprint/example_04.py
-share/examples/py-gnome/gnomeprint/example_05.py
-share/examples/py-gnome/gnomeprint/example_06.py
-share/examples/py-gnome/gnomeprint/example_08.py
-share/examples/py-gnome/gnomeprint/example_09.py
-share/examples/py-gnome/gnomeprint/example_10.glade
-share/examples/py-gnome/gnomeprint/example_10.py
-share/examples/py-gnome/gnomeprint/example_11.py
-share/examples/py-gnome/gnomeprint/sample-image.png
-share/examples/py-gnome/gnomeprint/test-print.py
-share/examples/py-gnome/gtksourceview/test-widget.py
-share/examples/py-gnome/keyring.py
-share/examples/py-gnome/mediaprofiles/profiles.py
-share/examples/py-gnome/nautilusburn/blank_disc.py
-share/examples/py-gnome/nautilusburn/drive_selection.py
-share/examples/py-gnome/nautilusburn/write_iso.py
-share/examples/py-gnome/rsvg/rsvg-cairo.py
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/class-gnomeprintconfig.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/class-gnomeprintcontext.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/class-gnomeprintfont.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/class-gnomeprintfontface.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/class-gnomeprintglyphlist.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/class-gnomeprintjob.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/gnomeprint-class-reference.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/index.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/index.sgml
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprint/pygnomeprint.devhelp
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuidialog.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuifontdialog.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuifontpreview.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuifontselection.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuijobpreview.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuipaperselector.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/class-gnomeprintuipreview.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/gnomeprintui-class-reference.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/index.html
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/index.sgml
+%%PORTDOCS%%%%DOCSDIR%%/pygnomeprintui/pygnomeprintui.devhelp
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourcebuffer.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourcelanguage.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourcelanguagesmanager.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourcemarker.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourceprintjob.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourcestylescheme.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourcetag.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourcetagstyle.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourcetagtable.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/class-gtksourceview.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/gtksourcesview-class-reference.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/index.html
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/index.sgml
+%%PORTDOCS%%%%DOCSDIR%%/pygtksourceview/pygtksourceview.devhelp
+%%PORTDOCS%%share/examples/py-gnome/applet/GNOME_PythonAppletSample.server
+%%PORTDOCS%%share/examples/py-gnome/applet/README
+%%PORTDOCS%%share/examples/py-gnome/applet/applet.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/README
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_01.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_02.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_03.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_04.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_05.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_06.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_08.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_09.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_10.glade
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_10.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/example_11.py
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/sample-image.png
+%%PORTDOCS%%share/examples/py-gnome/gnomeprint/test-print.py
+%%PORTDOCS%%share/examples/py-gnome/gtksourceview/test-widget.py
+%%PORTDOCS%%share/examples/py-gnome/keyring-async.py
+%%PORTDOCS%%share/examples/py-gnome/keyring.py
+%%PORTDOCS%%share/examples/py-gnome/mediaprofiles/profiles.py
+%%PORTDOCS%%share/examples/py-gnome/nautilusburn/blank_disc.py
+%%PORTDOCS%%share/examples/py-gnome/nautilusburn/drive_selection.py
+%%PORTDOCS%%share/examples/py-gnome/nautilusburn/write_iso.py
+%%PORTDOCS%%share/examples/py-gnome/rsvg/rsvg-cairo.py
+%%PORTDOCS%%share/examples/py-gnome/wnck_example.py
share/pygtk/2.0/defs/_gnomedesktop.defs
share/pygtk/2.0/defs/applet.defs
share/pygtk/2.0/defs/art.defs
@@ -113,6 +118,7 @@ share/pygtk/2.0/defs/wnck.defs
%%PORTDOCS%%@dirrm share/examples/py-gnome/gtksourceview
%%PORTDOCS%%@dirrm share/examples/py-gnome/gnomeprint
%%PORTDOCS%%@dirrm share/examples/py-gnome/applet
+%%PORTDOCS%%@dirrmtry share/examples/py-gnome
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pygtksourceview
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pygnomeprintui
%%PORTDOCS%%@dirrm %%DOCSDIR%%/pygnomeprint