aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gnome2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:27:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:27:11 +0000
commit3d675decde9361177503ddfccda1f1752d3c71a0 (patch)
tree0245c0a47272b4188dcdb3cf7a6626fd923753f1 /x11-toolkits/py-gnome2
parent658c3a1f53f61ceb23f1c62d355011fadeadee3e (diff)
downloadports-3d675decde9361177503ddfccda1f1752d3c71a0.tar.gz
ports-3d675decde9361177503ddfccda1f1752d3c71a0.zip
Notes
Diffstat (limited to 'x11-toolkits/py-gnome2')
-rw-r--r--x11-toolkits/py-gnome2/Makefile18
-rw-r--r--x11-toolkits/py-gnome2/distinfo4
-rw-r--r--x11-toolkits/py-gnome2/files/extra-patch-gnomevfs_Makefile.in11
-rw-r--r--x11-toolkits/py-gnome2/files/patch-gnomevfs_Makefile.in11
-rw-r--r--x11-toolkits/py-gnome2/pkg-plist10
5 files changed, 49 insertions, 5 deletions
diff --git a/x11-toolkits/py-gnome2/Makefile b/x11-toolkits/py-gnome2/Makefile
index a3ae42f4cb60..3f8e8d55430a 100644
--- a/x11-toolkits/py-gnome2/Makefile
+++ b/x11-toolkits/py-gnome2/Makefile
@@ -3,10 +3,11 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/x11-toolkits/py-gnome2/Makefile,v 1.24 2005/10/03 16:28:50 marcus Exp $
#
PORTNAME= gnome
-PORTVERSION= 2.10.0
+PORTVERSION= 2.12.1
CATEGORIES= x11-toolkits python gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-python/${PORTVERSION:C/..$//}
@@ -25,7 +26,8 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_PYTHON= yes
USE_GNOME= gnomehack libgnomeui pygtk2
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -34,6 +36,16 @@ EG_DST_DIR= ${PREFIX}/share/examples/py-gnome
CONFLICTS= py*-gnome-1*
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 503001
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gnomevfs_Makefile.in
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|' \
+ ${WRKSRC}/gnomevfs/Makefile.in
+
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${EG_DST_DIR}
@@ -43,4 +55,4 @@ post-install:
${FIND} ${EG_DST_DIR} -type f -print | ${XARGS} ${CHMOD} 0444
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/py-gnome2/distinfo b/x11-toolkits/py-gnome2/distinfo
index 102515b97634..d4808302c91e 100644
--- a/x11-toolkits/py-gnome2/distinfo
+++ b/x11-toolkits/py-gnome2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-python-2.10.0.tar.bz2) = 018c210bc5e2e9be36791bede9dbdc73
-SIZE (gnome2/gnome-python-2.10.0.tar.bz2) = 359598
+MD5 (gnome2/gnome-python-2.12.1.tar.bz2) = 7f772bd8a209c1f1f42d9e52e12aed5b
+SIZE (gnome2/gnome-python-2.12.1.tar.bz2) = 376463
diff --git a/x11-toolkits/py-gnome2/files/extra-patch-gnomevfs_Makefile.in b/x11-toolkits/py-gnome2/files/extra-patch-gnomevfs_Makefile.in
new file mode 100644
index 000000000000..30912b7f1a09
--- /dev/null
+++ b/x11-toolkits/py-gnome2/files/extra-patch-gnomevfs_Makefile.in
@@ -0,0 +1,11 @@
+--- gnomevfs/Makefile.in.orig Thu Jul 14 03:25:16 2005
++++ gnomevfs/Makefile.in Thu Jul 14 03:25:26 2005
+@@ -278,7 +278,7 @@
+ libpythonmethod_la_CFLAGS = $(GNOME_VFS_MODULE_CFLAGS) -DGNOME_VFS_PYTHON_DIR="\"$(vfsmethoddir)\""
+ libpythonmethod_la_SOURCES = gnome-vfs-python-method.c
+ libpythonmethod_la_LDFLAGS = $(common_ldflags) -export-symbols-regex "vfs_module_(init|shutdown)"
+-libpythonmethod_la_LIBADD = $(GNOME_VFS_MODULE_LIBS) -lpython$(PYTHON_VERSION)
++libpythonmethod_la_LIBADD = $(GNOME_VFS_MODULE_LIBS) -l$(PYTHON_VERSION)
+ all: all-am
+
+ .SUFFIXES:
diff --git a/x11-toolkits/py-gnome2/files/patch-gnomevfs_Makefile.in b/x11-toolkits/py-gnome2/files/patch-gnomevfs_Makefile.in
new file mode 100644
index 000000000000..40844f935796
--- /dev/null
+++ b/x11-toolkits/py-gnome2/files/patch-gnomevfs_Makefile.in
@@ -0,0 +1,11 @@
+--- gnomevfs/Makefile.in.orig Sat Sep 3 15:51:39 2005
++++ gnomevfs/Makefile.in Sat Sep 3 15:52:19 2005
+@@ -276,7 +276,7 @@
+
+ gpincdir = $(includedir)/gnome-python-2.0
+ gpinc_HEADERS = pygnomevfs.h
+-vfsmethoddir = $(libdir)/gnome-vfs-2.0/modules
++vfsmethoddir = %%X11BASE%%/lib/gnome-vfs-2.0/modules
+ @BUILD_PYVFSMODULE_FALSE@vfsmethod_LTLIBRARIES =
+ @BUILD_PYVFSMODULE_TRUE@vfsmethod_LTLIBRARIES = libpythonmethod.la
+ libpythonmethod_la_CFLAGS = $(GNOME_VFS_MODULE_CFLAGS) -DGNOME_VFS_PYTHON_DIR="\"$(vfsmethoddir)\""
diff --git a/x11-toolkits/py-gnome2/pkg-plist b/x11-toolkits/py-gnome2/pkg-plist
index 86007f9e2806..6b32aab4fa47 100644
--- a/x11-toolkits/py-gnome2/pkg-plist
+++ b/x11-toolkits/py-gnome2/pkg-plist
@@ -1,3 +1,4 @@
+include/gnome-python-2.0/pygnomevfs.h
%%PYTHON_SITELIBDIR%%/gtk-2.0/bonobo/__init__.py
%%PYTHON_SITELIBDIR%%/gtk-2.0/bonobo/__init__.pyc
%%PYTHON_SITELIBDIR%%/gtk-2.0/bonobo/__init__.pyo
@@ -25,6 +26,7 @@ libdata/pkgconfig/gnome-python-2.0.pc
%%PORTDOCS%%share/examples/py-gnome/bonobo/echo/README
%%PORTDOCS%%share/examples/py-gnome/bonobo/echo/echo-client.py
%%PORTDOCS%%share/examples/py-gnome/bonobo/unknown.py
+%%PORTDOCS%%share/examples/py-gnome/canvas/canvas-curve.py
%%PORTDOCS%%share/examples/py-gnome/canvas/canvas-example.py
%%PORTDOCS%%share/examples/py-gnome/gconf/basic-gconf-app.py
%%PORTDOCS%%share/examples/py-gnome/gconf/simple-controller.py
@@ -32,6 +34,10 @@ libdata/pkgconfig/gnome-python-2.0.pc
%%PORTDOCS%%share/examples/py-gnome/popt/popt.py
%%PORTDOCS%%share/examples/py-gnome/vfs/async-xfer.py
%%PORTDOCS%%share/examples/py-gnome/vfs/async.py
+%%PORTDOCS%%share/examples/py-gnome/vfs/cancellation.py
+%%PORTDOCS%%share/examples/py-gnome/vfs/pygvfsmethod/README
+%%PORTDOCS%%share/examples/py-gnome/vfs/pygvfsmethod/pyfs.conf
+%%PORTDOCS%%share/examples/py-gnome/vfs/pygvfsmethod/pyfs.py
%%PORTDOCS%%share/examples/py-gnome/vfs/shell.py
%%PORTDOCS%%share/examples/py-gnome/vfs/sync-xfer.py
share/pygtk/2.0/argtypes/bonobo-arg-types.py
@@ -50,6 +56,7 @@ share/pygtk/2.0/defs/gnome-types.defs
share/pygtk/2.0/defs/gnome.defs
share/pygtk/2.0/defs/ui.defs
@dirrm share/pygtk/2.0/argtypes
+%%PORTDOCS%%@dirrm share/examples/py-gnome/vfs/pygvfsmethod
%%PORTDOCS%%@dirrm share/examples/py-gnome/vfs
%%PORTDOCS%%@dirrm share/examples/py-gnome/popt
%%PORTDOCS%%@dirrm share/examples/py-gnome/gconf
@@ -60,3 +67,6 @@ share/pygtk/2.0/defs/ui.defs
%%PORTDOCS%%@dirrm share/examples/py-gnome
@dirrm %%PYTHON_SITELIBDIR%%/gtk-2.0/gnome
@dirrm %%PYTHON_SITELIBDIR%%/gtk-2.0/bonobo
+@dirrm include/gnome-python-2.0
+@cwd %%X11BASE%%
+lib/gnome-vfs-2.0/modules/libpythonmethod.so