aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gnome
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-06-01 16:10:38 +0000
committerAde Lovett <ade@FreeBSD.org>2000-06-01 16:10:38 +0000
commit1ecc592d8c0f766d78b1cd5cd0639a82cba48dd1 (patch)
treef3a64f821d9a3948862b11e80f4879b827fecfc7 /x11-toolkits/py-gnome
parent5df7ac46c165a290e3d709d4080d1f2d65a168d9 (diff)
downloadports-1ecc592d8c0f766d78b1cd5cd0639a82cba48dd1.tar.gz
ports-1ecc592d8c0f766d78b1cd5cd0639a82cba48dd1.zip
Notes
Diffstat (limited to 'x11-toolkits/py-gnome')
-rw-r--r--x11-toolkits/py-gnome/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/x11-toolkits/py-gnome/Makefile b/x11-toolkits/py-gnome/Makefile
index c17d9feaecab..b380c0d856d8 100644
--- a/x11-toolkits/py-gnome/Makefile
+++ b/x11-toolkits/py-gnome/Makefile
@@ -19,13 +19,17 @@ MAINTAINER= nectar@FreeBSD.org
BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python ${PYGTK_DEP}
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- capplet.1:${PORTSDIR}/sysutils/gnomecontrolcenter
+ capplet.4:${PORTSDIR}/sysutils/gnomecontrolcenter
RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python ${PYGTK_DEP}
-GTK_CONFIG= ${X11BASE}/bin/gtk12-config
-GNU_CONFIGURE= yes
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
USE_GMAKE= yes
-CONFIGURE_ENV= GTK_CONFIG=${GTK_CONFIG}
+USE_LIBTOOL= yes
+LIBTOOLFILES= configure pygnome/configure pygtk/configure
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}"
CONFIGURE_ARGS= --with-python=python1.5 \
--with-gnome-config=${X11BASE}/bin/gnome-config