aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gtk2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-11 19:50:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-11 19:50:48 +0000
commit156030da7284e767b20cae7d0cd9116bbac22743 (patch)
tree85766f1d8ca301feaa6df8579f45bc598279bc1d /x11-toolkits/py-gtk2/Makefile
parentc71fcf8f8c3e79d6b84aed0cc0a3d50922aee686 (diff)
downloadports-156030da7284e767b20cae7d0cd9116bbac22743.tar.gz
ports-156030da7284e767b20cae7d0cd9116bbac22743.zip
Notes
Diffstat (limited to 'x11-toolkits/py-gtk2/Makefile')
-rw-r--r--x11-toolkits/py-gtk2/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 5df66d0ee0de..1b1fb14ee3ac 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -6,6 +6,7 @@
PORTNAME= gtk
PORTVERSION= 1.99.13
+PORTREVISION= 1
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/pygtk/1.99
@@ -29,6 +30,19 @@ USE_LIBTOOL= yes
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gtk
+#
+# Use the same way as the Python port to determine if we want
+# threading support.
+#
+LIBC_R!= /sbin/ldconfig -r | grep c_r || true
+.if (${LIBC_R} != "") && !defined(WITHOUT_THREADS)
+CONFIGURE_ARGS+= --enable-thread
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV+= LDFLAGS="${PTHREAD_LIBS} ${LDFLAGS}"
+.else
+CONFIGURE_ARGS+= --disable-thread
+.endif
+
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
pre-build:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL