aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gtk2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:27:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 06:27:38 +0000
commit2abce9b40513c446e8003d12828c398c56e718c9 (patch)
treea298bcb9208c39b819502901864d02b76447fa3f /x11-toolkits/py-gtk2
parent5625df324d0de3712a915505f1e22f6742f861b6 (diff)
downloadports-2abce9b40513c446e8003d12828c398c56e718c9.tar.gz
ports-2abce9b40513c446e8003d12828c398c56e718c9.zip
Notes
Diffstat (limited to 'x11-toolkits/py-gtk2')
-rw-r--r--x11-toolkits/py-gtk2/Makefile11
-rw-r--r--x11-toolkits/py-gtk2/distinfo4
-rw-r--r--x11-toolkits/py-gtk2/pkg-plist121
3 files changed, 66 insertions, 70 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index f89d27afbaf0..8452d99e98b5 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -3,13 +3,14 @@
# Whom: marc@informatik.uni-bremen.de
#
# $FreeBSD$
+# $MCom: ports/x11-toolkits/py-gtk2/Makefile,v 1.29 2005/10/09 19:52:49 marcus Exp $
#
PORTNAME= gtk
-PORTVERSION= 2.6.2
+PORTVERSION= 2.8.2
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/pygtk/2.6
+MASTER_SITE_SUBDIR= sources/pygtk/2.8
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= pygtk-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -17,14 +18,16 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A set of Python bindings for GTK
-RUN_DEPENDS= ${PYNUMERIC}
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/cairo/__init__.py:${PORTSDIR}/graphics/py-cairo
+RUN_DEPENDS= ${PYNUMERIC} \
+ ${PYTHON_SITELIBDIR}/cairo/__init__.py:${PORTSDIR}/graphics/py-cairo
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget libglade2
USE_PYTHON= yes
USE_GETTEXT= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-lintl"
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/x11-toolkits/py-gtk2/distinfo b/x11-toolkits/py-gtk2/distinfo
index 01e6af61059f..fb27d5950450 100644
--- a/x11-toolkits/py-gtk2/distinfo
+++ b/x11-toolkits/py-gtk2/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/pygtk-2.6.2.tar.bz2) = 0d4dca0564fc867a976808d18443f059
-SIZE (gnome2/pygtk-2.6.2.tar.bz2) = 731185
+MD5 (gnome2/pygtk-2.8.2.tar.bz2) = 455b50a79015e46b8bcb0664f6d1ece8
+SIZE (gnome2/pygtk-2.8.2.tar.bz2) = 748763
diff --git a/x11-toolkits/py-gtk2/pkg-plist b/x11-toolkits/py-gtk2/pkg-plist
index 7d139723aff4..dbc0bf03a446 100644
--- a/x11-toolkits/py-gtk2/pkg-plist
+++ b/x11-toolkits/py-gtk2/pkg-plist
@@ -103,6 +103,7 @@ lib/pygtk/2.0/pygtk-demo.pyo
%%PYTHON_SITELIBDIR%%/gtk-2.0/gtk/keysyms.pyc
%%PYTHON_SITELIBDIR%%/gtk-2.0/gtk/keysyms.pyo
%%PYTHON_SITELIBDIR%%/gtk-2.0/pango.so
+%%PYTHON_SITELIBDIR%%/gtk-2.0/pangocairo.so
%%PYTHON_SITELIBDIR%%/pygtk.pth
%%PYTHON_SITELIBDIR%%/pygtk.py
%%PYTHON_SITELIBDIR%%/pygtk.pyc
@@ -143,16 +144,7 @@ libdata/pkgconfig/pygtk-2.0.pc
%%PORTDOCS%%share/examples/py-gtk/ide/return.xpm
%%PORTDOCS%%share/examples/py-gtk/ide/run.xpm
%%PORTDOCS%%share/examples/py-gtk/ide/step.xpm
-%%PORTDOCS%%share/examples/py-gtk/neil/README
-%%PORTDOCS%%share/examples/py-gtk/neil/TAppli.py
-%%PORTDOCS%%share/examples/py-gtk/neil/TAppli2.py
-%%PORTDOCS%%share/examples/py-gtk/neil/TAppli3.py
-%%PORTDOCS%%share/examples/py-gtk/neil/TAppli4.py
-%%PORTDOCS%%share/examples/py-gtk/neil/TAppli5.py
-%%PORTDOCS%%share/examples/py-gtk/neil/bomb.xpm
-%%PORTDOCS%%share/examples/py-gtk/neil/gtk-logo.xpm
-%%PORTDOCS%%share/examples/py-gtk/neil/notebook.py
-%%PORTDOCS%%share/examples/py-gtk/neil/question.xpm
+%%PORTDOCS%%share/examples/py-gtk/pango/pangocairo-simple.py
%%PORTDOCS%%share/examples/py-gtk/pango/utf8-demo.py
%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/__init__.py
%%PORTDOCS%%share/examples/py-gtk/pygtk-demo/demos/appwindow.py
@@ -199,65 +191,66 @@ libdata/pkgconfig/pygtk-2.0.pc
%%PORTDOCS%%share/examples/py-gtk/simple/scribble.py
%%PORTDOCS%%share/examples/py-gtk/simple/simple.py
%%PORTDOCS%%share/examples/py-gtk/simple/tooltip.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/__init__.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/__init__.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/__init__.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/argtypes.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/argtypes.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/argtypes.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/codegen.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/codegen.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/codegen.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/definitions.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/definitions.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/definitions.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/defsparser.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/defsparser.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/defsparser.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/docextract.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/docextract.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/docextract.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/docgen.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/docgen.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/docgen.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/h2def.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/h2def.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/h2def.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/mergedefs.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/mergedefs.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/mergedefs.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/mkskel.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/mkskel.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/mkskel.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/override.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/override.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/override.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/reversewrapper.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/reversewrapper.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/reversewrapper.pyo
-%%PORTDOCS%%share/pygtk/2.0/codegen/scmexpr.py
-%%PORTDOCS%%share/pygtk/2.0/codegen/scmexpr.pyc
-%%PORTDOCS%%share/pygtk/2.0/codegen/scmexpr.pyo
-%%PORTDOCS%%share/pygtk/2.0/defs/atk-types.defs
-%%PORTDOCS%%share/pygtk/2.0/defs/atk.defs
-%%PORTDOCS%%share/pygtk/2.0/defs/gdk-types.defs
-%%PORTDOCS%%share/pygtk/2.0/defs/gdk.defs
-%%PORTDOCS%%share/pygtk/2.0/defs/gtk-extrafuncs.defs
-%%PORTDOCS%%share/pygtk/2.0/defs/gtk-types.defs
-%%PORTDOCS%%share/pygtk/2.0/defs/gtk.defs
-%%PORTDOCS%%share/pygtk/2.0/defs/libglade.defs
-%%PORTDOCS%%share/pygtk/2.0/defs/pango-types.defs
-%%PORTDOCS%%share/pygtk/2.0/defs/pango.defs
-%%PORTDOCS%%@dirrm share/pygtk/2.0/defs
-%%PORTDOCS%%@dirrm share/pygtk/2.0/codegen
-%%PORTDOCS%%@dirrm share/pygtk/2.0
-%%PORTDOCS%%@dirrm share/pygtk
+share/pygtk/2.0/codegen/__init__.py
+share/pygtk/2.0/codegen/__init__.pyc
+share/pygtk/2.0/codegen/__init__.pyo
+share/pygtk/2.0/codegen/argtypes.py
+share/pygtk/2.0/codegen/argtypes.pyc
+share/pygtk/2.0/codegen/argtypes.pyo
+share/pygtk/2.0/codegen/codegen.py
+share/pygtk/2.0/codegen/codegen.pyc
+share/pygtk/2.0/codegen/codegen.pyo
+share/pygtk/2.0/codegen/definitions.py
+share/pygtk/2.0/codegen/definitions.pyc
+share/pygtk/2.0/codegen/definitions.pyo
+share/pygtk/2.0/codegen/defsparser.py
+share/pygtk/2.0/codegen/defsparser.pyc
+share/pygtk/2.0/codegen/defsparser.pyo
+share/pygtk/2.0/codegen/docextract.py
+share/pygtk/2.0/codegen/docextract.pyc
+share/pygtk/2.0/codegen/docextract.pyo
+share/pygtk/2.0/codegen/docgen.py
+share/pygtk/2.0/codegen/docgen.pyc
+share/pygtk/2.0/codegen/docgen.pyo
+share/pygtk/2.0/codegen/h2def.py
+share/pygtk/2.0/codegen/h2def.pyc
+share/pygtk/2.0/codegen/h2def.pyo
+share/pygtk/2.0/codegen/mergedefs.py
+share/pygtk/2.0/codegen/mergedefs.pyc
+share/pygtk/2.0/codegen/mergedefs.pyo
+share/pygtk/2.0/codegen/mkskel.py
+share/pygtk/2.0/codegen/mkskel.pyc
+share/pygtk/2.0/codegen/mkskel.pyo
+share/pygtk/2.0/codegen/override.py
+share/pygtk/2.0/codegen/override.pyc
+share/pygtk/2.0/codegen/override.pyo
+share/pygtk/2.0/codegen/reversewrapper.py
+share/pygtk/2.0/codegen/reversewrapper.pyc
+share/pygtk/2.0/codegen/reversewrapper.pyo
+share/pygtk/2.0/codegen/scmexpr.py
+share/pygtk/2.0/codegen/scmexpr.pyc
+share/pygtk/2.0/codegen/scmexpr.pyo
+share/pygtk/2.0/defs/atk-types.defs
+share/pygtk/2.0/defs/atk.defs
+share/pygtk/2.0/defs/gdk-types.defs
+share/pygtk/2.0/defs/gdk.defs
+share/pygtk/2.0/defs/gtk-extrafuncs.defs
+share/pygtk/2.0/defs/gtk-types.defs
+share/pygtk/2.0/defs/gtk.defs
+share/pygtk/2.0/defs/libglade.defs
+share/pygtk/2.0/defs/pango-types.defs
+share/pygtk/2.0/defs/pango.defs
+share/pygtk/2.0/defs/pangocairo.defs
+share/pygtk/2.0/defs/pangocairo.override
+@dirrm share/pygtk/2.0/defs
+@dirrm share/pygtk/2.0/codegen
+@dirrm share/pygtk/2.0
+@dirrm share/pygtk
%%PORTDOCS%%@dirrm share/examples/py-gtk/simple
%%PORTDOCS%%@dirrm share/examples/py-gtk/pygtk-demo/demos/images
%%PORTDOCS%%@dirrm share/examples/py-gtk/pygtk-demo/demos
%%PORTDOCS%%@dirrm share/examples/py-gtk/pygtk-demo
%%PORTDOCS%%@dirrm share/examples/py-gtk/pango
-%%PORTDOCS%%@dirrm share/examples/py-gtk/neil
%%PORTDOCS%%@dirrm share/examples/py-gtk/ide
%%PORTDOCS%%@dirrm share/examples/py-gtk/gtk
%%PORTDOCS%%@dirrm share/examples/py-gtk/gobject