aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-kde
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-23 05:11:52 +0000
committerWill Andrews <will@FreeBSD.org>2000-04-23 05:11:52 +0000
commit7261ca08628e61bc8e38881d9a2c1e8d059e1e17 (patch)
tree09fba121585d6d39757d13940a9b80489294c2b8 /x11-toolkits/py-kde
parentd0efc5b86b39bafb00f9b4b1ba580fa730aaca3f (diff)
downloadports-7261ca08628e61bc8e38881d9a2c1e8d059e1e17.tar.gz
ports-7261ca08628e61bc8e38881d9a2c1e8d059e1e17.zip
Notes
Diffstat (limited to 'x11-toolkits/py-kde')
-rw-r--r--x11-toolkits/py-kde/Makefile25
-rw-r--r--x11-toolkits/py-kde/distinfo1
-rw-r--r--x11-toolkits/py-kde/pkg-comment1
-rw-r--r--x11-toolkits/py-kde/pkg-descr2
-rw-r--r--x11-toolkits/py-kde/pkg-plist20
5 files changed, 49 insertions, 0 deletions
diff --git a/x11-toolkits/py-kde/Makefile b/x11-toolkits/py-kde/Makefile
new file mode 100644
index 000000000000..c47b00326495
--- /dev/null
+++ b/x11-toolkits/py-kde/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: PyKDE
+# Version required: 0.9
+# Date created: Sun Oct 17 00:24:28 PDT 1999
+# Whom: adsharma@sharmas.dhs.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= py-kde
+PORTVERSION= 0.11.1
+CATEGORIES= x11-toolkits kde python
+MASTER_SITES= http://www.river-bank.demon.co.uk/software/
+DISTNAME= PyKDE-${PORTVERSION}
+
+MAINTAINER= adsharma@sharmas.dhs.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/python1.5/qt.py:${PORTSDIR}/x11-toolkits/py-qt
+
+USE_LIBTOOL= yes
+USE_QT= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/X11/qt
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-kde/distinfo b/x11-toolkits/py-kde/distinfo
new file mode 100644
index 000000000000..283a25744185
--- /dev/null
+++ b/x11-toolkits/py-kde/distinfo
@@ -0,0 +1 @@
+MD5 (PyKDE-0.11.1.tar.gz) = 0110b211d723db525ebb4e4ea9e0d443
diff --git a/x11-toolkits/py-kde/pkg-comment b/x11-toolkits/py-kde/pkg-comment
new file mode 100644
index 000000000000..b7dced59276b
--- /dev/null
+++ b/x11-toolkits/py-kde/pkg-comment
@@ -0,0 +1 @@
+Python Bindings for KDE
diff --git a/x11-toolkits/py-kde/pkg-descr b/x11-toolkits/py-kde/pkg-descr
new file mode 100644
index 000000000000..705b05322cc7
--- /dev/null
+++ b/x11-toolkits/py-kde/pkg-descr
@@ -0,0 +1,2 @@
+Python Bindings for KDE
+http://www.river-bank.demon.co.uk/software/
diff --git a/x11-toolkits/py-kde/pkg-plist b/x11-toolkits/py-kde/pkg-plist
new file mode 100644
index 000000000000..3ce8785c4bcd
--- /dev/null
+++ b/x11-toolkits/py-kde/pkg-plist
@@ -0,0 +1,20 @@
+lib/python1.5/lib-dynload/libkdecorecmodule-0.11.1.so
+lib/python1.5/lib-dynload/libkdeuicmodule-0.11.1.so
+lib/python1.5/lib-dynload/libkhtmlwcmodule-0.11.1.so
+lib/python1.5/lib-dynload/libkfmcmodule-0.11.1.so
+lib/python1.5/lib-dynload/libkfilecmodule-0.11.1.so
+lib/python1.5/lib-dynload/libkspellcmodule-0.11.1.so
+@exec /sbin/ldconfig -m %D/lib
+@unexec /sbin/ldconfig -R
+lib/python1.5/kdecore.py
+lib/python1.5/kdecore.pyc
+lib/python1.5/kdeui.py
+lib/python1.5/kdeui.pyc
+lib/python1.5/khtmlw.py
+lib/python1.5/khtmlw.pyc
+lib/python1.5/kfm.py
+lib/python1.5/kfm.pyc
+lib/python1.5/kfile.py
+lib/python1.5/kfile.pyc
+lib/python1.5/kspell.py
+lib/python1.5/kspell.pyc