aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-kde
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-06 16:52:22 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-06 16:52:22 +0000
commitf35ec7277cd648283a3550be810663598a153f7e (patch)
treed95bd527cd68601035e167f8adfde9b467f5598d /x11-toolkits/py-kde
parent4c1648eac3599041a69a86f5a60b90986dd98449 (diff)
downloadports-f35ec7277cd648283a3550be810663598a153f7e.tar.gz
ports-f35ec7277cd648283a3550be810663598a153f7e.zip
Notes
Diffstat (limited to 'x11-toolkits/py-kde')
-rw-r--r--x11-toolkits/py-kde/Makefile59
-rw-r--r--x11-toolkits/py-kde/distinfo6
-rw-r--r--x11-toolkits/py-kde/files/patch-build.py11
-rw-r--r--x11-toolkits/py-kde/files/patch-configure.py11
-rw-r--r--x11-toolkits/py-kde/pkg-descr2
-rw-r--r--x11-toolkits/py-kde/pkg-plist628
6 files changed, 587 insertions, 130 deletions
diff --git a/x11-toolkits/py-kde/Makefile b/x11-toolkits/py-kde/Makefile
index 404356392c16..eab065695eaa 100644
--- a/x11-toolkits/py-kde/Makefile
+++ b/x11-toolkits/py-kde/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= kde
-PORTVERSION= 3.3.2
-PORTREVISION= 2
+PORTVERSION= 3.11.r1
CATEGORIES= x11-toolkits kde python
MASTER_SITES= http://www.river-bank.demon.co.uk/download/PyKDE2/ \
http://www.river-bank.demon.co.uk/download/PyQt/:qt
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= PyKDE-${PORTVERSION}-3
+DISTNAME= PyKDE-3.11rc1
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} PyQt-x11-gpl-${PYQTVERSION}${EXTRACT_SUFX}:qt
MAINTAINER= ports@FreeBSD.org
@@ -20,49 +19,43 @@ COMMENT= Python Bindings for KDE
BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
-BROKEN= "Checksum mismatch; will be removed after Feb 2"
-
-WRKSRC= ${WRKDIR}/PyKDE-${PORTVERSION}
-
USE_PYTHON= yes
USE_KDELIBS_VER=3
USE_REINPLACE= yes
-PYQTVERSION= 3.4
+PYQTVERSION= 3.11
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGBASE}
-ALL_TARGET= all install
+NO_FILTER_SHLIBS= yes
-MODULES= dcop kdecore kdesu kdefx kdeui kio kfile kparts khtml kjs kspell kdeprint
+.include <bsd.port.pre.mk>
-PLIST_SUB+= PKGBASE=${PKGBASE}
-
-NO_FILTER_SHLIBS= yes
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
post-patch:
@${REINPLACE_CMD} -e 's#/usr/bin/python#${PYTHON_CMD}#' ${WRKSRC}/postproc
do-configure:
- @${MKDIR} ${WRKDIR}/modules
- @( cd ${WRKSRC} && env KDEDIR=${PREFIX} ${PYTHON_CMD} build.py -c \
- -e ${PREFIX}/include/sip -q ${X11BASE} \
- -v ${WRKDIR}/PyQt-x11-gpl-3.4/sip -d ${WRKDIR}/modules )
- @${REINPLACE_CMD} -e 's#LIBS *= $$(SUBLIBS)#LIBS = $$(SUBLIBS) -L${WRKDIR}/modules -Wl,-rpath,${PYTHONPREFIX_SITELIBDIR}#' ${WRKSRC}/*/Makefile
- @${REINPLACE_CMD} -e 's#atoll (s)#strtoll (s, NULL, 10)#' ${WRKSRC}/kio/kiohuge.cpp
-
-pre-build:
-.for module in ${MODULES}
- ( cd ${WRKSRC}/${module} && ${MAKE} ${ALL_TARGET} )
-.endfor
+ @( cd ${WRKSRC} && ${PYTHON_CMD} configure.py -c \
+ -k ${LOCALBASE} \
+ -v ${PREFIX}/share/sip \
+ -d ${PYTHONPREFIX_SITELIBDIR} )
pre-install:
- @(${ECHO} "#!${PYTHON_CMD}"; ${CAT} ${WRKSRC}/kdepyuic.py) > ${WRKSRC}/kdepyuic
+ @${REINPLACE_CMD} -e "s,/usr/bin/env python,${PYTHON_CMD}," \
+ ${WRKSRC}/contrib/kdepyuic
-do-install:
- @( cd ${WRKDIR}/modules/ && ${TAR} -cf - . ) | \
- ( cd ${PYTHONPREFIX_SITELIBDIR} && ${TAR} xf - )
- @${MKDIR} ${PREFIX}/share/examples/${PKGBASE}
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
@( cd ${WRKSRC}/examples && ${TAR} -cf - . ) | \
- ( cd ${PREFIX}/share/examples/${PKGBASE} && ${TAR} -xf - )
- @${INSTALL_SCRIPT} ${WRKSRC}/kdepyuic ${PREFIX}/bin
-
-.include <bsd.port.mk>
+ ( cd ${EXAMPLESDIR} && ${TAR} -xf - )
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${EXAMPLESDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${EXAMPLESDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.endif
+ @${INSTALL_SCRIPT} ${WRKSRC}/contrib/kdepyuic ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/py-kde/distinfo b/x11-toolkits/py-kde/distinfo
index b55f6f3a889e..0f7c6bf350e2 100644
--- a/x11-toolkits/py-kde/distinfo
+++ b/x11-toolkits/py-kde/distinfo
@@ -1,2 +1,4 @@
-MD5 (PyKDE-3.3.2-3.tar.gz) = 1df179c05b7d296e88e8f04d9a384522
-MD5 (PyQt-x11-gpl-3.4.tar.gz) = 1a61c55ad716f20f52883740c578c352
+MD5 (PyKDE-3.11rc1.tar.gz) = ad113efa838c79f262212d1795485f22
+SIZE (PyKDE-3.11rc1.tar.gz) = 1019499
+MD5 (PyQt-x11-gpl-3.11.tar.gz) = 78d0ef29f57d7efd1d87f9a24fc25f1e
+SIZE (PyQt-x11-gpl-3.11.tar.gz) = 757652
diff --git a/x11-toolkits/py-kde/files/patch-build.py b/x11-toolkits/py-kde/files/patch-build.py
deleted file mode 100644
index 7fc169cb89a7..000000000000
--- a/x11-toolkits/py-kde/files/patch-build.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- build.py.orig Tue Sep 17 15:40:30 2002
-+++ build.py Tue Sep 17 15:40:48 2002
-@@ -805,7 +805,7 @@
- proPatches["DEFINES"] = [re.compile("@BL_DEFINES@",re.M), defines]
-
- checkQtLibrary()
-- checkThreading ()
-+ #checkThreading ()
- checkKDELibrary()
- checkPyQt ()
-
diff --git a/x11-toolkits/py-kde/files/patch-configure.py b/x11-toolkits/py-kde/files/patch-configure.py
new file mode 100644
index 000000000000..eaa1aa938e71
--- /dev/null
+++ b/x11-toolkits/py-kde/files/patch-configure.py
@@ -0,0 +1,11 @@
+--- configure.py.orig Sat May 8 11:09:53 2004
++++ configure.py Wed May 26 19:47:16 2004
+@@ -700,7 +700,7 @@
+ opt_concat = 1
+
+ elif opt == "-d":
+- opt_pyqtmoddir = arg
++ opt_pykdemoddir = arg
+ elif opt == "-g":
+ opt_releasegil = 1
+
diff --git a/x11-toolkits/py-kde/pkg-descr b/x11-toolkits/py-kde/pkg-descr
index 10851d25bfc3..7d8285fa55a1 100644
--- a/x11-toolkits/py-kde/pkg-descr
+++ b/x11-toolkits/py-kde/pkg-descr
@@ -1,3 +1,3 @@
Python Bindings for KDE.
-WWW: http://www.thekompany.com/projects/pykde/
+WWW: http://www.riverbankcomputing.co.uk/pykde/index.php
diff --git a/x11-toolkits/py-kde/pkg-plist b/x11-toolkits/py-kde/pkg-plist
index 4a8c9d836b30..88aaff017572 100644
--- a/x11-toolkits/py-kde/pkg-plist
+++ b/x11-toolkits/py-kde/pkg-plist
@@ -1,84 +1,546 @@
bin/kdepyuic
-lib/%%PYTHON_VERSION%%/site-packages/dcop.py
-lib/%%PYTHON_VERSION%%/site-packages/dcop.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kdecore.py
-lib/%%PYTHON_VERSION%%/site-packages/kdecore.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kdefx.py
-lib/%%PYTHON_VERSION%%/site-packages/kdefx.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kdeprint.py
-lib/%%PYTHON_VERSION%%/site-packages/kdeprint.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kdesu.py
-lib/%%PYTHON_VERSION%%/site-packages/kdesu.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kdeui.py
-lib/%%PYTHON_VERSION%%/site-packages/kdeui.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kfile.py
-lib/%%PYTHON_VERSION%%/site-packages/kfile.pyc
-lib/%%PYTHON_VERSION%%/site-packages/khtml.py
-lib/%%PYTHON_VERSION%%/site-packages/khtml.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kio.py
-lib/%%PYTHON_VERSION%%/site-packages/kio.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kjs.py
-lib/%%PYTHON_VERSION%%/site-packages/kjs.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kparts.py
-lib/%%PYTHON_VERSION%%/site-packages/kparts.pyc
-lib/%%PYTHON_VERSION%%/site-packages/kspell.py
-lib/%%PYTHON_VERSION%%/site-packages/kspell.pyc
-lib/%%PYTHON_VERSION%%/site-packages/libdcopcmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libdcopcmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libdcopcmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libdcopcmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkdecorecmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdecorecmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdecorecmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkdecorecmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkdefxcmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdefxcmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdefxcmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkdefxcmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkdeprintcmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdeprintcmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdeprintcmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkdeprintcmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkdesucmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdesucmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdesucmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkdesucmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkdeuicmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdeuicmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkdeuicmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkdeuicmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkfilecmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkfilecmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkfilecmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkfilecmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkhtmlcmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkhtmlcmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkhtmlcmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkhtmlcmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkiocmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkiocmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkiocmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkiocmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkjscmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkjscmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkjscmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkjscmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkpartscmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkpartscmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkpartscmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkpartscmodule.so
-lib/%%PYTHON_VERSION%%/site-packages/libkspellcmodule.so.1.0.0
-lib/%%PYTHON_VERSION%%/site-packages/libkspellcmodule.so.1.0
-lib/%%PYTHON_VERSION%%/site-packages/libkspellcmodule.so.1
-lib/%%PYTHON_VERSION%%/site-packages/libkspellcmodule.so
-share/examples/%%PKGBASE%%/Makefile.am
-share/examples/%%PKGBASE%%/README
-share/examples/%%PKGBASE%%/aboutkde.png
-share/examples/%%PKGBASE%%/first.py
-share/examples/%%PKGBASE%%/first.ui
-share/examples/%%PKGBASE%%/pyKHTMLPart.py
-share/examples/%%PKGBASE%%/pyParts.py
-share/examples/%%PKGBASE%%/pyParts.rc
-share/examples/%%PKGBASE%%/pykdehome.jpg
-share/examples/%%PKGBASE%%/pykless.py
-share/examples/%%PKGBASE%%/pyklistview.py
+%%PYTHON_SITELIBDIR%%/dcop.so
+%%PYTHON_SITELIBDIR%%/kdecore.so
+%%PYTHON_SITELIBDIR%%/kdefx.so
+%%PYTHON_SITELIBDIR%%/kdeprint.so
+%%PYTHON_SITELIBDIR%%/kdesu.so
+%%PYTHON_SITELIBDIR%%/kdeui.so
+%%PYTHON_SITELIBDIR%%/kfile.so
+%%PYTHON_SITELIBDIR%%/khtml.so
+%%PYTHON_SITELIBDIR%%/kio.so
+%%PYTHON_SITELIBDIR%%/kmdi.so
+%%PYTHON_SITELIBDIR%%/kparts.so
+%%PYTHON_SITELIBDIR%%/kspell.so
+%%PYTHON_SITELIBDIR%%/pykdeconfig.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/aboutkde.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/astron.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/kdeform1.ui
+%%PORTDOCS%%%%EXAMPLESDIR%%/kdeform1.ui.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/kpartgui.dtd
+%%PORTDOCS%%%%EXAMPLESDIR%%/kurldemo.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/kurldemo.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/kurldemo.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/menudemo.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/menudemo.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/menudemo.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/mimetype.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/mimetype.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/mimetype.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/pyKHTMLPart.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/pyKHTMLPart.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/pyKHTMLPart.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/pytestimage.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/qxembed_example.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/qxembedexample.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/qxembedexample.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/qxembedexample.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/qxembedexample.ui
+%%PORTDOCS%%%%EXAMPLESDIR%%/systray.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/systray.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/systray.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/uikmdi.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/uikmdi.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/uikmdi.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/uikmdi.rc
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uidialogs.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uidialogs.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uidialogs.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uimenus.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uimenus.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uimenus.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uimisc.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uimisc.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uimisc.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uiwidgets.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uiwidgets.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uiwidgets.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uixml.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uixml.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/uimodules/uixml.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/uiqxembed.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/uiqxembed.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/uiqxembed.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/uisampler.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/uisampler.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/uisampler.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/xmlmenudemo.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/xmlmenudemo.pyc
+%%PORTDOCS%%%%EXAMPLESDIR%%/xmlmenudemo.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/xmlmenudemoui.rc
+share/sip/dcop/dcopclient.sip
+share/sip/dcop/dcopmod.sip
+share/sip/dcop/dcopmod.sip.in
+share/sip/dcop/dcopobject.sip
+share/sip/dcop/dcopref.sip
+share/sip/dcop/dcopstub.sip
+share/sip/dcop/typedefs.sip
+share/sip/kdecore/fixx11h.sip
+share/sip/kdecore/kaboutdata.sip
+share/sip/kdecore/kaccel.sip
+share/sip/kdecore/kaccelaction.sip
+share/sip/kdecore/kaccelbase.sip
+share/sip/kdecore/kallocator.sip
+share/sip/kdecore/kapplication.sip
+share/sip/kdecore/kasyncio.sip
+share/sip/kdecore/kaudioplayer.sip
+share/sip/kdecore/kbufferedio.sip
+share/sip/kdecore/kcalendarsystem.sip
+share/sip/kdecore/kcalendarsystemfactory.sip
+share/sip/kdecore/kcatalogue.sip
+share/sip/kdecore/kcharsets.sip
+share/sip/kdecore/kclipboard.sip
+share/sip/kdecore/kcmdlineargs.sip
+share/sip/kdecore/kcompletion.sip
+share/sip/kdecore/kconfig.sip
+share/sip/kdecore/kconfigbackend.sip
+share/sip/kdecore/kconfigbase.sip
+share/sip/kdecore/kconfigdata.sip
+share/sip/kdecore/kconfigdialogmanager.sip
+share/sip/kdecore/kconfigskeleton.sip
+share/sip/kdecore/kcrash.sip
+share/sip/kdecore/kdcoppropertyproxy.sip
+share/sip/kdecore/kdebug.sip
+share/sip/kdecore/kdecore-kde310.diff
+share/sip/kdecore/kdecore-kde311.diff
+share/sip/kdecore/kdecore-kde312.diff
+share/sip/kdecore/kdecore-kde313.diff
+share/sip/kdecore/kdecore-kde314.diff
+share/sip/kdecore/kdecore-kde315.diff
+share/sip/kdecore/kdecore-kde320.diff
+share/sip/kdecore/kdecore-kde321.diff
+share/sip/kdecore/kdecore-kde322.diff
+share/sip/kdecore/kdecoremod.sip
+share/sip/kdecore/kdecoremod.sip.in
+share/sip/kdecore/kdesktopfile.sip
+share/sip/kdecore/kdesktopwidget.sip
+share/sip/kdecore/kdestyle.sip
+share/sip/kdecore/kdeversion.sip
+share/sip/kdecore/kglobal.sip
+share/sip/kdecore/kglobalaccel.sip
+share/sip/kdecore/kglobalsettings.sip
+share/sip/kdecore/kiconeffect.sip
+share/sip/kdecore/kiconloader.sip
+share/sip/kdecore/kicontheme.sip
+share/sip/kdecore/kidna.sip
+share/sip/kdecore/kinstance.sip
+share/sip/kdecore/kipc.sip
+share/sip/kdecore/kkeynative.sip
+share/sip/kdecore/kkeyserver_x11.sip
+share/sip/kdecore/klibloader.sip
+share/sip/kdecore/klocale.sip
+share/sip/kdecore/kmacroexpander.sip
+share/sip/kdecore/kmanagerselection.sip
+share/sip/kdecore/kmdcodec.sip
+share/sip/kdecore/kmimesourcefactory.sip
+share/sip/kdecore/kmountpoint.sip
+share/sip/kdecore/kmultipledrag.sip
+share/sip/kdecore/knotifyclient.sip
+share/sip/kdecore/kpalette.sip
+share/sip/kdecore/kpixmapprovider.sip
+share/sip/kdecore/kprocctrl.sip
+share/sip/kdecore/kprocess.sip
+share/sip/kdecore/kprocio.sip
+share/sip/kdecore/kpty.sip
+share/sip/kdecore/krandomsequence.sip
+share/sip/kdecore/kregexp.sip
+share/sip/kdecore/krfcdate.sip
+share/sip/kdecore/krootprop.sip
+share/sip/kdecore/ksavefile.sip
+share/sip/kdecore/ksharedptr.sip
+share/sip/kdecore/kshell.sip
+share/sip/kdecore/kshortcut.sip
+share/sip/kdecore/kshortcutlist.sip
+share/sip/kdecore/ksimpleconfig.sip
+share/sip/kdecore/ksock.sip
+share/sip/kdecore/kstartupinfo.sip
+share/sip/kdecore/kstaticdeleter.sip
+share/sip/kdecore/kstdaccel.sip
+share/sip/kdecore/kstddirs.sip
+share/sip/kdecore/kstringhandler.sip
+share/sip/kdecore/ktempdir.sip
+share/sip/kdecore/ktempfile.sip
+share/sip/kdecore/kuniqueapp.sip
+share/sip/kdecore/kurl.sip
+share/sip/kdecore/kurldrag.sip
+share/sip/kdecore/kuser.sip
+share/sip/kdecore/kvmallocator.sip
+share/sip/kdecore/kwin.sip
+share/sip/kdecore/kwinmodule.sip
+share/sip/kdecore/kxmessages.sip
+share/sip/kdecore/netwm.sip
+share/sip/kdecore/netwm_def.sip
+share/sip/kdefx/kcpuinfo.sip
+share/sip/kdefx/kdefx-kde320.diff
+share/sip/kdefx/kdefx-kde321.diff
+share/sip/kdefx/kdefx-kde322.diff
+share/sip/kdefx/kdefxmod.sip
+share/sip/kdefx/kdefxmod.sip.in
+share/sip/kdefx/kdrawutil.sip
+share/sip/kdefx/kimageeffect.sip
+share/sip/kdefx/kpixmap.sip
+share/sip/kdefx/kpixmapeffect.sip
+share/sip/kdefx/kpixmapsplitter.sip
+share/sip/kdefx/kstyle.sip
+share/sip/kdeprint/driver.sip
+share/sip/kdeprint/kdeprint-kde310.diff
+share/sip/kdeprint/kdeprint-kde311.diff
+share/sip/kdeprint/kdeprint-kde312.diff
+share/sip/kdeprint/kdeprint-kde313.diff
+share/sip/kdeprint/kdeprint-kde314.diff
+share/sip/kdeprint/kdeprint-kde315.diff
+share/sip/kdeprint/kdeprint-kde320.diff
+share/sip/kdeprint/kdeprint-kde321.diff
+share/sip/kdeprint/kdeprint-kde322.diff
+share/sip/kdeprint/kdeprintmod.sip
+share/sip/kdeprint/kdeprintmod.sip.in
+share/sip/kdeprint/kmjob.sip
+share/sip/kdeprint/kmjobmanager.sip
+share/sip/kdeprint/kmmanager.sip
+share/sip/kdeprint/kmobject.sip
+share/sip/kdeprint/kmprinter.sip
+share/sip/kdeprint/kpreloadobject.sip
+share/sip/kdeprint/kprintaction.sip
+share/sip/kdeprint/kprintdialog.sip
+share/sip/kdeprint/kprintdialogpage.sip
+share/sip/kdeprint/kprinter.sip
+share/sip/kdesu/client.sip
+share/sip/kdesu/defaults.sip
+share/sip/kdesu/kcookie.sip
+share/sip/kdesu/kdesu_pty.sip
+share/sip/kdesu/kdesumod.sip
+share/sip/kdesu/kdesumod.sip.in
+share/sip/kdesu/process.sip
+share/sip/kdesu/ssh.sip
+share/sip/kdesu/stub.sip
+share/sip/kdesu/su.sip
+share/sip/kdeui/kaboutapplication.sip
+share/sip/kdeui/kaboutdialog.sip
+share/sip/kdeui/kaboutkde.sip
+share/sip/kdeui/kaccelmanager.sip
+share/sip/kdeui/kaccelmenu.sip
+share/sip/kdeui/kaction.sip
+share/sip/kdeui/kactionclasses.sip
+share/sip/kdeui/kactioncollection.sip
+share/sip/kdeui/kactionshortcutlist.sip
+share/sip/kdeui/kactivelabel.sip
+share/sip/kdeui/kalphapainter.sip
+share/sip/kdeui/kanimwidget.sip
+share/sip/kdeui/karrowbutton.sip
+share/sip/kdeui/kauthicon.sip
+share/sip/kdeui/kbugreport.sip
+share/sip/kdeui/kbuttonbox.sip
+share/sip/kdeui/kcharselect.sip
+share/sip/kdeui/kcmenumngr.sip
+share/sip/kdeui/kcmodule.sip
+share/sip/kdeui/kcolorbtn.sip
+share/sip/kdeui/kcolorcombo.sip
+share/sip/kdeui/kcolordialog.sip
+share/sip/kdeui/kcolordrag.sip
+share/sip/kdeui/kcombobox.sip
+share/sip/kdeui/kcommand.sip
+share/sip/kdeui/kcompletionbox.sip
+share/sip/kdeui/kconfigdialog.sip
+share/sip/kdeui/kcontainer.sip
+share/sip/kdeui/kcursor.sip
+share/sip/kdeui/kdatepicker.sip
+share/sip/kdeui/kdatepik.sip
+share/sip/kdeui/kdatetbl.sip
+share/sip/kdeui/kdatetimewidget.sip
+share/sip/kdeui/kdatewidget.sip
+share/sip/kdeui/kdbtn.sip
+share/sip/kdeui/kdcopactionproxy.sip
+share/sip/kdeui/kdeui-kde310.diff
+share/sip/kdeui/kdeui-kde311.diff
+share/sip/kdeui/kdeui-kde312.diff
+share/sip/kdeui/kdeui-kde313.diff
+share/sip/kdeui/kdeui-kde314.diff
+share/sip/kdeui/kdeui-kde315.diff
+share/sip/kdeui/kdeui-kde320.diff
+share/sip/kdeui/kdeui-kde321.diff
+share/sip/kdeui/kdeui-kde322.diff
+share/sip/kdeui/kdeuimod.sip
+share/sip/kdeui/kdeuimod.sip.in
+share/sip/kdeui/kdialog.sip
+share/sip/kdeui/kdialogbase.sip
+share/sip/kdeui/kdocktabctl.sip
+share/sip/kdeui/kdockwidget.sip
+share/sip/kdeui/kdockwindow.sip
+share/sip/kdeui/kdualcolorbtn.sip
+share/sip/kdeui/kdualcolorbutton.sip
+share/sip/kdeui/keditcl.sip
+share/sip/kdeui/keditlistbox.sip
+share/sip/kdeui/kedittoolbar.sip
+share/sip/kdeui/kfontcombo.sip
+share/sip/kdeui/kfontdialog.sip
+share/sip/kdeui/kfontrequester.sip
+share/sip/kdeui/kguiitem.sip
+share/sip/kdeui/khelpmenu.sip
+share/sip/kdeui/kiconview.sip
+share/sip/kdeui/kinputdialog.sip
+share/sip/kdeui/kjanuswidget.sip
+share/sip/kdeui/kkeybutton.sip
+share/sip/kdeui/kkeydialog.sip
+share/sip/kdeui/kled.sip
+share/sip/kdeui/klineedit.sip
+share/sip/kdeui/klineeditdlg.sip
+share/sip/kdeui/klistbox.sip
+share/sip/kdeui/klistview.sip
+share/sip/kdeui/klistviewlineedit.sip
+share/sip/kdeui/kmainwindow.sip
+share/sip/kdeui/kmainwindowiface.sip
+share/sip/kdeui/kmenubar.sip
+share/sip/kdeui/kmessagebox.sip
+share/sip/kdeui/knuminput.sip
+share/sip/kdeui/knumvalidator.sip
+share/sip/kdeui/kpanelapplet.sip
+share/sip/kdeui/kpanelappmenu.sip
+share/sip/kdeui/kpanelextension.sip
+share/sip/kdeui/kpanelmenu.sip
+share/sip/kdeui/kpassdlg.sip
+share/sip/kdeui/kpassivepopup.sip
+share/sip/kdeui/kpixmapio.sip
+share/sip/kdeui/kpopupmenu.sip
+share/sip/kdeui/kprogress.sip
+share/sip/kdeui/kpushbutton.sip
+share/sip/kdeui/krestrictedline.sip
+share/sip/kdeui/krootpixmap.sip
+share/sip/kdeui/kruler.sip
+share/sip/kdeui/kselect.sip
+share/sip/kdeui/kseparator.sip
+share/sip/kdeui/ksharedpixmap.sip
+share/sip/kdeui/ksplashscreen.sip
+share/sip/kdeui/ksqueezedtextlabel.sip
+share/sip/kdeui/kstatusbar.sip
+share/sip/kdeui/kstdaction.sip
+share/sip/kdeui/kstdguiitem.sip
+share/sip/kdeui/kstringvalidator.sip
+share/sip/kdeui/ksystemtray.sip
+share/sip/kdeui/ktabbar.sip
+share/sip/kdeui/ktabctl.sip
+share/sip/kdeui/ktabwidget.sip
+share/sip/kdeui/ktextbrowser.sip
+share/sip/kdeui/ktextedit.sip
+share/sip/kdeui/kthemebase.sip
+share/sip/kdeui/kthemestyle.sip
+share/sip/kdeui/ktimewidget.sip
+share/sip/kdeui/ktip.sip
+share/sip/kdeui/ktmainwindow.sip
+share/sip/kdeui/ktoolbar.sip
+share/sip/kdeui/ktoolbarbutton.sip
+share/sip/kdeui/ktoolbarradiogroup.sip
+share/sip/kdeui/kurllabel.sip
+share/sip/kdeui/kwindowinfo.sip
+share/sip/kdeui/kwindowlistmenu.sip
+share/sip/kdeui/kwizard.sip
+share/sip/kdeui/kwordwrap.sip
+share/sip/kdeui/kxmlgui.sip
+share/sip/kdeui/kxmlguibuilder.sip
+share/sip/kdeui/kxmlguiclient.sip
+share/sip/kdeui/kxmlguifactory.sip
+share/sip/kdeui/qxembed.sip
+share/sip/kfile/booktoken.sip
+share/sip/kfile/kcombiview.sip
+share/sip/kfile/kcustommenueditor.sip
+share/sip/kfile/kdiroperator.sip
+share/sip/kfile/kdirselectdialog.sip
+share/sip/kfile/kdirsize.sip
+share/sip/kfile/kdiskfreesp.sip
+share/sip/kfile/kencodingfiledialog.sip
+share/sip/kfile/kfile-kde310.diff
+share/sip/kfile/kfile-kde311.diff
+share/sip/kfile/kfile-kde312.diff
+share/sip/kfile/kfile-kde313.diff
+share/sip/kfile/kfile-kde314.diff
+share/sip/kfile/kfile-kde315.diff
+share/sip/kfile/kfile-kde320.diff
+share/sip/kfile/kfile-kde321.diff
+share/sip/kfile/kfile-kde322.diff
+share/sip/kfile/kfile.sip
+share/sip/kfile/kfilebookmark.sip
+share/sip/kfile/kfiledetailview.sip
+share/sip/kfile/kfiledialog.sip
+share/sip/kfile/kfilefiltercombo.sip
+share/sip/kfile/kfileiconview.sip
+share/sip/kfile/kfilemod.sip
+share/sip/kfile/kfilemod.sip.in
+share/sip/kfile/kfilepreview.sip
+share/sip/kfile/kfilereader.sip
+share/sip/kfile/kfilesharedlg.sip
+share/sip/kfile/kfiletreebranch.sip
+share/sip/kfile/kfiletreeview.sip
+share/sip/kfile/kfiletreeviewitem.sip
+share/sip/kfile/kfileview.sip
+share/sip/kfile/kfileviewitem.sip
+share/sip/kfile/kicondialog.sip
+share/sip/kfile/kimagefilepreview.sip
+share/sip/kfile/knotifydialog.sip
+share/sip/kfile/knotifywidgetbase.sip
+share/sip/kfile/kopenwith.sip
+share/sip/kfile/kpreviewwidgetbase.sip
+share/sip/kfile/kpropertiesdialog.sip
+share/sip/kfile/kpropsdlg.sip
+share/sip/kfile/krecentdocument.sip
+share/sip/kfile/kurlbar.sip
+share/sip/kfile/kurlcombobox.sip
+share/sip/kfile/kurlrequester.sip
+share/sip/kfile/kurlrequesterdlg.sip
+share/sip/khtml/css_rule.sip
+share/sip/khtml/css_stylesheet.sip
+share/sip/khtml/css_value.sip
+share/sip/khtml/dom2_events.sip
+share/sip/khtml/dom2_range.sip
+share/sip/khtml/dom2_traversal.sip
+share/sip/khtml/dom2_views.sip
+share/sip/khtml/dom_doc.sip
+share/sip/khtml/dom_element.sip
+share/sip/khtml/dom_exception.sip
+share/sip/khtml/dom_misc.sip
+share/sip/khtml/dom_node.sip
+share/sip/khtml/dom_string.sip
+share/sip/khtml/dom_text.sip
+share/sip/khtml/dom_xml.sip
+share/sip/khtml/html_base.sip
+share/sip/khtml/html_block.sip
+share/sip/khtml/html_document.sip
+share/sip/khtml/html_element.sip
+share/sip/khtml/html_form.sip
+share/sip/khtml/html_head.sip
+share/sip/khtml/html_image.sip
+share/sip/khtml/html_inline.sip
+share/sip/khtml/html_list.sip
+share/sip/khtml/html_misc.sip
+share/sip/khtml/html_object.sip
+share/sip/khtml/html_table.sip
+share/sip/khtml/khtml_part.sip
+share/sip/khtml/khtml_settings.sip
+share/sip/khtml/khtmlmod.sip
+share/sip/khtml/khtmlmod.sip.in
+share/sip/khtml/khtmlview.sip
+share/sip/kio/authinfo.sip
+share/sip/kio/chmodjob.sip
+share/sip/kio/connection.sip
+share/sip/kio/davjob.sip
+share/sip/kio/defaultprogress.sip
+share/sip/kio/global.sip
+share/sip/kio/job.sip
+share/sip/kio/jobclasses.sip
+share/sip/kio/kar.sip
+share/sip/kio/karchive.sip
+share/sip/kio/kautomount.sip
+share/sip/kio/kdatatool.sip
+share/sip/kio/kdcopservicestarter.sip
+share/sip/kio/kdirlister.sip
+share/sip/kio/kdirnotify.sip
+share/sip/kio/kdirwatch.sip
+share/sip/kio/kemailsettings.sip
+share/sip/kio/kfilefilter.sip
+share/sip/kio/kfileitem.sip
+share/sip/kio/kfilemetainfo.sip
+share/sip/kio/kfileshare.sip
+share/sip/kio/kfilterbase.sip
+share/sip/kio/kfilterdev.sip
+share/sip/kio/kimageio.sip
+share/sip/kio/kio-kde310.diff
+share/sip/kio/kio-kde311.diff
+share/sip/kio/kio-kde312.diff
+share/sip/kio/kio-kde313.diff
+share/sip/kio/kio-kde314.diff
+share/sip/kio/kio-kde315.diff
+share/sip/kio/kio-kde320.diff
+share/sip/kio/kio-kde321.diff
+share/sip/kio/kio-kde322.diff
+share/sip/kio/kiomod.sip
+share/sip/kio/kiomod.sip.in
+share/sip/kio/kmimemagic.sip
+share/sip/kio/kmimetype.sip
+share/sip/kio/kpac.sip
+share/sip/kio/kprotocolinfo.sip
+share/sip/kio/kprotocolmanager.sip
+share/sip/kio/krun.sip
+share/sip/kio/kscan.sip
+share/sip/kio/kservice.sip
+share/sip/kio/kservicegroup.sip
+share/sip/kio/kservicetype.sip
+share/sip/kio/kshellcompletion.sip
+share/sip/kio/kshred.sip
+share/sip/kio/ksycoca.sip
+share/sip/kio/ksycocaentry.sip
+share/sip/kio/ksycocafactory.sip
+share/sip/kio/ksycocatype.sip
+share/sip/kio/ktar.sip
+share/sip/kio/ktrader.sip
+share/sip/kio/kurifilter.sip
+share/sip/kio/kurlcompletion.sip
+share/sip/kio/kurlpixmapprovider.sip
+share/sip/kio/kuserprofile.sip
+share/sip/kio/kzip.sip
+share/sip/kio/metainfojob.sip
+share/sip/kio/netaccess.sip
+share/sip/kio/observer.sip
+share/sip/kio/passdlg.sip
+share/sip/kio/paste.sip
+share/sip/kio/previewjob.sip
+share/sip/kio/progressbase.sip
+share/sip/kio/renamedlg.sip
+share/sip/kio/renamedlgplugin.sip
+share/sip/kio/scheduler.sip
+share/sip/kio/sessiondata.sip
+share/sip/kio/skipdlg.sip
+share/sip/kio/slave.sip
+share/sip/kio/slavebase.sip
+share/sip/kio/slaveconfig.sip
+share/sip/kio/slaveinterface.sip
+share/sip/kio/statusbarprogress.sip
+share/sip/kio/tcpslavebase.sip
+share/sip/kio/thumbcreator.sip
+share/sip/kmdi/kmdi-kde322.diff
+share/sip/kmdi/kmdichildarea.sip
+share/sip/kmdi/kmdichildfrm.sip
+share/sip/kmdi/kmdichildfrmcaption.sip
+share/sip/kmdi/kmdichildview.sip
+share/sip/kmdi/kmdidefines.sip
+share/sip/kmdi/kmdimainfrm.sip
+share/sip/kmdi/kmdimod.sip
+share/sip/kmdi/kmdimod.sip.in
+share/sip/kmdi/kmditaskbar.sip
+share/sip/kmdi/kmditoolviewaccessor.sip
+share/sip/kparts/browserextension.sip
+share/sip/kparts/browserinterface.sip
+share/sip/kparts/browserrun.sip
+share/sip/kparts/dockmainwindow.sip
+share/sip/kparts/event.sip
+share/sip/kparts/factory.sip
+share/sip/kparts/genericfactory.sip
+share/sip/kparts/historyprovider.sip
+share/sip/kparts/kparts-kde320.diff
+share/sip/kparts/kparts-kde321.diff
+share/sip/kparts/kparts-kde322.diff
+share/sip/kparts/kpartsmod.sip
+share/sip/kparts/kpartsmod.sip.in
+share/sip/kparts/mainwindow.sip
+share/sip/kparts/part.sip
+share/sip/kparts/partmanager.sip
+share/sip/kparts/plugin.sip
+share/sip/kparts/statusbarextension.sip
+share/sip/kspell/ksconfig.sip
+share/sip/kspell/kspell-kde320.diff
+share/sip/kspell/kspell.sip
+share/sip/kspell/kspelldlg.sip
+share/sip/kspell/kspellmod.sip
+share/sip/kspell/kspellmod.sip.in
+share/sip/kspell/ksyntaxhighlighter.sip
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/uimodules
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm share/sip/dcop
+@dirrm share/sip/kdecore
+@dirrm share/sip/kdefx
+@dirrm share/sip/kdeprint
+@dirrm share/sip/kdesu
+@dirrm share/sip/kdeui
+@dirrm share/sip/kfile
+@dirrm share/sip/khtml
+@dirrm share/sip/kio
+@dirrm share/sip/kmdi
+@dirrm share/sip/kparts
+@dirrm share/sip/kspell