aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-kivy
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-16 22:16:47 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-16 22:16:47 +0000
commit38fdc8b04eec2c314bb8db6a801f16c248f0c742 (patch)
treee30a6be2b0acd7ad1c571e7d95736e74f2cd5621 /x11-toolkits/py-kivy
parent9d46416064dc404f80e12c4fba4546f3aa2ce61a (diff)
x11-toolkits/py-kivy: mark BROKEN after r470010
Error compiling Cython file: ------------------------------------------------------------ ... end = time() Logger.debug("Svg: Loaded {} in {:.2f}s".format(filename, end - start)) finally: fd.close() cdef void reload(self) except *: ^ ------------------------------------------------------------ kivy/graphics/svg.pyx:469:9: Signature not compatible with previous declaration Error compiling Cython file: ------------------------------------------------------------ ... cpdef flag_update(self, int do_parent=?, list _instrs=?) ELSE: cpdef flag_update(self, int do_parent=?) cdef void flag_update_done(self) cdef void set_parent(self, Instruction parent) cdef void reload(self) ^ ------------------------------------------------------------ kivy/graphics/instructions.pxd:36:20: Previous declaration is here building 'kivy.graphics.svg' extension cc -DNDEBUG -O2 -pipe -fstack-protector -fno-strict-aliasing -fPIC -Ikivy/include -I/usr/local/include -Ikivy/include -I/usr/local/include/python2.7 -c kivy/graphics/svg.c -o build/temp.freebsd-11.1-RELEASE-p9-i386-2.7/kivy/graphics/svg.o kivy/graphics/svg.c:1:2: error: Do not use this file, it is the result of a failed Cython compilation. #error Do not use this file, it is the result of a failed Cython compilation. ^ PR: 228235
Notes
Notes: svn path=/head/; revision=470154
Diffstat (limited to 'x11-toolkits/py-kivy')
-rw-r--r--x11-toolkits/py-kivy/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/x11-toolkits/py-kivy/Makefile b/x11-toolkits/py-kivy/Makefile
index bb8f355b3a44..1950b37e7809 100644
--- a/x11-toolkits/py-kivy/Makefile
+++ b/x11-toolkits/py-kivy/Makefile
@@ -13,6 +13,8 @@ COMMENT= Python NUI library for rapid application development
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN= fails to build with cython 0.28
+
BUILD_DEPENDS= git:devel/git \
${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${FLAVOR}
LIB_DEPENDS= libmtdev.so:devel/libmtdev