aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-qt/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-23 05:07:11 +0000
committerWill Andrews <will@FreeBSD.org>2000-04-23 05:07:11 +0000
commitd0efc5b86b39bafb00f9b4b1ba580fa730aaca3f (patch)
treefce82abe1e3cb80b4f9faff03f538b2f0f817b34 /x11-toolkits/py-qt/Makefile
parentf19242cba485e49f8560a40cc285f966d84b2824 (diff)
downloadports-d0efc5b86b39bafb00f9b4b1ba580fa730aaca3f.tar.gz
ports-d0efc5b86b39bafb00f9b4b1ba580fa730aaca3f.zip
Notes
Diffstat (limited to 'x11-toolkits/py-qt/Makefile')
-rw-r--r--x11-toolkits/py-qt/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-toolkits/py-qt/Makefile b/x11-toolkits/py-qt/Makefile
new file mode 100644
index 000000000000..e1e1a4c90c74
--- /dev/null
+++ b/x11-toolkits/py-qt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: PyQt
+# Version required: 0.9
+# Date created: Sun Oct 17 00:24:28 PDT 1999
+# Whom: adsharma@sharmas.dhs.org
+#
+# $FreeBSD$
+
+PORTNAME= py-qt
+PORTVERSION= 0.11.1
+CATEGORIES= x11-toolkits python
+MASTER_SITES= http://www.river-bank.demon.co.uk/software/
+DISTNAME= PyQt-${PORTVERSION}
+
+MAINTAINER= adsharma@sharmas.dhs.org
+
+LIB_DEPENDS= sip.2:${PORTSDIR}/devel/sip
+
+USE_QT= yes
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= LDFLAGS=-lgcc
+CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/X11/qt
+
+.include <bsd.port.mk>