aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-qt4-gui
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-07-23 19:53:11 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-07-23 19:53:11 +0000
commitc3f9087c486683a6de3d8f1db91050bdb8340e45 (patch)
tree4e541e979a7f5bac477f1b27f24bd820268cd256 /x11-toolkits/py-qt4-gui
parent25a105eeedb0ea4d81483bde3499155ebdc93c58 (diff)
downloadports-c3f9087c486683a6de3d8f1db91050bdb8340e45.tar.gz
ports-c3f9087c486683a6de3d8f1db91050bdb8340e45.zip
Notes
Diffstat (limited to 'x11-toolkits/py-qt4-gui')
-rw-r--r--x11-toolkits/py-qt4-gui/Makefile63
-rw-r--r--x11-toolkits/py-qt4-gui/pkg-plist1
2 files changed, 12 insertions, 52 deletions
diff --git a/x11-toolkits/py-qt4-gui/Makefile b/x11-toolkits/py-qt4-gui/Makefile
index ab444e8754b5..cc04047612e6 100644
--- a/x11-toolkits/py-qt4-gui/Makefile
+++ b/x11-toolkits/py-qt4-gui/Makefile
@@ -2,12 +2,8 @@
# $FreeBSD$
PORTNAME= gui
-PORTVERSION= ${PYQT4_VERSION}
PORTEPOCH= 1
CATEGORIES= x11-toolkits devel python
-MASTER_SITES= ${MASTER_SITES_PYQT4}
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
-DISTNAME= ${PYQT4_DISTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for the Qt4 toolkit, QtGui module
@@ -15,59 +11,22 @@ COMMENT= Python bindings for the Qt4 toolkit, QtGui module
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip
RUN_DEPENDS= ${PKGNAMEPREFIX}core>=${PYQT4_VERSION}:${PORTSDIR}/devel/py-qt4-core
-DISTINFO_FILE= ${PYQT4_DISTINFO_FILE}
-HAS_CONFIGURE= yes
-USE_PYTHON= yes
+CONFIGURE_ARGS= --enable QtGui
+PYQT4_DIST= yes
USE_QT4= gui imageformats_run inputmethods_run iconengines_run \
qmake_build moc_build
-OPTIONS_DEFINE= API
+OPTIONS_DEFINE= API DEBUG
OPTIONS_DEFAULT=API
-API_DESC= Install QtGui API for QScintilla2
+OPTIONS_SUB= yes
-PATCHDIR= ${.CURDIR}/../../devel/py-qt4-core/files
-OPTIONSFILE?= ${PORT_DBDIR}/py-qt4-${PORTNAME}/options
-SIPDIR= ${PREFIX}/share/py-sip
-QSCIDIR= ${PREFIX}/share/qt4/qsci
-ARGS= -b ${PREFIX}/bin \
- -d ${PYTHONPREFIX_SITELIBDIR} \
- -p ${PREFIX}/${QT_PLUGINDIR_REL} \
- -q ${QMAKE} \
- --confirm-license \
- --sipdir ${SIPDIR} \
- --enable QtGui \
- CC="${CC}" CXX="${CXX}" LINK="${CXX}" LINK_SHLIB="${CXX}" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
+API_DESC= Install QtGui API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
+DEBUG_CONFIGURE_ON= --debug --trace
-.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
-.include <bsd.port.options.mk>
-
-.if empty(PORT_OPTIONS:MAPI)
-ARGS+= --no-qsci-api
-PLIST_SUB+= API="@comment "
-.else
-LIB_DEPENDS+= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
-ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
-PLIST_SUB+= API=""
-.endif
-
-.if defined(WITH_DEBUG)
-ARGS+= --debug --trace
-.endif
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
- ${PYTHON_CMD} configure.py ${ARGS}
-
-post-configure:
- ${REINPLACE_CMD} -e 's|^CC.*|CC = ${CC}|' \
- -e 's|^CXX.*|CXX = ${CXX}|' \
- -e 's|^LINK.*|LINK = ${CXX}|' \
- -e 's|^CFLAGS|CXXFLAGS|' \
- ${WRKSRC}/qpy/QtGui/Makefile
+BROKEN_sparc64= Does not compile on sparc64
+.include "${.CURDIR}/../../devel/py-qt4/bsd.pyqt.mk"
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-qt4-gui/pkg-plist b/x11-toolkits/py-qt4-gui/pkg-plist
index d84e831c8dd2..6ac895990699 100644
--- a/x11-toolkits/py-qt4-gui/pkg-plist
+++ b/x11-toolkits/py-qt4-gui/pkg-plist
@@ -1,5 +1,6 @@
%%PYTHON_SITELIBDIR%%/PyQt4/QtGui.so
share/py-sip/QtGui/QtGuimod.sip
+share/py-sip/QtGui/opengl_types.sip
share/py-sip/QtGui/qabstractbutton.sip
share/py-sip/QtGui/qabstractitemdelegate.sip
share/py-sip/QtGui/qabstractitemview.sip