aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-tkinter
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-03-30 20:19:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-03-30 20:19:19 +0000
commitd3c45e5f78108702351d2c7476f0701b2ac841f6 (patch)
tree49f6f17051f14f3eb989b1eb55706a0b5d6eca72 /x11-toolkits/py-tkinter
parentc84b851cacb6ad960d31e61142607f2dac417ce6 (diff)
downloadports-d3c45e5f78108702351d2c7476f0701b2ac841f6.tar.gz
ports-d3c45e5f78108702351d2c7476f0701b2ac841f6.zip
Notes
Diffstat (limited to 'x11-toolkits/py-tkinter')
-rw-r--r--x11-toolkits/py-tkinter/Makefile7
-rw-r--r--x11-toolkits/py-tkinter/files/setup.py2
2 files changed, 4 insertions, 5 deletions
diff --git a/x11-toolkits/py-tkinter/Makefile b/x11-toolkits/py-tkinter/Makefile
index c19c3a2f0db1..d3a7d10b52f0 100644
--- a/x11-toolkits/py-tkinter/Makefile
+++ b/x11-toolkits/py-tkinter/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tkinter
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits python
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -17,18 +17,17 @@ DISTFILES= ${PYTHON_DISTFILE}
MAINTAINER= perky@FreeBSD.org
COMMENT= Python bindings to the Tk widget set
-LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
-
DIST_SUBDIR= python
PLIST_FILES= lib/%%PYTHON_VERSION%%/site-packages/_tkinter.so
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= Tkinter
PYDISTUTILS_PKGVERSION= 0.0.0
+USE_TK= 82+
WRKSRC= ${PYTHON_WRKSRC}/Modules
MD5_FILE= ${PORTSDIR}/lang/python/distinfo
post-extract:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}
+ @${SED} -e "s|%%TK_VER%%|${TK_VER}|" ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-tkinter/files/setup.py b/x11-toolkits/py-tkinter/files/setup.py
index a3bd3da94179..2d6100c2ff61 100644
--- a/x11-toolkits/py-tkinter/files/setup.py
+++ b/x11-toolkits/py-tkinter/files/setup.py
@@ -15,7 +15,7 @@ try:
except:
raise SystemExit, "Distutils problem"
-tkversion = "8.4"
+tkversion = "%%TK_VER%%"
prefix = sysconfig.PREFIX
# Python 1.5 doesn't have os.getenv()?
x11base = os.environ['LOCALBASE'] or '/usr/X11R6'