aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-vte
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-03-19 05:14:07 +0000
commit951c257ea3655de6e80c26a36c18c69ee8047ea8 (patch)
tree249b59a23d9c6fae8db5e5639385f6273d237705 /x11-toolkits/py-vte
parent91926e92b73e3751382216a16044c5d8b24ad126 (diff)
downloadports-951c257ea3655de6e80c26a36c18c69ee8047ea8.tar.gz
ports-951c257ea3655de6e80c26a36c18c69ee8047ea8.zip
Notes
Diffstat (limited to 'x11-toolkits/py-vte')
-rw-r--r--x11-toolkits/py-vte/Makefile27
-rw-r--r--x11-toolkits/py-vte/pkg-descr3
-rw-r--r--x11-toolkits/py-vte/pkg-plist3
3 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/py-vte/Makefile b/x11-toolkits/py-vte/Makefile
new file mode 100644
index 000000000000..eb09aa46be14
--- /dev/null
+++ b/x11-toolkits/py-vte/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-vte
+# Date created: 18 February 2007
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/x11-toolkits/py-vte/Makefile,v 1.1 2007/02/18 19:12:57 mezz Exp $
+#
+
+PORTREVISION= 0
+CATEGORIES= x11-toolkits gnome python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python interface for VTE (Terminal widget)
+
+MASTERDIR= ${.CURDIR}/../vte
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnomehack gnometarget vte pygtk2
+USE_PYTHON= yes
+CONFIGURE_ARGS= --enable-python \
+ --disable-freetypetest
+
+.include "${MASTERDIR}/Makefile"
diff --git a/x11-toolkits/py-vte/pkg-descr b/x11-toolkits/py-vte/pkg-descr
new file mode 100644
index 000000000000..c01fbb23df30
--- /dev/null
+++ b/x11-toolkits/py-vte/pkg-descr
@@ -0,0 +1,3 @@
+Python interface for VTE (Terminal widget).
+
+WWW: http://www.gnome.org/
diff --git a/x11-toolkits/py-vte/pkg-plist b/x11-toolkits/py-vte/pkg-plist
new file mode 100644
index 000000000000..d67a8a180e60
--- /dev/null
+++ b/x11-toolkits/py-vte/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/gtk-2.0/vtemodule.a
+%%PYTHON_SITELIBDIR%%/gtk-2.0/vtemodule.la
+%%PYTHON_SITELIBDIR%%/gtk-2.0/vtemodule.so