aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython24/Makefile
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1999-09-19 20:07:04 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1999-09-19 20:07:04 +0000
commit77e5e9119980f0a5e600f0f6d9402d24c063c16f (patch)
tree409cfc975477f33a4886b472dbef03d4c2eacb00 /x11-toolkits/py-wxPython24/Makefile
parent8977b908f4ee0f4cf5d26a3c5b7e9d6ebdba76e1 (diff)
downloadports-77e5e9119980f0a5e600f0f6d9402d24c063c16f.tar.gz
ports-77e5e9119980f0a5e600f0f6d9402d24c063c16f.zip
Notes
Diffstat (limited to 'x11-toolkits/py-wxPython24/Makefile')
-rw-r--r--x11-toolkits/py-wxPython24/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-toolkits/py-wxPython24/Makefile b/x11-toolkits/py-wxPython24/Makefile
new file mode 100644
index 000000000000..daf2799e92e5
--- /dev/null
+++ b/x11-toolkits/py-wxPython24/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: wxPython
+# Version required: 2.1b3
+# Date created: September 18, 1999
+# Whom: nectar@FreeBSD.ORG
+#
+# $FreeBSD$
+#
+
+DISTNAME= wxPython-2.1b3
+PKGNAME= py-wxPython-2.1b3
+CATEGORIES= x11-toolkits python
+MASTER_SITES= http://alldunn.com/wxPython/ \
+ http://www.nectar.com/distfiles/
+
+MAINTAINER= nectar@FreeBSD.ORG
+
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
+LIB_DEPENDS= wx_gtk.1:${PORTSDIR}/x11-toolkits/wxgtk
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+
+USE_GMAKE= YES
+MAKE_ENV= "LN_S=${LN} -s" "INSTALL_DATA=${INSTALL_DATA}"
+ALL_TARGET= default
+INSTALL_TARGET= install-freebsd
+
+TARGETDIR= ${LOCALBASE}/lib/python1.5/site-packages/wxPython
+HELPERLIBDIR= ${LOCALBASE}/lib
+
+do-configure:
+ ${SED} -e "s:%CFLAGS%:${CFLAGS} `gtk12-config --cflags`:" \
+ -e "s:%LFLAGS%:`gtk12-config --libs` -L${WRKSRC}:" \
+ -e "s:%TARGETDIR%:${TARGETDIR}:" \
+ -e "s:%HELPERLIBDIR%:${HELPERLIBDIR}:" \
+ ${FILESDIR}/build.local > ${WRKSRC}/build.local
+ cd ${WRKSRC} && ../distrib/build.py
+
+.include <bsd.port.mk>