aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython24/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-05-13 17:59:41 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-05-13 17:59:41 +0000
commitd145d1a02db8b45c1fe36f3fbe5debc7053c6d63 (patch)
tree39733b2be3d997b2d2534d35fc628a8fb989b721 /x11-toolkits/py-wxPython24/Makefile
parentf4f49ff0b2ecbcd81a3071c75f802b47e174ffc6 (diff)
Notes
Diffstat (limited to 'x11-toolkits/py-wxPython24/Makefile')
-rw-r--r--x11-toolkits/py-wxPython24/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/x11-toolkits/py-wxPython24/Makefile b/x11-toolkits/py-wxPython24/Makefile
index 16eddf63a955..99156af34701 100644
--- a/x11-toolkits/py-wxPython24/Makefile
+++ b/x11-toolkits/py-wxPython24/Makefile
@@ -30,10 +30,13 @@ PYDISTUTILS_NOEGGINFO= yes
USE_WX= 2.4
DEMO_DIR= ${PYTHONPREFIX_SITELIBDIR}/wxPython/demo
+post-extract:
+ @${RM} ${WRKSRC}/demo/dllwidget/test_dll.so
+
post-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/demo
.if !defined(DEBUG_FLAGS)
- @${FIND} ${WRKSRC} -name "*.so" | ${XARGS} strip
+ @${FIND} ${WRKSRC} -name "*.so" | ${XARGS} ${STRIP_CMD}
.endif
post-install:
@@ -50,10 +53,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= Does not build on 64-bit architectures
-.endif
-
CONFIGURE_ARGS+= --enable-gtk2
PYDISTUTILS_BUILDARGS+= WXPORT=gtk2
PYDISTUTILS_INSTALLARGS:= ${PYDISTUTILS_INSTALLARGS} ${PYDISTUTILS_BUILDARGS}