aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython26/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-22 01:41:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-22 01:41:06 +0000
commitc6d24391a2421fdefa457bac9d511aebeba65666 (patch)
tree9e6cecad4c8f277e134b12656ee6340f28b5fe7d /x11-toolkits/py-wxPython26/Makefile
parent062b2a35b0cc261e71bd68e3d53bd3c27d06b51f (diff)
downloadports-c6d24391a2421fdefa457bac9d511aebeba65666.tar.gz
ports-c6d24391a2421fdefa457bac9d511aebeba65666.zip
Notes
Diffstat (limited to 'x11-toolkits/py-wxPython26/Makefile')
-rw-r--r--x11-toolkits/py-wxPython26/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/x11-toolkits/py-wxPython26/Makefile b/x11-toolkits/py-wxPython26/Makefile
index b3cd70289b8a..7adc55b00299 100644
--- a/x11-toolkits/py-wxPython26/Makefile
+++ b/x11-toolkits/py-wxPython26/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= wxPython
-PORTVERSION= 2.4.2.4
-PORTREVISION= 4
+PORTVERSION= 2.6.0.0
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wxpython
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}Src-${PORTVERSION}
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= neal@nelson.name
COMMENT= Python bindings for the wxWidgets/GTK GUI toolkit
+LIB_DEPENDS= wx_gtk2_core-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26 \
+ wx_gtk2_gizmos-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26-contrib
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenGL/__init__.py:${PORTSDIR}/graphics/py-opengl
WRKSRC= ${WRKDIR}/${DISTNAME}/wxPython
@@ -25,12 +26,16 @@ USE_GMAKE= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_BUILDARGS= WX_CONFIG="${WX_CONFIG}"
+PYDISTUTILS_CONFIGUREARGS+= WX_CONFIG="${WX_CONFIG}"
DEMO_DIR= ${PYTHONPREFIX_SITELIBDIR}/wxPython/demo
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PYTHON_SITELIBDIR%%/wx-2.6.0-gtk2-ansi/wx/
+
post-build:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/demo
.if !defined(DEBUG_FLAGS)
- @${FIND} ${WRKSRC} -name "*.so" | ${XARGS} strip
+ @${FIND} ${WRKSRC} -name "*.so" | ${XARGS} ${STRIP_CMD}
.endif
post-install:
@@ -47,8 +52,7 @@ post-install:
.include <bsd.port.pre.mk>
-LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
-WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.4-config
+WX_CONFIG= ${X11BASE}/bin/wxgtk2-2.6-config
CONFIGURE_ARGS+= --enable-gtk2
PYDISTUTILS_BUILDARGS+= WXPORT=gtk2