aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython28/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-28 20:10:54 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-28 20:10:54 +0000
commited63ab2664e40ad060fdfa86036249547e7f44ae (patch)
tree308560a306def81a002ca313020b0af3c71e90c3 /x11-toolkits/py-wxPython28/files
parentcb0a5a6b032712281e0fc5cb79032e7d278740e0 (diff)
downloadports-ed63ab2664e40ad060fdfa86036249547e7f44ae.tar.gz
ports-ed63ab2664e40ad060fdfa86036249547e7f44ae.zip
Notes
Diffstat (limited to 'x11-toolkits/py-wxPython28/files')
-rw-r--r--x11-toolkits/py-wxPython28/files/patch-ac23
-rw-r--r--x11-toolkits/py-wxPython28/files/patch-my_distutils.py20
-rw-r--r--x11-toolkits/py-wxPython28/files/patch-src::gtk::misc2.cpp14
3 files changed, 23 insertions, 34 deletions
diff --git a/x11-toolkits/py-wxPython28/files/patch-ac b/x11-toolkits/py-wxPython28/files/patch-ac
index 3dec6284f128..79ffff04c345 100644
--- a/x11-toolkits/py-wxPython28/files/patch-ac
+++ b/x11-toolkits/py-wxPython28/files/patch-ac
@@ -1,6 +1,9 @@
---- setup.py 2000/12/12 14:56:17 1.1
-+++ setup.py 2000/12/12 15:22:46
-@@ -68,6 +68,19 @@
+
+$FreeBSD$
+
+--- setup.py.orig Tue May 22 19:02:54 2001
++++ setup.py Mon May 28 19:58:15 2001
+@@ -86,6 +86,16 @@
#----------------------------------------------------------------------
@@ -10,9 +13,6 @@
+try: gtk_config = os.environ['GTK_CONFIG']
+except KeyError: gtk_config = 'gtk-config'
+
-+try: wx_config = os.environ['WX_CONFIG']
-+except KeyError: wx_config = 'wx-config'
-+
+try: sys_libs = string.split(os.environ['LIBS'])
+except KeyError: sys_libs = []
+
@@ -20,20 +20,15 @@
# Check for build flags on the command line
#----------------------------------------------------------------------
-@@ -172,12 +185,13 @@
+@@ -229,9 +239,10 @@
]
libdirs = []
libs = []
+ libs.extend(sys_libs)
-- cflags = os.popen('wx-config --cflags', 'r').read()[:-1] + ' ' + \
+ cflags = os.popen(WX_CONFIG + ' --cflags', 'r').read()[:-1] + ' ' + \
- os.popen('gtk-config --cflags', 'r').read()[:-1]
-+ cflags = os.popen(wx_config + ' --cflags', 'r').read()[:-1] + ' ' + \
+ os.popen(gtk_config + ' --cflags', 'r').read()[:-1]
cflags = string.split(cflags)
-- lflags = os.popen('wx-config --libs', 'r').read()[:-1]
-+ lflags = os.popen(wx_config + ' --libs', 'r').read()[:-1]
- lflags = string.split(lflags)
-
-
+ lflags = os.popen(WX_CONFIG + ' --libs', 'r').read()[:-1]
diff --git a/x11-toolkits/py-wxPython28/files/patch-my_distutils.py b/x11-toolkits/py-wxPython28/files/patch-my_distutils.py
deleted file mode 100644
index dce6b0885145..000000000000
--- a/x11-toolkits/py-wxPython28/files/patch-my_distutils.py
+++ /dev/null
@@ -1,20 +0,0 @@
-
-$FreeBSD$
-
---- my_distutils.py 2001/05/28 14:50:41 1.1
-+++ my_distutils.py 2001/05/28 14:51:09
-@@ -122,10 +122,10 @@
-
- from distutils import ccompiler
-
--ccompiler.default_compiler['nt'] = 'my_msvc'
--ccompiler.compiler_class['my_msvc'] = ('my_distutils',
-- 'MyMSVCCompiler',
-- 'My MSVC derived class')
-+#ccompiler.default_compiler['nt'] = 'my_msvc'
-+#ccompiler.compiler_class['my_msvc'] = ('my_distutils',
-+# 'MyMSVCCompiler',
-+# 'My MSVC derived class')
-
-
- # make it look like it is part of the package...
diff --git a/x11-toolkits/py-wxPython28/files/patch-src::gtk::misc2.cpp b/x11-toolkits/py-wxPython28/files/patch-src::gtk::misc2.cpp
new file mode 100644
index 000000000000..484ce2d3096b
--- /dev/null
+++ b/x11-toolkits/py-wxPython28/files/patch-src::gtk::misc2.cpp
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/gtk/misc2.cpp 2001/05/28 18:13:20 1.1
++++ src/gtk/misc2.cpp 2001/05/28 18:13:40
+@@ -221,7 +221,7 @@
+ int GetUPosition() { return -1; }
+ int GetVPosition() { return -1; }
+ int GetMovementThreshold() { return -1; }
+- void SetMovementThreshold(int threshold) ;
++ void SetMovementThreshold(int threshold) { return; };
+
+ bool IsOk(void) { return FALSE; }
+ int GetNumberJoysticks() { return -1; }