aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-wxPython28/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-21 16:08:51 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-21 16:08:51 +0000
commit47088bfcbaba6a44baa875bb13619e8c3b06187b (patch)
tree99e9d8d1a694a1b0f48dd0c2a18dac3f1ef7be74 /x11-toolkits/py-wxPython28/files
parent32daf3b9ed587e7c655ff7f1f3ed2355c5b1b6f2 (diff)
downloadports-47088bfcbaba6a44baa875bb13619e8c3b06187b.tar.gz
ports-47088bfcbaba6a44baa875bb13619e8c3b06187b.zip
Notes
Diffstat (limited to 'x11-toolkits/py-wxPython28/files')
-rw-r--r--x11-toolkits/py-wxPython28/files/build.local17
-rw-r--r--x11-toolkits/py-wxPython28/files/build.local.ogl10
-rw-r--r--x11-toolkits/py-wxPython28/files/build.local.stc16
-rw-r--r--x11-toolkits/py-wxPython28/files/patch-ab15
-rw-r--r--x11-toolkits/py-wxPython28/files/patch-ac39
5 files changed, 39 insertions, 58 deletions
diff --git a/x11-toolkits/py-wxPython28/files/build.local b/x11-toolkits/py-wxPython28/files/build.local
deleted file mode 100644
index 3ac0d3b2b624..000000000000
--- a/x11-toolkits/py-wxPython28/files/build.local
+++ /dev/null
@@ -1,17 +0,0 @@
-WXPSRCDIR = "$(WRKSRC)/src"
-CCC = "$(CXX)"
-OTHERCFLAGS = "$(SYSCFLAGS)"
-OTHERLFLAGS = "$(SYSLFLAGS)"
-TARGETDIR = "$(_TARGETDIR)"
-HELPERLIBDIR= "$(_HELPERLIBDIR)"
-OTHERRULES = OTHERRULES + r"""
-
-install-freebsd: $(TARGETDIR) $(TARGETDIR)/$(TARGET) pycfiles \
- installLib installDemo lib$(HELPERLIB)$(SO)
- $(BSD_INSTALL_DATA) lib$(HELPERLIB)$(SO) \
- $(HELPERLIBDIR)/lib$(HELPERLIB)$(SO).1
- cd $(HELPERLIBDIR) && rm -f lib$(HELPERLIB)$(SO)
- cd $(HELPERLIBDIR) && ${LN_S} lib$(HELPERLIB)$(SO).1 \
- lib$(HELPERLIB)$(SO)
-
-"""
diff --git a/x11-toolkits/py-wxPython28/files/build.local.ogl b/x11-toolkits/py-wxPython28/files/build.local.ogl
deleted file mode 100644
index d70f790435fc..000000000000
--- a/x11-toolkits/py-wxPython28/files/build.local.ogl
+++ /dev/null
@@ -1,10 +0,0 @@
-WXPSRCDIR = "$(WRKSRC)/src"
-CCC = "$(CXX)"
-OTHERLFLAGS = "$(SYSLFLAGS)"
-TARGETDIR = "$(_TARGETDIR)"
-OTHERRULES = OTHERRULES + r"""
-
-install-freebsd: default $(TARGETDIR) $(TARGETDIR)/$(TARGET) pycfiles
- $(BSD_INSTALL_PROGRAM) $(TARGET) $(TARGETDIR)
-
-"""
diff --git a/x11-toolkits/py-wxPython28/files/build.local.stc b/x11-toolkits/py-wxPython28/files/build.local.stc
deleted file mode 100644
index bf6a4c55a1fe..000000000000
--- a/x11-toolkits/py-wxPython28/files/build.local.stc
+++ /dev/null
@@ -1,16 +0,0 @@
-WXPSRCDIR = "$(WRKSRC)/src"
-CCC = "$(CXX)"
-OTHERCFLAGS = '-D__WX__ -DSCI_LEXER ' + \
- '-I$(STCLOC)/contrib/src/stc/scintilla/include ' + \
- '-I$(STCLOC)/contrib/include ' + \
- '-I$(STCLOC)/contrib/src/stc/scintilla/src ' + \
- '-I$(WXPSRCDIR) ' + \
- '$(SYSCFLAGS)'
-OTHERLFLAGS = "$(SYSLFLAGS)"
-TARGETDIR = "$(_TARGETDIR)"
-OTHERRULES = OTHERRULES + r"""
-
-install-freebsd: default $(TARGETDIR) $(TARGETDIR)/$(TARGET) pycfiles
- $(BSD_INSTALL_PROGRAM) $(TARGET) $(TARGETDIR)
-
-"""
diff --git a/x11-toolkits/py-wxPython28/files/patch-ab b/x11-toolkits/py-wxPython28/files/patch-ab
deleted file mode 100644
index 91d04cbfe00a..000000000000
--- a/x11-toolkits/py-wxPython28/files/patch-ab
+++ /dev/null
@@ -1,15 +0,0 @@
---- Makefile.orig Fri Dec 8 16:07:15 2000
-+++ Makefile Fri Dec 8 16:48:34 2000
-@@ -0,0 +1,12 @@
-+SUBDIRS= src contrib/stc contrib/ogl
-+
-+default:
-+ @for dir in $(SUBDIRS); do \
-+ $(MAKE) -C $${dir} default || exit 1; \
-+ done
-+
-+install-freebsd:
-+ @for dir in $(SUBDIRS); do \
-+ $(MAKE) -C $${dir} install-freebsd || exit 1; \
-+ done
-+
diff --git a/x11-toolkits/py-wxPython28/files/patch-ac b/x11-toolkits/py-wxPython28/files/patch-ac
new file mode 100644
index 000000000000..3dec6284f128
--- /dev/null
+++ b/x11-toolkits/py-wxPython28/files/patch-ac
@@ -0,0 +1,39 @@
+--- setup.py 2000/12/12 14:56:17 1.1
++++ setup.py 2000/12/12 15:22:46
+@@ -68,6 +68,19 @@
+
+
+ #----------------------------------------------------------------------
++# Check for some environment variables
++#----------------------------------------------------------------------
++
++try: gtk_config = os.environ['GTK_CONFIG']
++except KeyError: gtk_config = 'gtk-config'
++
++try: wx_config = os.environ['WX_CONFIG']
++except KeyError: wx_config = 'wx-config'
++
++try: sys_libs = string.split(os.environ['LIBS'])
++except KeyError: sys_libs = []
++
++#----------------------------------------------------------------------
+ # Check for build flags on the command line
+ #----------------------------------------------------------------------
+
+@@ -172,12 +185,13 @@
+ ]
+ libdirs = []
+ libs = []
++ libs.extend(sys_libs)
+
+- cflags = os.popen('wx-config --cflags', 'r').read()[:-1] + ' ' + \
+- os.popen('gtk-config --cflags', 'r').read()[:-1]
++ cflags = os.popen(wx_config + ' --cflags', 'r').read()[:-1] + ' ' + \
++ os.popen(gtk_config + ' --cflags', 'r').read()[:-1]
+ cflags = string.split(cflags)
+
+- lflags = os.popen('wx-config --libs', 'r').read()[:-1]
++ lflags = os.popen(wx_config + ' --libs', 'r').read()[:-1]
+ lflags = string.split(lflags)
+
+